linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Florian Fainelli <f.fainelli@gmail.com>
To: matthias.bgg@kernel.org, mpm@selenic.com,
	herbert@gondor.apana.org.au, rjui@broadcom.com,
	sbranden@broadcom.com, f.fainelli@gmail.com
Cc: linux-kernel@vger.kernel.org, Julia.Lawall@inria.fr,
	bcm-kernel-feedback-list@broadcom.com,
	linux-arm-kernel@lists.infradead.org, nsaenzjulienne@suse.de,
	linux-crypto@vger.kernel.org,
	Matthias Brugger <mbrugger@suse.com>
Subject: Re: [PATCH 2/2] hwrng: iproc-rng200: Move enable/disable in separate function
Date: Mon, 14 Dec 2020 09:39:01 -0800	[thread overview]
Message-ID: <55db8315-77b4-da25-9f28-0a0b55cebf3f@gmail.com> (raw)
In-Reply-To: <20201214160454.22769-2-matthias.bgg@kernel.org>

On 12/14/20 8:04 AM, matthias.bgg@kernel.org wrote:
> From: Matthias Brugger <mbrugger@suse.com>
> 
> We are calling the same code for enable and disable the block in various
> parts of the driver. Put that code into a new function to reduce code
> duplication.
> 
> Signed-off-by: Matthias Brugger <mbrugger@suse.com>
> 
> ---
> 
>  drivers/char/hw_random/iproc-rng200.c | 37 ++++++++++++---------------
>  1 file changed, 17 insertions(+), 20 deletions(-)
> 
> diff --git a/drivers/char/hw_random/iproc-rng200.c b/drivers/char/hw_random/iproc-rng200.c
> index e106ce3c0146..3367b26085e8 100644
> --- a/drivers/char/hw_random/iproc-rng200.c
> +++ b/drivers/char/hw_random/iproc-rng200.c
> @@ -53,15 +53,26 @@ struct iproc_rng200_dev {
>  
>  #define to_rng_priv(rng)	container_of(rng, struct iproc_rng200_dev, rng)
>  
> -static void iproc_rng200_restart(void __iomem *rng_base)
> +static void iproc_rng200_enable(void __iomem *rng_base, bool enable)

I would prefer naming the function iproc_rng200_enable_set() to indicate
that it sets the enable to the parameter value, this is just personal
taste, you may discard it.

>  {
>  	uint32_t val;

Since you are refactoring this into a new function, do you mind changing
the variable to u32 to match the kernel code? With that fixed:

Acked-by: Florian Fainelli <f.fainelli@gmail.com>

Thanks!
-- 
Florian

  reply	other threads:[~2020-12-14 17:44 UTC|newest]

Thread overview: 7+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-12-14 16:04 [PATCH 1/2] hwrng: iproc-rng200: Fix disable of the block matthias.bgg
2020-12-14 16:04 ` [PATCH 2/2] hwrng: iproc-rng200: Move enable/disable in separate function matthias.bgg
2020-12-14 17:39   ` Florian Fainelli [this message]
2020-12-14 17:50   ` Scott Branden
2020-12-14 17:36 ` [PATCH 1/2] hwrng: iproc-rng200: Fix disable of the block Florian Fainelli
2020-12-14 17:45 ` Scott Branden
2020-12-18 10:49   ` Matthias Brugger

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=55db8315-77b4-da25-9f28-0a0b55cebf3f@gmail.com \
    --to=f.fainelli@gmail.com \
    --cc=Julia.Lawall@inria.fr \
    --cc=bcm-kernel-feedback-list@broadcom.com \
    --cc=herbert@gondor.apana.org.au \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-crypto@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=matthias.bgg@kernel.org \
    --cc=mbrugger@suse.com \
    --cc=mpm@selenic.com \
    --cc=nsaenzjulienne@suse.de \
    --cc=rjui@broadcom.com \
    --cc=sbranden@broadcom.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).