From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S932517AbcCHPqD (ORCPT ); Tue, 8 Mar 2016 10:46:03 -0500 Received: from hqemgate14.nvidia.com ([216.228.121.143]:9263 "EHLO hqemgate14.nvidia.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1752253AbcCHPpz (ORCPT ); Tue, 8 Mar 2016 10:45:55 -0500 X-PGP-Universal: processed; by hqnvupgp07.nvidia.com on Tue, 08 Mar 2016 07:44:35 -0800 Message-ID: <56DEF0AB.7090807@nvidia.com> Date: Tue, 8 Mar 2016 21:02:59 +0530 From: Laxman Dewangan User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:24.0) Gecko/20100101 Thunderbird/24.4.0 MIME-Version: 1.0 To: Thierry Reding CC: , , , , , , , Subject: Re: [PATCH 2/5] gpio: gpiolib: Print error number if gpio hog failed References: <1457438528-29054-1-git-send-email-ldewangan@nvidia.com> <1457438528-29054-3-git-send-email-ldewangan@nvidia.com> <20160308142217.GB9864@ulmo.nvidia.com> In-Reply-To: <20160308142217.GB9864@ulmo.nvidia.com> X-Originating-IP: [10.19.65.30] X-ClientProxiedBy: DRUKMAIL102.nvidia.com (10.25.59.20) To bgmail102.nvidia.com (10.25.59.11) Content-Type: text/plain; charset="ISO-8859-1"; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tuesday 08 March 2016 07:52 PM, Thierry Reding wrote: > On Tue, Mar 08, 2016 at 05:32:05PM +0530, Laxman Dewangan wrote: > >> Signed-off-by: Laxman Dewangan >> --- >> drivers/gpio/gpiolib.c | 9 +++++---- >> 1 file changed, 5 insertions(+), 4 deletions(-) >> >> diff --git a/drivers/gpio/gpiolib.c b/drivers/gpio/gpiolib.c >> index bc788b9..7575ebb 100644 >> --- a/drivers/gpio/gpiolib.c >> +++ b/drivers/gpio/gpiolib.c >> @@ -2621,15 +2621,16 @@ int gpiod_hog(struct gpio_desc *desc, const char *name, >> >> local_desc = gpiochip_request_own_desc(chip, hwnum, name); >> if (IS_ERR(local_desc)) { >> - pr_err("requesting hog GPIO %s (chip %s, offset %d) failed\n", >> - name, chip->label, hwnum); >> + status = PTR_ERR(local_desc); >> + pr_err("requesting hog GPIO %s, chip %s, offset %d failed %d\n", >> + name, chip->label, hwnum, status); > I find this type of format hard to read. I prefer a semi-colon to > separate the message from the failure reason (i.e. error code). > > Besides that I don't understand why you're dropping the parentheses > around the "chip %s, offset %d", I found that easier on the eye. > > I did to accommodate the 3 extra character ( %d) for string format on that line as it was already near to 80 column. Just did not want to split in multiple lines.