From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S933426AbcCIRRi (ORCPT ); Wed, 9 Mar 2016 12:17:38 -0500 Received: from avon.wwwdotorg.org ([70.85.31.133]:43738 "EHLO avon.wwwdotorg.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1753273AbcCIRRc (ORCPT ); Wed, 9 Mar 2016 12:17:32 -0500 Subject: Re: [PATCH 4/5] gpio: of: Add support to have multiple gpios in gpio-hog To: Laxman Dewangan References: <1457438528-29054-1-git-send-email-ldewangan@nvidia.com> <1457438528-29054-5-git-send-email-ldewangan@nvidia.com> <20160309062849.GB10454@pengutronix.de> <56E02335.6020901@nvidia.com> Cc: Markus Pargmann , linus.walleij@linaro.org, robh+dt@kernel.org, pawel.moll@arm.com, mark.rutland@arm.com, devicetree@vger.kernel.org, linux-kernel@vger.kernel.org, linux-gpio@vger.kernel.org, treding@nvidia.com, Benoit Parrot , Alexandre Courbot From: Stephen Warren Message-ID: <56E05AA9.8000503@wwwdotorg.org> Date: Wed, 9 Mar 2016 10:17:29 -0700 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:38.0) Gecko/20100101 Thunderbird/38.5.1 MIME-Version: 1.0 In-Reply-To: <56E02335.6020901@nvidia.com> Content-Type: text/plain; charset=utf-8; format=flowed Content-Transfer-Encoding: 7bit Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 03/09/2016 06:20 AM, Laxman Dewangan wrote: > > On Wednesday 09 March 2016 11:58 AM, Markus Pargmann wrote: >> * PGP Signed by an unknown key >> >> Hi, >> >> On Tue, Mar 08, 2016 at 05:32:07PM +0530, Laxman Dewangan wrote: >>> The child node for gpio hogs under gpio controller's node >>> provide the mechanism to automatic GPIO request and >>> configuration as part of the gpio-controller's driver >>> probe function. >>> >>> Currently, property "gpio" takes one gpios for such >>> configuration. Add support to have multiple GPIOs in >>> this property so that multiple GPIOs of gpio-controller >>> can be configured by this mechanism with one child node. >> So if I read this correctly you want to have multiple GPIOs with the >> same line name? Why don't you use multiple child nodes with individual >> line names? >> > There is cases on which particular functional configuration needs sets > of GPIO to set. On this case, making sub node for each GPIOs creates > lots of sub-nodes and add complexity on readability, usability and > maintainability. > Example: for my board, I wanted to set GPIO H2 to input and H0 and H1 to > be output high. > Instead of three nodes, I can have two here: > gpio@0,6000d000 { > wlan_input { > gpio-hog; > gpios = ; > input; > }; > > wlan_output { > gpio-hog; > gpios = ; > output-high; > }; > }; > > So here I am grouping the multiple output GPIO together. > > This looks much similar if we have many GPIOs for one type of > configurations. > > Even it looks better if we have something: > gpio@0,6000d000 { > wlan_control { > gpio-hog; > gpios-input = ; > gpios-output-high = TEGRA_GPIO(H, 1) 0>; > }; > }; The problem with that is the description used when acquiring the GPIO is just "wlan_input", "wlan_output", or "wlan_control". There's nothing to indicate what those individual pins do (perhaps one is a reset signal, one is a regulator enable, etc.?) By requiring separate nodes for each GPIO, then the node name can provide a meaningful semantic name/description for each GPIO, which provides much more information. If the approach in this patch is acceptable though, I think you want to update the description of "gpios" (in the GPIO hog definition section) in Documentation/devicetree/bindings/gpio/gpio.txt to mention that multiple GPIO entries are legal. Right now it says that property much contain exactly #gpio-cells, not a multiple of #gpio-cells.