linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Daniel Lezcano <daniel.lezcano@linaro.org>
To: fu.wei@linaro.org, rjw@rjwysocki.net, lenb@kernel.org,
	tglx@linutronix.de, marc.zyngier@arm.com, hanjun.guo@linaro.org
Cc: linux-arm-kernel@lists.infradead.org,
	linaro-acpi@lists.linaro.org, linux-kernel@vger.kernel.org,
	linux-acpi@vger.kernel.org, rruigrok@codeaurora.org,
	harba@codeaurora.org, cov@codeaurora.org, timur@codeaurora.org,
	graeme.gregory@linaro.org, al.stone@linaro.org, jcm@redhat.com,
	wei@redhat.com, arnd@arndb.de, wim@iguana.be,
	catalin.marinas@arm.com, will.deacon@arm.com,
	Suravee.Suthikulpanit@amd.com, leo.duran@amd.com
Subject: Re: [PATCH v5 2/6] clocksource/drivers/arm_arch_timer: Add a new enum for spi type
Date: Mon, 30 May 2016 17:07:16 +0200	[thread overview]
Message-ID: <574C5724.30200@linaro.org> (raw)
In-Reply-To: <1464096633-9309-3-git-send-email-fu.wei@linaro.org>

On 05/24/2016 03:30 PM, fu.wei@linaro.org wrote:
> From: Fu Wei <fu.wei@linaro.org>
>
> This patch add a new enum "spi_nr" and use it in the driver.
> Just for code's readability, no functional change.
>
> Signed-off-by: Fu Wei <fu.wei@linaro.org>
> ---
>   drivers/clocksource/arm_arch_timer.c | 4 ++--
>   include/clocksource/arm_arch_timer.h | 6 ++++++
>   2 files changed, 8 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/clocksource/arm_arch_timer.c b/drivers/clocksource/arm_arch_timer.c
> index 5d7272e..966c574 100644
> --- a/drivers/clocksource/arm_arch_timer.c
> +++ b/drivers/clocksource/arm_arch_timer.c
> @@ -826,9 +826,9 @@ static void __init arch_timer_mem_init(struct device_node *np)
>   	}
>
>   	if (arch_timer_mem_use_virtual)
> -		irq = irq_of_parse_and_map(best_frame, 1);
> +		irq = irq_of_parse_and_map(best_frame, VIRT_SPI);
>   	else
> -		irq = irq_of_parse_and_map(best_frame, 0);
> +		irq = irq_of_parse_and_map(best_frame, PHYS_SPI);
>
>   	if (!irq) {
>   		pr_err("arch_timer: Frame missing %s irq",
> diff --git a/include/clocksource/arm_arch_timer.h b/include/clocksource/arm_arch_timer.h
> index 6f06481..16dcd10 100644
> --- a/include/clocksource/arm_arch_timer.h
> +++ b/include/clocksource/arm_arch_timer.h
> @@ -45,6 +45,12 @@ enum ppi_nr {
>   	MAX_TIMER_PPI
>   };
>
> +enum spi_nr {
> +	PHYS_SPI,
> +	VIRT_SPI,
> +	MAX_TIMER_SPI
> +};

Wouldn't make sense to use the constant below instead of defining new ones ?

>   #define ARCH_TIMER_PHYS_ACCESS		0
>   #define ARCH_TIMER_VIRT_ACCESS		1
>   #define ARCH_TIMER_MEM_PHYS_ACCESS	2
>


-- 
  <http://www.linaro.org/> Linaro.org │ Open source software for ARM SoCs

Follow Linaro:  <http://www.facebook.com/pages/Linaro> Facebook |
<http://twitter.com/#!/linaroorg> Twitter |
<http://www.linaro.org/linaro-blog/> Blog

  reply	other threads:[~2016-05-30 15:07 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-05-24 13:30 [PATCH v5 0/6] acpi, clocksource: add GTDT driver and GTDT support in arm_arch_timer fu.wei
2016-05-24 13:30 ` [PATCH v5 1/6] clocksource/drivers/arm_arch_timer: Move enums and defines to header file fu.wei
2016-05-24 13:30 ` [PATCH v5 2/6] clocksource/drivers/arm_arch_timer: Add a new enum for spi type fu.wei
2016-05-30 15:07   ` Daniel Lezcano [this message]
2016-05-24 13:30 ` [PATCH v5 3/6] clocksource/drivers/arm_arch_timer: Improve printk relevant code fu.wei
2016-05-24 13:30 ` [PATCH v5 4/6] acpi: Add GTDT table parse driver into ACPI driver fu.wei
2016-05-30 22:56   ` Daniel Lezcano
     [not found]     ` <CADyBb7vL1RHa3V8M1bNb-63rZiRZWJt4Kory61+1PA+Ruv59Gg@mail.gmail.com>
2016-06-02 12:51       ` Daniel Lezcano
2016-05-24 13:30 ` [PATCH v5 5/6] clocksource/drivers/arm_arch_timer: Simplify ACPI support code fu.wei
2016-06-01 16:03   ` Timur Tabi
2016-05-24 13:30 ` [PATCH v5 6/6] clocksource/drivers/arm_arch_timer: Add GTDT support for memory-mapped timer fu.wei

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=574C5724.30200@linaro.org \
    --to=daniel.lezcano@linaro.org \
    --cc=Suravee.Suthikulpanit@amd.com \
    --cc=al.stone@linaro.org \
    --cc=arnd@arndb.de \
    --cc=catalin.marinas@arm.com \
    --cc=cov@codeaurora.org \
    --cc=fu.wei@linaro.org \
    --cc=graeme.gregory@linaro.org \
    --cc=hanjun.guo@linaro.org \
    --cc=harba@codeaurora.org \
    --cc=jcm@redhat.com \
    --cc=lenb@kernel.org \
    --cc=leo.duran@amd.com \
    --cc=linaro-acpi@lists.linaro.org \
    --cc=linux-acpi@vger.kernel.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=marc.zyngier@arm.com \
    --cc=rjw@rjwysocki.net \
    --cc=rruigrok@codeaurora.org \
    --cc=tglx@linutronix.de \
    --cc=timur@codeaurora.org \
    --cc=wei@redhat.com \
    --cc=will.deacon@arm.com \
    --cc=wim@iguana.be \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).