linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [GIT PULL] Floppy cleanups for next
@ 2020-03-16 10:47 Denis Efremov
  2020-03-16 15:08 ` Jens Axboe
  0 siblings, 1 reply; 5+ messages in thread
From: Denis Efremov @ 2020-03-16 10:47 UTC (permalink / raw)
  To: Jens Axboe; +Cc: linux-block, Linux-Kernel@Vger. Kernel. Org, Willy Tarreau

Hi Jens,

The following changes since commit 5d50c8f405bf91d9d9a48628fde0f2f4ff069d7b:

  Merge branch 'for-5.7/io_uring' into for-next (2020-03-14 17:20:45 -0600)

are available in the Git repository at:

  https://github.com/evdenis/linux-floppy tags/floppy-for-5.7

Please pull

----------------------------------------------------------------
Floppy patches for 5.7

Cleanups from Willy Tarreau:
  - expansion of macros referencing global or local variables with
    equivalent code
  - removal of incomplete support for second FDC from ARM code
  - renaming the "fdc" global variable to "current_fdc" to differ
    between global and local context

Changes were compile tested on arm, x86 arches. Changes introduce
no binary difference on x86 arch (before and after the patches).
On arm, incomplete support for second FDC removed. This set of
patches with commit 2e90ca68 ("floppy: check FDC index for errors
before assigning it") was tested with syzkaller and simple
write/read/format tests for no new issues.

Signed-off-by: Denis Efremov <efremov@linux.com>

----------------------------------------------------------------
Willy Tarreau (16):
      floppy: cleanup: expand macro FDCS
      floppy: cleanup: expand macro UFDCS
      floppy: cleanup: expand macro UDP
      floppy: cleanup: expand macro UDRS
      floppy: cleanup: expand macro UDRWE
      floppy: cleanup: expand macro DP
      floppy: cleanup: expand macro DRS
      floppy: cleanup: expand macro DRWE
      floppy: cleanup: expand the R/W / format command macros
      floppy: cleanup: expand the reply_buffer macros
      floppy: remove dead code for drives scanning on ARM
      floppy: remove incomplete support for second FDC from ARM code
      floppy: prepare ARM code to simplify base address separation
      floppy: introduce new functions fdc_inb() and fdc_outb()
      floppy: separate the FDC's base address from its registers
      floppy: rename the global "fdc" variable to "current_fdc"

 arch/arm/include/asm/floppy.h |   88 +----
 drivers/block/floppy.c        | 1093 +++++++++++++++++++++++++++++++----------------------------
 include/uapi/linux/fdreg.h    |   18 +-
 3 files changed, 586 insertions(+), 613 deletions(-)

^ permalink raw reply	[flat|nested] 5+ messages in thread
* [GIT PULL] Floppy cleanups for next
@ 2020-05-12 14:28 Denis Efremov
  2020-05-12 15:23 ` Jens Axboe
  0 siblings, 1 reply; 5+ messages in thread
From: Denis Efremov @ 2020-05-12 14:28 UTC (permalink / raw)
  To: Jens Axboe; +Cc: linux-block, Linux Kernel Mailing List

Hi Jens,

The following changes since commit 2ef96a5bb12be62ef75b5828c0aab838ebb29cb8:

  Linux 5.7-rc5 (2020-05-10 15:16:58 -0700)

are available in the Git repository at:

  https://github.com/evdenis/linux-floppy tags/floppy-for-5.8

Please pull

----------------------------------------------------------------
Floppy patches for 5.8

Cleanups:
  - symbolic register names for x86,sparc64,sparc32,powerpc,parisc,m68k
  - split of local/global variables for drive,fdc
  - UBSAN warning suppress in setup_rw_floppy()

Changes were compile tested on arm, sparc64, powerpc, m68k. Many patches
introduce no binary changes by using defines instead of magic numbers.
The patches were also tested with syzkaller and simple write/read/format
tests on real hardware.

Signed-off-by: Denis Efremov <efremov@linux.com>

----------------------------------------------------------------
Denis Efremov (4):
      floppy: use print_hex_dump() in setup_DMA()
      floppy: add FD_AUTODETECT_SIZE define for struct floppy_drive_params
      floppy: add defines for sizes of cmd & reply buffers of floppy_raw_cmd
      floppy: suppress UBSAN warning in setup_rw_floppy()

Willy Tarreau (27):
      floppy: split the base port from the register in I/O accesses
      floppy: add references to 82077's extra registers
      floppy: use symbolic register names in the m68k port
      floppy: use symbolic register names in the parisc port
      floppy: use symbolic register names in the powerpc port
      floppy: use symbolic register names in the sparc32 port
      floppy: use symbolic register names in the sparc64 port
      floppy: use symbolic register names in the x86 port
      floppy: cleanup: make twaddle() not rely on current_{fdc,drive} anymore
      floppy: cleanup: make reset_fdc_info() not rely on current_fdc anymore
      floppy: cleanup: make show_floppy() not rely on current_fdc anymore
      floppy: cleanup: make wait_til_ready() not rely on current_fdc anymore
      floppy: cleanup: make output_byte() not rely on current_fdc anymore
      floppy: cleanup: make result() not rely on current_fdc anymore
      floppy: cleanup: make need_more_output() not rely on current_fdc anymore
      floppy: cleanup: make perpendicular_mode() not rely on current_fdc anymore
      floppy: cleanup: make fdc_configure() not rely on current_fdc anymore
      floppy: cleanup: make fdc_specify() not rely on current_{fdc,drive} anymore
      floppy: cleanup: make check_wp() not rely on current_{fdc,drive} anymore
      floppy: cleanup: make next_valid_format() not rely on current_drive anymore
      floppy: cleanup: make get_fdc_version() not rely on current_fdc anymore
      floppy: cleanup: do not iterate on current_fdc in DMA grab/release functions
      floppy: cleanup: add a few comments about expectations in certain functions
      floppy: cleanup: do not iterate on current_fdc in do_floppy_init()
      floppy: make sure to reset all FDCs upon resume()
      floppy: cleanup: get rid of current_reqD in favor of current_drive
      floppy: cleanup: make set_fdc() always set current_drive and current_fd

 arch/alpha/include/asm/floppy.h             |   4 +-
 arch/arm/include/asm/floppy.h               |   8 +-
 arch/m68k/include/asm/floppy.h              |  27 ++++---
 arch/mips/include/asm/mach-generic/floppy.h |   8 +-
 arch/mips/include/asm/mach-jazz/floppy.h    |   8 +-
 arch/parisc/include/asm/floppy.h            |  19 ++---
 arch/powerpc/include/asm/floppy.h           |  19 ++---
 arch/sparc/include/asm/floppy_32.h          |  50 ++++++------
 arch/sparc/include/asm/floppy_64.h          |  59 +++++++-------
 arch/x86/include/asm/floppy.h               |  19 ++---
 drivers/block/floppy.c                      | 456 ++++++++++++++++++++++++++++++++++++++++++++++++++++++----------------------------------------------------
 include/uapi/linux/fd.h                     |  26 +++++-
 include/uapi/linux/fdreg.h                  |  16 +++-
 13 files changed, 384 insertions(+), 335 deletions(-)

^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2020-05-12 15:55 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-03-16 10:47 [GIT PULL] Floppy cleanups for next Denis Efremov
2020-03-16 15:08 ` Jens Axboe
2020-05-12 14:28 Denis Efremov
2020-05-12 15:23 ` Jens Axboe
2020-05-12 15:55   ` Denis Efremov

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).