linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH][next] dmaengine: hisilicon: Use struct_size() in devm_kzalloc()
@ 2020-06-17 21:11 Gustavo A. R. Silva
  2020-06-22  5:24 ` Zhou Wang
  2020-06-24  5:56 ` Vinod Koul
  0 siblings, 2 replies; 3+ messages in thread
From: Gustavo A. R. Silva @ 2020-06-17 21:11 UTC (permalink / raw)
  To: Zhou Wang, Dan Williams, Vinod Koul
  Cc: dmaengine, linux-kernel, Gustavo A. R. Silva

Make use of the struct_size() helper instead of an open-coded version
in order to avoid any potential type mistakes.

This code was detected with the help of Coccinelle and, audited and
fixed manually.

Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>
---
 drivers/dma/hisi_dma.c | 5 +----
 1 file changed, 1 insertion(+), 4 deletions(-)

diff --git a/drivers/dma/hisi_dma.c b/drivers/dma/hisi_dma.c
index ed3619266a48..e1a958ae7925 100644
--- a/drivers/dma/hisi_dma.c
+++ b/drivers/dma/hisi_dma.c
@@ -511,7 +511,6 @@ static int hisi_dma_probe(struct pci_dev *pdev, const struct pci_device_id *id)
 	struct device *dev = &pdev->dev;
 	struct hisi_dma_dev *hdma_dev;
 	struct dma_device *dma_dev;
-	size_t dev_size;
 	int ret;
 
 	ret = pcim_enable_device(pdev);
@@ -534,9 +533,7 @@ static int hisi_dma_probe(struct pci_dev *pdev, const struct pci_device_id *id)
 	if (ret)
 		return ret;
 
-	dev_size = sizeof(struct hisi_dma_chan) * HISI_DMA_CHAN_NUM +
-		   sizeof(*hdma_dev);
-	hdma_dev = devm_kzalloc(dev, dev_size, GFP_KERNEL);
+	hdma_dev = devm_kzalloc(dev, struct_size(hdma_dev, chan, HISI_DMA_CHAN_NUM), GFP_KERNEL);
 	if (!hdma_dev)
 		return -EINVAL;
 
-- 
2.27.0


^ permalink raw reply related	[flat|nested] 3+ messages in thread

* Re: [PATCH][next] dmaengine: hisilicon: Use struct_size() in devm_kzalloc()
  2020-06-17 21:11 [PATCH][next] dmaengine: hisilicon: Use struct_size() in devm_kzalloc() Gustavo A. R. Silva
@ 2020-06-22  5:24 ` Zhou Wang
  2020-06-24  5:56 ` Vinod Koul
  1 sibling, 0 replies; 3+ messages in thread
From: Zhou Wang @ 2020-06-22  5:24 UTC (permalink / raw)
  To: Gustavo A. R. Silva, Dan Williams, Vinod Koul
  Cc: dmaengine, linux-kernel, Gustavo A. R. Silva

On 2020/6/18 5:11, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.
> 
> Signed-off-by: Gustavo A. R. Silva <gustavoars@kernel.org>

Looks good to me, thanks!

Reviewed-by: Zhou Wang <wangzhou1@hisilicon.com>

> ---
>  drivers/dma/hisi_dma.c | 5 +----
>  1 file changed, 1 insertion(+), 4 deletions(-)
> 
> diff --git a/drivers/dma/hisi_dma.c b/drivers/dma/hisi_dma.c
> index ed3619266a48..e1a958ae7925 100644
> --- a/drivers/dma/hisi_dma.c
> +++ b/drivers/dma/hisi_dma.c
> @@ -511,7 +511,6 @@ static int hisi_dma_probe(struct pci_dev *pdev, const struct pci_device_id *id)
>  	struct device *dev = &pdev->dev;
>  	struct hisi_dma_dev *hdma_dev;
>  	struct dma_device *dma_dev;
> -	size_t dev_size;
>  	int ret;
>  
>  	ret = pcim_enable_device(pdev);
> @@ -534,9 +533,7 @@ static int hisi_dma_probe(struct pci_dev *pdev, const struct pci_device_id *id)
>  	if (ret)
>  		return ret;
>  
> -	dev_size = sizeof(struct hisi_dma_chan) * HISI_DMA_CHAN_NUM +
> -		   sizeof(*hdma_dev);
> -	hdma_dev = devm_kzalloc(dev, dev_size, GFP_KERNEL);
> +	hdma_dev = devm_kzalloc(dev, struct_size(hdma_dev, chan, HISI_DMA_CHAN_NUM), GFP_KERNEL);
>  	if (!hdma_dev)
>  		return -EINVAL;
>  
> 

^ permalink raw reply	[flat|nested] 3+ messages in thread

* Re: [PATCH][next] dmaengine: hisilicon: Use struct_size() in devm_kzalloc()
  2020-06-17 21:11 [PATCH][next] dmaengine: hisilicon: Use struct_size() in devm_kzalloc() Gustavo A. R. Silva
  2020-06-22  5:24 ` Zhou Wang
@ 2020-06-24  5:56 ` Vinod Koul
  1 sibling, 0 replies; 3+ messages in thread
From: Vinod Koul @ 2020-06-24  5:56 UTC (permalink / raw)
  To: Gustavo A. R. Silva
  Cc: Zhou Wang, Dan Williams, dmaengine, linux-kernel, Gustavo A. R. Silva

On 17-06-20, 16:11, Gustavo A. R. Silva wrote:
> Make use of the struct_size() helper instead of an open-coded version
> in order to avoid any potential type mistakes.
> 
> This code was detected with the help of Coccinelle and, audited and
> fixed manually.

Applied, thanks

-- 
~Vinod

^ permalink raw reply	[flat|nested] 3+ messages in thread

end of thread, other threads:[~2020-06-24  5:56 UTC | newest]

Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2020-06-17 21:11 [PATCH][next] dmaengine: hisilicon: Use struct_size() in devm_kzalloc() Gustavo A. R. Silva
2020-06-22  5:24 ` Zhou Wang
2020-06-24  5:56 ` Vinod Koul

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).