From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751236AbdLAVVx (ORCPT ); Fri, 1 Dec 2017 16:21:53 -0500 Received: from mga05.intel.com ([192.55.52.43]:63048 "EHLO mga05.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750742AbdLAVVw (ORCPT ); Fri, 1 Dec 2017 16:21:52 -0500 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.45,347,1508828400"; d="scan'208";a="12025843" Subject: Re: [PATCH 16/21] x86/entry/64: Use a per-CPU trampoline stack for IDT entries To: Andy Lutomirski References: <20171127104529.12435-1-mingo@kernel.org> <20171127104529.12435-17-mingo@kernel.org> <305ed448-6f8e-eecd-d120-546efc185443@linux.intel.com> Cc: Ingo Molnar , "linux-kernel@vger.kernel.org" , Thomas Gleixner , "H . Peter Anvin" , Peter Zijlstra , Borislav Petkov , Linus Torvalds From: Dave Hansen Message-ID: <5b74d67c-8253-8585-c8c0-9e61e3f119b2@linux.intel.com> Date: Fri, 1 Dec 2017 13:21:50 -0800 User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Thunderbird/52.4.0 MIME-Version: 1.0 In-Reply-To: Content-Type: multipart/mixed; boundary="------------A868543A1B0DAC47DF04C983" Content-Language: en-US Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org This is a multi-part message in MIME format. --------------A868543A1B0DAC47DF04C983 Content-Type: text/plain; charset=utf-8 Content-Transfer-Encoding: 7bit >>> [ 30.811750] CR2: fffffffffdeb2f98 CR3: 0000000423fae001 CR4: 00000000001607e0 >>> [ 30.819712] Call Trace: >>> [ 30.822442] >>> [ 30.825170] trace_hardirqs_on_thunk+0x1c/0x1c >> ... >>> [ 31.000571] R13: 0000000000000050 R14: 0000000000000076 R15: 00007f59f76f2d60 >>> [ 31.008533] >> >> Should we change that string to something more descriptive? > > I suppose we could rename it to "ENTRY_TRAMPOLINE" or something like that. The attached patch does just that. Any objections? --------------A868543A1B0DAC47DF04C983 Content-Type: text/x-patch; name="SYSENTER-rename.patch" Content-Transfer-Encoding: 7bit Content-Disposition: attachment; filename="SYSENTER-rename.patch" From: Dave Hansen The "SYSENTER" stack is used for a lot more than SYSENTER now. Give it a better string to display in stack dumps. We should probably cleanse the 64-bit code of the remaining "SYSENTER" nomenclature too at some point. Signed-off-by: Dave Hansen --- b/arch//x86/kernel/dumpstack_64.c | 10 ++++++++-- 1 file changed, 8 insertions(+), 2 deletions(-) diff -puN arch//x86/kernel/dumpstack_64.c~SYSENTER-rename arch//x86/kernel/dumpstack_64.c --- a/arch//x86/kernel/dumpstack_64.c~SYSENTER-rename 2017-12-01 12:43:16.768707737 -0800 +++ b/arch//x86/kernel/dumpstack_64.c 2017-12-01 13:19:21.741702337 -0800 @@ -37,8 +37,14 @@ const char *stack_type_name(enum stack_t if (type == STACK_TYPE_IRQ) return "IRQ"; - if (type == STACK_TYPE_SYSENTER) - return "SYSENTER"; + if (type == STACK_TYPE_SYSENTER) { + /* + * On 64-bit, we have a generic entry stack that we + * use for all the kernel try points, including + * SYSENTER. + */ + return "ENTRY_TRAMPOLINE"; + } if (type >= STACK_TYPE_EXCEPTION && type <= STACK_TYPE_EXCEPTION_LAST) return exception_stack_names[type - STACK_TYPE_EXCEPTION]; _ --------------A868543A1B0DAC47DF04C983--