linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH linux-next] PCI: Fix the order in unregister path
@ 2021-08-25  8:34 Yajun Deng
  2021-08-25 13:55 ` Rob Herring
  2021-08-26  3:57 ` yajun.deng
  0 siblings, 2 replies; 7+ messages in thread
From: Yajun Deng @ 2021-08-25  8:34 UTC (permalink / raw)
  To: bhelgaas, arnd, robh, lorenzo.pieralisi
  Cc: linux-pci, linux-kernel, Yajun Deng

device_del() should be called first and then called put_device() in
unregister path, becase if that the final reference count, the device
will be cleaned up via device_release() above. So use device_unregister()
instead.

Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
Signed-off-by: Yajun Deng <yajun.deng@linux.dev>
---
 drivers/pci/probe.c | 4 +---
 1 file changed, 1 insertion(+), 3 deletions(-)

diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
index 0ec5c792c27d..abd481a15a17 100644
--- a/drivers/pci/probe.c
+++ b/drivers/pci/probe.c
@@ -994,9 +994,7 @@ static int pci_register_host_bridge(struct pci_host_bridge *bridge)
 	return 0;
 
 unregister:
-	put_device(&bridge->dev);
-	device_del(&bridge->dev);
-
+	device_unregister(&bridge->dev);
 free:
 	kfree(bus);
 	return err;
-- 
2.32.0


^ permalink raw reply related	[flat|nested] 7+ messages in thread

* Re: [PATCH linux-next] PCI: Fix the order in unregister path
  2021-08-25  8:34 [PATCH linux-next] PCI: Fix the order in unregister path Yajun Deng
@ 2021-08-25 13:55 ` Rob Herring
  2021-08-26  3:57 ` yajun.deng
  1 sibling, 0 replies; 7+ messages in thread
From: Rob Herring @ 2021-08-25 13:55 UTC (permalink / raw)
  To: Yajun Deng
  Cc: Bjorn Helgaas, Arnd Bergmann, Lorenzo Pieralisi, PCI, linux-kernel

On Wed, Aug 25, 2021 at 3:34 AM Yajun Deng <yajun.deng@linux.dev> wrote:
>
> device_del() should be called first and then called put_device() in
> unregister path, becase if that the final reference count, the device
> will be cleaned up via device_release() above. So use device_unregister()
> instead.
>
> Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
> Signed-off-by: Yajun Deng <yajun.deng@linux.dev>
> ---
>  drivers/pci/probe.c | 4 +---
>  1 file changed, 1 insertion(+), 3 deletions(-)

NAK.

The current code is correct. Go read the comments for device_add/device_del.

> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
> index 0ec5c792c27d..abd481a15a17 100644
> --- a/drivers/pci/probe.c
> +++ b/drivers/pci/probe.c
> @@ -994,9 +994,7 @@ static int pci_register_host_bridge(struct pci_host_bridge *bridge)
>         return 0;
>
>  unregister:

We get here if device_register() failed. Calling device_unregister()
in that case is never right.

> -       put_device(&bridge->dev);

This is for the get_device() we do above, not the get the driver core does.

> -       device_del(&bridge->dev);

This undoes the device_add() we do following the comment: "NOTE: this
should be called manually _iff_ device_add() was also called
manually."

> -
> +       device_unregister(&bridge->dev);
>  free:
>         kfree(bus);
>         return err;
> --
> 2.32.0
>

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH linux-next] PCI: Fix the order in unregister path
  2021-08-25  8:34 [PATCH linux-next] PCI: Fix the order in unregister path Yajun Deng
  2021-08-25 13:55 ` Rob Herring
@ 2021-08-26  3:57 ` yajun.deng
  2021-08-26 12:01   ` Rob Herring
  2021-08-27  2:39   ` yajun.deng
  1 sibling, 2 replies; 7+ messages in thread
From: yajun.deng @ 2021-08-26  3:57 UTC (permalink / raw)
  To: Rob Herring
  Cc: Bjorn Helgaas, Arnd Bergmann, Lorenzo Pieralisi, PCI, linux-kernel

August 25, 2021 9:55 PM, "Rob Herring" <robh@kernel.org> wrote:

> On Wed, Aug 25, 2021 at 3:34 AM Yajun Deng <yajun.deng@linux.dev> wrote:
> 
>> device_del() should be called first and then called put_device() in
>> unregister path, becase if that the final reference count, the device
>> will be cleaned up via device_release() above. So use device_unregister()
>> instead.
>> 
>> Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
>> Signed-off-by: Yajun Deng <yajun.deng@linux.dev>
>> ---
>> drivers/pci/probe.c | 4 +---
>> 1 file changed, 1 insertion(+), 3 deletions(-)
> 
> NAK.
> 
> The current code is correct. Go read the comments for device_add/device_del.

But the device_unregister() is only contains device_del() and put_device(). It just put
device_del() before put_device().

> 
>> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
>> index 0ec5c792c27d..abd481a15a17 100644
>> --- a/drivers/pci/probe.c
>> +++ b/drivers/pci/probe.c
>> @@ -994,9 +994,7 @@ static int pci_register_host_bridge(struct pci_host_bridge *bridge)
>> return 0;
>> 
>> unregister:
> 
> We get here if device_register() failed. Calling device_unregister()
> in that case is never right.
> 
>> - put_device(&bridge->dev);
> 
> This is for the get_device() we do above, not the get the driver core does.
> 
>> - device_del(&bridge->dev);
> 
> This undoes the device_add() we do following the comment: "NOTE: this
> should be called manually _iff_ device_add() was also called
> manually."
> 
>> -
>> + device_unregister(&bridge->dev);
>> free:
>> kfree(bus);
>> return err;
>> --
>> 2.32.0

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH linux-next] PCI: Fix the order in unregister path
  2021-08-26  3:57 ` yajun.deng
@ 2021-08-26 12:01   ` Rob Herring
  2021-08-27  2:39   ` yajun.deng
  1 sibling, 0 replies; 7+ messages in thread
From: Rob Herring @ 2021-08-26 12:01 UTC (permalink / raw)
  To: Yajun Deng
  Cc: Bjorn Helgaas, Arnd Bergmann, Lorenzo Pieralisi, PCI, linux-kernel

On Wed, Aug 25, 2021 at 10:57 PM <yajun.deng@linux.dev> wrote:
>
> August 25, 2021 9:55 PM, "Rob Herring" <robh@kernel.org> wrote:
>
> > On Wed, Aug 25, 2021 at 3:34 AM Yajun Deng <yajun.deng@linux.dev> wrote:
> >
> >> device_del() should be called first and then called put_device() in
> >> unregister path, becase if that the final reference count, the device
> >> will be cleaned up via device_release() above. So use device_unregister()
> >> instead.
> >>
> >> Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
> >> Signed-off-by: Yajun Deng <yajun.deng@linux.dev>
> >> ---
> >> drivers/pci/probe.c | 4 +---
> >> 1 file changed, 1 insertion(+), 3 deletions(-)
> >
> > NAK.
> >
> > The current code is correct. Go read the comments for device_add/device_del.
>
> But the device_unregister() is only contains device_del() and put_device(). It just put
> device_del() before put_device().

And that is the wrong order as we want to undo what the code above
did. The put_device here is for the get_device we did. The put_device
in device_unregister is for the get_device that device_register did
(on success only).

Logically, it is wrong too to call unregister if register failed. That
would be like doing this:

p = malloc(1);
if (!p)
  free(p);

Rob

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH linux-next] PCI: Fix the order in unregister path
  2021-08-26  3:57 ` yajun.deng
  2021-08-26 12:01   ` Rob Herring
@ 2021-08-27  2:39   ` yajun.deng
  2021-08-30 14:55     ` Rob Herring
  2021-08-31  2:41     ` yajun.deng
  1 sibling, 2 replies; 7+ messages in thread
From: yajun.deng @ 2021-08-27  2:39 UTC (permalink / raw)
  To: Rob Herring
  Cc: Bjorn Helgaas, Arnd Bergmann, Lorenzo Pieralisi, PCI, linux-kernel

August 26, 2021 8:01 PM, "Rob Herring" <robh@kernel.org> wrote:

> On Wed, Aug 25, 2021 at 10:57 PM <yajun.deng@linux.dev> wrote:
> 
>> August 25, 2021 9:55 PM, "Rob Herring" <robh@kernel.org> wrote:
>> 
>> On Wed, Aug 25, 2021 at 3:34 AM Yajun Deng <yajun.deng@linux.dev> wrote:
>> 
>> device_del() should be called first and then called put_device() in
>> unregister path, becase if that the final reference count, the device
>> will be cleaned up via device_release() above. So use device_unregister()
>> instead.
>> 
>> Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
>> Signed-off-by: Yajun Deng <yajun.deng@linux.dev>
>> ---
>> drivers/pci/probe.c | 4 +---
>> 1 file changed, 1 insertion(+), 3 deletions(-)
>> 
>> NAK.
>> 
>> The current code is correct. Go read the comments for device_add/device_del.
>> 
>> But the device_unregister() is only contains device_del() and put_device(). It just put
>> device_del() before put_device().
> 
> And that is the wrong order as we want to undo what the code above
> did. The put_device here is for the get_device we did. The put_device
> in device_unregister is for the get_device that device_register did
> (on success only).
> 
> Logically, it is wrong too to call unregister if register failed. That
> would be like doing this:
> 
> p = malloc(1);
> if (!p)
> free(p);
>
This is the raw code:
        err = device_register(&bus->dev);
        if (err)
                goto unregister;
unregister:
        put_device(&bridge->dev);
        device_del(&bridge->dev);

This is my code:
        err = device_register(&bus->dev);
        if (err)
                goto unregister;
 unregister:
        device_unregister(&bridge->dev);


The parameter in  device_register() is bus->dev, but the parameter in device_unregister() is bridge->dev.The are different.
The bridge->dev is already success before called device_register().So it wouldn't be happen like your code.

 
> Rob

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH linux-next] PCI: Fix the order in unregister path
  2021-08-27  2:39   ` yajun.deng
@ 2021-08-30 14:55     ` Rob Herring
  2021-08-31  2:41     ` yajun.deng
  1 sibling, 0 replies; 7+ messages in thread
From: Rob Herring @ 2021-08-30 14:55 UTC (permalink / raw)
  To: Yajun Deng
  Cc: Bjorn Helgaas, Arnd Bergmann, Lorenzo Pieralisi, PCI, linux-kernel

On Thu, Aug 26, 2021 at 9:39 PM <yajun.deng@linux.dev> wrote:
>
> August 26, 2021 8:01 PM, "Rob Herring" <robh@kernel.org> wrote:
>
> > On Wed, Aug 25, 2021 at 10:57 PM <yajun.deng@linux.dev> wrote:
> >
> >> August 25, 2021 9:55 PM, "Rob Herring" <robh@kernel.org> wrote:
> >>
> >> On Wed, Aug 25, 2021 at 3:34 AM Yajun Deng <yajun.deng@linux.dev> wrote:
> >>
> >> device_del() should be called first and then called put_device() in
> >> unregister path, becase if that the final reference count, the device
> >> will be cleaned up via device_release() above. So use device_unregister()
> >> instead.
> >>
> >> Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
> >> Signed-off-by: Yajun Deng <yajun.deng@linux.dev>
> >> ---
> >> drivers/pci/probe.c | 4 +---
> >> 1 file changed, 1 insertion(+), 3 deletions(-)
> >>
> >> NAK.
> >>
> >> The current code is correct. Go read the comments for device_add/device_del.
> >>
> >> But the device_unregister() is only contains device_del() and put_device(). It just put
> >> device_del() before put_device().
> >
> > And that is the wrong order as we want to undo what the code above
> > did. The put_device here is for the get_device we did. The put_device
> > in device_unregister is for the get_device that device_register did
> > (on success only).
> >
> > Logically, it is wrong too to call unregister if register failed. That
> > would be like doing this:

You are right that the register and unregister are different devices.
However, your change is still wrong. The device_register is actually
irrelevant.

> >
> > p = malloc(1);
> > if (!p)
> > free(p);
> >
> This is the raw code:
>         err = device_register(&bus->dev);
>         if (err)
>                 goto unregister;
> unregister:
>         put_device(&bridge->dev);
>         device_del(&bridge->dev);

The pertinent parts are this:

err = device_add(&bridge->dev);  // which calls get_device() itself,
so there's the first ref
if (err) {
    put_device(&bridge->dev);
    goto free;
}
bus->bridge = get_device(&bridge->dev);  // This is the 2nd ref which
the PCI core holds
...
unregister:
    put_device(&bridge->dev);  // This is the put for the get_device
just above here.
    device_del(&bridge->dev);  // Then this does the 2nd put.

The get_device and put_device are paired, and the device_add and
device_del are paired.

As I said earlier, go read the kerneldoc for device_add. For your
convenience, here's the important part:

device_add:
 * Rule of thumb is: if device_add() succeeds, you should call
 * device_del() when you want to get rid of it. If device_add() has
 * *not* succeeded, use *only* put_device() to drop the reference
 * count.

device_del:
 * NOTE: this should be called manually _iff_ device_add() was
 * also called manually.


Rob

^ permalink raw reply	[flat|nested] 7+ messages in thread

* Re: [PATCH linux-next] PCI: Fix the order in unregister path
  2021-08-27  2:39   ` yajun.deng
  2021-08-30 14:55     ` Rob Herring
@ 2021-08-31  2:41     ` yajun.deng
  1 sibling, 0 replies; 7+ messages in thread
From: yajun.deng @ 2021-08-31  2:41 UTC (permalink / raw)
  To: Rob Herring
  Cc: Bjorn Helgaas, Arnd Bergmann, Lorenzo Pieralisi, PCI, linux-kernel

August 30, 2021 10:55 PM, "Rob Herring" <robh@kernel.org> wrote:

> On Thu, Aug 26, 2021 at 9:39 PM <yajun.deng@linux.dev> wrote:
> 
>> August 26, 2021 8:01 PM, "Rob Herring" <robh@kernel.org> wrote:
>> 
>> On Wed, Aug 25, 2021 at 10:57 PM <yajun.deng@linux.dev> wrote:
>> 
>> August 25, 2021 9:55 PM, "Rob Herring" <robh@kernel.org> wrote:
>> 
>> On Wed, Aug 25, 2021 at 3:34 AM Yajun Deng <yajun.deng@linux.dev> wrote:
>> 
>> device_del() should be called first and then called put_device() in
>> unregister path, becase if that the final reference count, the device
>> will be cleaned up via device_release() above. So use device_unregister()
>> instead.
>> 
>> Fixes: 9885440b16b8 (PCI: Fix pci_host_bridge struct device release/free handling)
>> Signed-off-by: Yajun Deng <yajun.deng@linux.dev>
>> ---
>> drivers/pci/probe.c | 4 +---
>> 1 file changed, 1 insertion(+), 3 deletions(-)
>> 
>> NAK.
>> 
>> The current code is correct. Go read the comments for device_add/device_del.
>> 
>> But the device_unregister() is only contains device_del() and put_device(). It just put
>> device_del() before put_device().
>> 
>> And that is the wrong order as we want to undo what the code above
>> did. The put_device here is for the get_device we did. The put_device
>> in device_unregister is for the get_device that device_register did
>> (on success only).
>> 
>> Logically, it is wrong too to call unregister if register failed. That
>> would be like doing this:
> 
> You are right that the register and unregister are different devices.
> However, your change is still wrong. The device_register is actually
> irrelevant.
> 
OK, the original order is right, it was my mistake.

>> p = malloc(1);
>> if (!p)
>> free(p);
>> 
>> This is the raw code:
>> err = device_register(&bus->dev);
>> if (err)
>> goto unregister;
>> unregister:
>> put_device(&bridge->dev);
>> device_del(&bridge->dev);
> 
> The pertinent parts are this:
> 
> err = device_add(&bridge->dev); // which calls get_device() itself,
> so there's the first ref
> if (err) {
> put_device(&bridge->dev);
> goto free;
> }
> bus->bridge = get_device(&bridge->dev); // This is the 2nd ref which
> the PCI core holds
> ...
> unregister:
> put_device(&bridge->dev); // This is the put for the get_device
> just above here.
> device_del(&bridge->dev); // Then this does the 2nd put.
> 
> The get_device and put_device are paired, and the device_add and
> device_del are paired.
> 
> As I said earlier, go read the kerneldoc for device_add. For your
> convenience, here's the important part:
> 
> device_add:
> * Rule of thumb is: if device_add() succeeds, you should call
> * device_del() when you want to get rid of it. If device_add() has
> * *not* succeeded, use *only* put_device() to drop the reference
> * count.
> 
> device_del:
> * NOTE: this should be called manually _iff_ device_add() was
> * also called manually.
> 
> Rob

^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2021-08-31  2:41 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2021-08-25  8:34 [PATCH linux-next] PCI: Fix the order in unregister path Yajun Deng
2021-08-25 13:55 ` Rob Herring
2021-08-26  3:57 ` yajun.deng
2021-08-26 12:01   ` Rob Herring
2021-08-27  2:39   ` yajun.deng
2021-08-30 14:55     ` Rob Herring
2021-08-31  2:41     ` yajun.deng

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).