linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: SF Markus Elfring <elfring@users.sourceforge.net>
To: linux-mtd@lists.infradead.org,
	Boris Brezillon <boris.brezillon@free-electrons.com>,
	Brian Norris <computersforpeace@gmail.com>,
	Cyrille Pitchen <cyrille.pitchen@atmel.com>,
	David Woodhouse <dwmw2@infradead.org>,
	Denys Vlasenko <dvlasenk@redhat.com>,
	Marek Vasut <marek.vasut@gmail.com>,
	Richard Weinberger <richard@nod.at>
Cc: LKML <linux-kernel@vger.kernel.org>, kernel-janitors@vger.kernel.org
Subject: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations
Date: Wed, 11 Jan 2017 21:34:13 +0100	[thread overview]
Message-ID: <71189baa-8780-b80a-0b4d-9dae74763ba3@users.sourceforge.net> (raw)

From: Markus Elfring <elfring@users.sourceforge.net>
Date: Wed, 11 Jan 2017 21:21:12 +0100

Several update suggestions were taken into account
from static source code analysis.

Markus Elfring (18):
  Use kmalloc_array() in cfi_intelext_partition_fixup()
  Improve another size determination in cfi_intelext_partition_fixup()
  cfi_cmdset_0001: Add some spaces for better code readability
  cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword()
  cfi_cmdset_0001: Use common error handling code in do_write_oneword()
  Use kcalloc() in cfi_intelext_setup()
  One function call and an unnecessary check less in cfi_intelext_setup()
  Rename a jump label in cfi_intelext_setup()
  Use kmalloc_array() in cfi_amdstd_setup()
  One function call less in cfi_amdstd_setup() after error detection
  Rename a jump label in cfi_amdstd_setup()
  cfi_cmdset_0002: Add some spaces for better code readability
  cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword()
  cfi_cmdset_0002: Use common error handling code in do_write_oneword()
  Use kcalloc() in cfi_ppb_unlock()
  Use kmalloc_array() in cfi_staa_setup()
  Use common error handling code in cfi_staa_setup()
  cfi_cmdset_0020: Add some spaces for better code readability

 drivers/mtd/chips/cfi_cmdset_0001.c | 165 +++++++++++++++++++-----------------
 drivers/mtd/chips/cfi_cmdset_0002.c | 110 +++++++++++++-----------
 drivers/mtd/chips/cfi_cmdset_0020.c | 127 ++++++++++++++-------------
 3 files changed, 214 insertions(+), 188 deletions(-)

-- 
2.11.0

             reply	other threads:[~2017-01-11 20:36 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2017-01-11 20:34 SF Markus Elfring [this message]
2017-01-11 20:35 ` [PATCH 01/18] mtd-cfi_cmdset_0001: Use kmalloc_array() in cfi_intelext_partition_fixup() SF Markus Elfring
2017-01-11 21:59   ` Marek Vasut
2017-01-11 20:37 ` [PATCH 02/18] mtd-cfi_cmdset_0001: Improve another size determination " SF Markus Elfring
2017-01-11 21:57   ` Marek Vasut
2017-01-11 20:38 ` [PATCH 03/18] mtd-cfi_cmdset_0001: Add some spaces for better code readability SF Markus Elfring
2017-01-12  9:19   ` Dan Carpenter
2017-01-11 20:39 ` [PATCH 04/18] mtd-cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword() SF Markus Elfring
2017-01-11 20:40 ` [PATCH 05/18] mtd-cfi_cmdset_0001: Use common error handling code " SF Markus Elfring
2017-01-11 20:41 ` [PATCH 06/18] mtd-cfi_cmdset_0001: Use kcalloc() in cfi_intelext_setup() SF Markus Elfring
2017-01-11 20:42 ` [PATCH 07/18] mtd-cfi_cmdset_0001: One function call and an unnecessary check less " SF Markus Elfring
2017-01-11 20:43 ` [PATCH 08/18] mtd-cfi_cmdset_0001: Rename a jump label " SF Markus Elfring
2017-01-11 20:44 ` [PATCH 09/18] mtd-cfi_cmdset_0002: Use kmalloc_array() in cfi_amdstd_setup() SF Markus Elfring
2017-01-11 20:45 ` [PATCH 10/18] mtd-cfi_cmdset_0002: One function call less in cfi_amdstd_setup() after error detection SF Markus Elfring
2017-01-11 20:46 ` [PATCH 11/18] mtd-cfi_cmdset_0002: Rename a jump label in cfi_amdstd_setup() SF Markus Elfring
2017-01-11 20:47 ` [PATCH 12/18] mtd-cfi_cmdset_0002: Add some spaces for better code readability SF Markus Elfring
2017-01-11 20:48 ` [PATCH 13/18] mtd-cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword() SF Markus Elfring
2017-01-11 20:49 ` [PATCH 14/18] mtd-cfi_cmdset_0002: Use common error handling code " SF Markus Elfring
2017-01-11 20:50 ` [PATCH 15/18] mtd-cfi_cmdset_0002: Use kcalloc() in cfi_ppb_unlock() SF Markus Elfring
2017-01-11 20:51 ` [PATCH 16/18] mtd-cfi_cmdset_0020: Use kmalloc_array() in cfi_staa_setup() SF Markus Elfring
2017-01-11 20:52 ` [PATCH 17/18] mtd-cfi_cmdset_0020: Use common error handling code " SF Markus Elfring
2017-01-11 20:55 ` [PATCH 18/18] mtd-cfi_cmdset_0020: Add some spaces for better code readability SF Markus Elfring
2017-01-12  9:27   ` Dan Carpenter
2017-01-11 21:56 ` [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations Boris Brezillon
2017-01-11 21:58 ` Marek Vasut

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=71189baa-8780-b80a-0b4d-9dae74763ba3@users.sourceforge.net \
    --to=elfring@users.sourceforge.net \
    --cc=boris.brezillon@free-electrons.com \
    --cc=computersforpeace@gmail.com \
    --cc=cyrille.pitchen@atmel.com \
    --cc=dvlasenk@redhat.com \
    --cc=dwmw2@infradead.org \
    --cc=kernel-janitors@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=marek.vasut@gmail.com \
    --cc=richard@nod.at \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).