linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: James Morse <james.morse@arm.com>
To: x86@kernel.org, linux-kernel@vger.kernel.org
Cc: Fenghua Yu <fenghua.yu@intel.com>,
	Reinette Chatre <reinette.chatre@intel.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	shameerali.kolothum.thodi@huawei.com,
	Jamie Iles <jamie@nuviainc.com>,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	lcherian@marvell.com, bobo.shaobowang@huawei.com
Subject: Re: [PATCH v6 01/24] x86/resctrl: Split struct rdt_resource
Date: Wed, 28 Jul 2021 17:17:03 +0100	[thread overview]
Message-ID: <76911cf6-799e-c8ae-b5c9-51d260d87402@arm.com> (raw)
In-Reply-To: <20210715173043.14222-2-james.morse@arm.com>

Hello,

On 15/07/2021 18:30, James Morse wrote:
> resctrl is the defacto Linux ABI for SoC resource partitioning features.
> 
> To support it on another architecture, it needs to be abstracted from
> the features provided by Intel RDT and AMD PQoS, and moved to /fs/.
> struct rdt_resource contains a mix of architecture private details
> and properties of the filesystem interface user-space uses.
> 
> Start by splitting struct rdt_resource, into an architecture private
> 'hw' struct, which contains the common resctrl structure that would be
> used by any architecture.

> The foreach helpers are most commonly used by
> the filesystem code, and should return the common resctrl structure.
> for_each_rdt_resource() is changed to walk the common structure in its
> parent arch private structure.

[...]

> diff --git a/arch/x86/kernel/cpu/resctrl/internal.h b/arch/x86/kernel/cpu/resctrl/internal.h
> index 6a5f60a37219..88d71c889328 100644
> --- a/arch/x86/kernel/cpu/resctrl/internal.h
> +++ b/arch/x86/kernel/cpu/resctrl/internal.h

> @@ -524,33 +439,42 @@ enum {
>  	RDT_NUM_RESOURCES,
>  };
>  
> +static inline struct rdt_resource *resctrl_inc(struct rdt_resource *res)
> +{
> +	struct rdt_hw_resource *hw_res = resctrl_to_arch_res(res);
> +
> +	hw_res++;
> +	return &hw_res->r_resctrl;
> +}
> +
> +/*
> + * To return the common struct rdt_resource, which is contained in struct
> + * rdt_hw_resource, walk the resctrl member of struct rdt_hw_resource.
> + * This makes the limit the resctrl member past the end of the array.
> + */
>  #define for_each_rdt_resource(r)					      \
> -	for (r = rdt_resources_all; r < rdt_resources_all + RDT_NUM_RESOURCES;\
> -	     r++)
> +	for (r = &rdt_resources_all[0].r_resctrl;			      \
> +	     r < &rdt_resources_all[RDT_NUM_RESOURCES].r_resctrl;	      \
> +	     r = resctrl_inc(r))

Kbuild robot reports UBSAN doesn't like this, presumably the dastardly compiler has gone
and generated some accesses. Easily fixed, (but now looks less like the original)

v6's branch gets a patch on top, I'll squash this into v7:
----%<----
@@ -441,11 +441,10 @@ int resctrl_arch_set_cdp_enabled(enum resctrl_res_level l, bool enable);
 /*
  * To return the common struct rdt_resource, which is contained in struct
  * rdt_hw_resource, walk the resctrl member of struct rdt_hw_resource.
- * This makes the limit the resctrl member past the end of the array.
  */
 #define for_each_rdt_resource(r)                                             \
        for (r = &rdt_resources_all[0].r_resctrl;                             \
-            r < &rdt_resources_all[RDT_NUM_RESOURCES].r_resctrl;             \
+            r <= &rdt_resources_all[RDT_NUM_RESOURCES - 1].r_resctrl;        \
             r = resctrl_inc(r))

 #define for_each_capable_rdt_resource(r)                                     \
----%<----


Thanks,

James

  reply	other threads:[~2021-07-28 16:17 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-15 17:30 [PATCH v6 00/24] x86/resctrl: Merge the CDP resources James Morse
2021-07-15 17:30 ` [PATCH v6 01/24] x86/resctrl: Split struct rdt_resource James Morse
2021-07-28 16:17   ` James Morse [this message]
2021-07-15 17:30 ` [PATCH v6 02/24] x86/resctrl: Split struct rdt_domain James Morse
2021-07-15 17:30 ` [PATCH v6 03/24] x86/resctrl: Add a separate schema list for resctrl James Morse
2021-07-15 17:30 ` [PATCH v6 04/24] x86/resctrl: Pass the schema in info dir's private pointer James Morse
2021-07-15 17:30 ` [PATCH v6 05/24] x86/resctrl: Label the resources with their configuration type James Morse
2021-07-15 17:30 ` [PATCH v6 06/24] x86/resctrl: Walk the resctrl schema list instead of an arch list James Morse
2021-07-15 17:30 ` [PATCH v6 07/24] x86/resctrl: Store the effective num_closid in the schema James Morse
2021-07-15 17:30 ` [PATCH v6 08/24] x86/resctrl: Add resctrl_arch_get_num_closid() James Morse
2021-07-15 17:30 ` [PATCH v6 09/24] x86/resctrl: Pass the schema to resctrl filesystem functions James Morse
2021-07-15 17:30 ` [PATCH v6 10/24] x86/resctrl: Swizzle rdt_resource and resctrl_schema in pseudo_lock_region James Morse
2021-07-15 17:30 ` [PATCH v6 11/24] x86/resctrl: Add a helper to read/set the CDP configuration James Morse
2021-07-15 17:30 ` [PATCH v6 12/24] x86/resctrl: Move the schemata names into struct resctrl_schema James Morse
2021-07-15 17:30 ` [PATCH v6 13/24] x86/resctrl: Group staged configuration into a separate struct James Morse
2021-07-15 17:30 ` [PATCH v6 14/24] x86/resctrl: Allow different CODE/DATA configurations to be staged James Morse
2021-07-15 17:30 ` [PATCH v6 15/24] x86/resctrl: Rename update_domains() resctrl_arch_update_domains() James Morse
2021-07-15 17:30 ` [PATCH v6 16/24] x86/resctrl: Add a helper to read a closid's configuration James Morse
2021-07-15 17:30 ` [PATCH v6 17/24] x86/resctrl: Pass configuration type to resctrl_arch_get_config() James Morse
2021-07-15 17:30 ` [PATCH v6 18/24] x86/resctrl: Make ctrlval arrays the same size James Morse
2021-07-15 17:30 ` [PATCH v6 19/24] x86/resctrl: Apply offset correction when config is staged James Morse
2021-07-15 17:30 ` [PATCH v6 20/24] x86/resctrl: Calculate the index from the configuration type James Morse
2021-07-15 17:30 ` [PATCH v6 21/24] x86/resctrl: Merge the ctrl_val arrays James Morse
2021-07-15 17:30 ` [PATCH v6 22/24] x86/resctrl: Remove rdt_cdp_peer_get() James Morse
2021-07-15 17:30 ` [PATCH v6 23/24] x86/resctrl: Expand resctrl_arch_update_domains()'s msr_param range James Morse
2021-07-15 17:30 ` [PATCH v6 24/24] x86/resctrl: Merge the CDP resources James Morse

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=76911cf6-799e-c8ae-b5c9-51d260d87402@arm.com \
    --to=james.morse@arm.com \
    --cc=Babu.Moger@amd.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=fenghua.yu@intel.com \
    --cc=hpa@zytor.com \
    --cc=jamie@nuviainc.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=reinette.chatre@intel.com \
    --cc=scott@os.amperecomputing.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).