linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Laura Abbott <labbott@redhat.com>
To: Florian Fainelli <f.fainelli@gmail.com>,
	linux-arm-kernel@lists.infradead.org
Cc: linux@armlinux.org.uk, nicolas.pitre@linaro.org,
	panand@redhat.com, chris.brandt@renesas.com, arnd@arndb.de,
	jonathan.austin@arm.com, pawel.moll@arm.com,
	vladimir.murzin@arm.com, mark.rutland@arm.com,
	ard.biesheuvel@linaro.org, keescook@chromium.org,
	matt@codeblueprint.co.uk, kirill.shutemov@linux.intel.com,
	ben@decadent.org.uk, js07.lee@samsung.com, stefan@agner.ch,
	linux-kernel@vger.kernel.org, linux-mtd@lists.infradead.org,
	cyrille.pitchen@atmel.com, richard@nod.at,
	boris.brezillon@free-electrons.com, computersforpeace@gmail.com,
	dwmw2@infradead.org
Subject: Re: [PATCH v3 3/4] ARM: Add support for CONFIG_DEBUG_VIRTUAL
Date: Wed, 21 Dec 2016 18:40:05 -0800	[thread overview]
Message-ID: <7721bed8-4b08-f5ce-056e-45f02a431e76@redhat.com> (raw)
In-Reply-To: <20161209233628.6642-4-f.fainelli@gmail.com>

On 12/09/2016 03:36 PM, Florian Fainelli wrote:
> x86 has an option: CONFIG_DEBUG_VIRTUAL to do additional checks on
> virt_to_phys calls. The goal is to catch users who are calling
> virt_to_phys on non-linear addresses immediately. This includes caller
> using __virt_to_phys() on image addresses instead of __pa_symbol(). This
> is a generally useful debug feature to spot bad code (particulary in
> drivers).
> 
> Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
> ---
>  arch/arm/Kconfig              |  1 +
>  arch/arm/include/asm/memory.h | 16 ++++++++++++--
>  arch/arm/mm/Makefile          |  1 +
>  arch/arm/mm/physaddr.c        | 51 +++++++++++++++++++++++++++++++++++++++++++
>  4 files changed, 67 insertions(+), 2 deletions(-)
>  create mode 100644 arch/arm/mm/physaddr.c
> 
> diff --git a/arch/arm/Kconfig b/arch/arm/Kconfig
> index b5d529fdffab..5e66173c5787 100644
> --- a/arch/arm/Kconfig
> +++ b/arch/arm/Kconfig
> @@ -2,6 +2,7 @@ config ARM
>  	bool
>  	default y
>  	select ARCH_CLOCKSOURCE_DATA
> +	select ARCH_HAS_DEBUG_VIRTUAL
>  	select ARCH_HAS_DEVMEM_IS_ALLOWED
>  	select ARCH_HAS_ELF_RANDOMIZE
>  	select ARCH_HAS_TICK_BROADCAST if GENERIC_CLOCKEVENTS_BROADCAST
> diff --git a/arch/arm/include/asm/memory.h b/arch/arm/include/asm/memory.h
> index bee7511c5098..d90300193adf 100644
> --- a/arch/arm/include/asm/memory.h
> +++ b/arch/arm/include/asm/memory.h
> @@ -213,7 +213,7 @@ extern const void *__pv_table_begin, *__pv_table_end;
>  	: "r" (x), "I" (__PV_BITS_31_24)		\
>  	: "cc")
>  
> -static inline phys_addr_t __virt_to_phys(unsigned long x)
> +static inline phys_addr_t __virt_to_phys_nodebug(unsigned long x)
>  {
>  	phys_addr_t t;
>  
> @@ -245,7 +245,7 @@ static inline unsigned long __phys_to_virt(phys_addr_t x)
>  #define PHYS_OFFSET	PLAT_PHYS_OFFSET
>  #define PHYS_PFN_OFFSET	((unsigned long)(PHYS_OFFSET >> PAGE_SHIFT))
>  
> -static inline phys_addr_t __virt_to_phys(unsigned long x)
> +static inline phys_addr_t __virt_to_phys_nodebug(unsigned long x)
>  {
>  	return (phys_addr_t)x - PAGE_OFFSET + PHYS_OFFSET;
>  }
> @@ -261,6 +261,16 @@ static inline unsigned long __phys_to_virt(phys_addr_t x)
>  	((((unsigned long)(kaddr) - PAGE_OFFSET) >> PAGE_SHIFT) + \
>  	 PHYS_PFN_OFFSET)
>  
> +#define __pa_symbol_nodebug(x)	__virt_to_phys_nodebug((x))
> +
> +#ifdef CONFIG_DEBUG_VIRTUAL
> +extern phys_addr_t __virt_to_phys(unsigned long x);
> +extern phys_addr_t __phys_addr_symbol(unsigned long x);
> +#else
> +#define __virt_to_phys(x)	__virt_to_phys_nodebug(x)
> +#define __phys_addr_symbol(x)	__pa_symbol_nodebug(x)
> +#endif
> +
>  /*
>   * These are *only* valid on the kernel direct mapped RAM memory.
>   * Note: Drivers should NOT use these.  They are the wrong
> @@ -283,9 +293,11 @@ static inline void *phys_to_virt(phys_addr_t x)
>   * Drivers should NOT use these either.
>   */
>  #define __pa(x)			__virt_to_phys((unsigned long)(x))
> +#define __pa_symbol(x)		__phys_addr_symbol(RELOC_HIDE((unsigned long)(x), 0))
>  #define __va(x)			((void *)__phys_to_virt((phys_addr_t)(x)))
>  #define pfn_to_kaddr(pfn)	__va((phys_addr_t)(pfn) << PAGE_SHIFT)
>  
> +
>  extern long long arch_phys_to_idmap_offset;
>  
>  /*
> diff --git a/arch/arm/mm/Makefile b/arch/arm/mm/Makefile
> index e8698241ece9..b3dea80715b4 100644
> --- a/arch/arm/mm/Makefile
> +++ b/arch/arm/mm/Makefile
> @@ -14,6 +14,7 @@ endif
>  
>  obj-$(CONFIG_ARM_PTDUMP)	+= dump.o
>  obj-$(CONFIG_MODULES)		+= proc-syms.o
> +obj-$(CONFIG_DEBUG_VIRTUAL)	+= physaddr.o
>  
>  obj-$(CONFIG_ALIGNMENT_TRAP)	+= alignment.o
>  obj-$(CONFIG_HIGHMEM)		+= highmem.o
> diff --git a/arch/arm/mm/physaddr.c b/arch/arm/mm/physaddr.c
> new file mode 100644
> index 000000000000..0288760306ce
> --- /dev/null
> +++ b/arch/arm/mm/physaddr.c
> @@ -0,0 +1,51 @@
> +#include <linux/bug.h>
> +#include <linux/export.h>
> +#include <linux/types.h>
> +#include <linux/mmdebug.h>
> +#include <linux/mm.h>
> +
> +#include <asm/sections.h>
> +#include <asm/memory.h>
> +#include <asm/fixmap.h>
> +#include <asm/dma.h>
> +
> +#include "mm.h"
> +
> +static inline bool __virt_addr_valid(unsigned long x)
> +{
> +	/* high_memory does not get immediately defined, and there
> +	 * are early callers of __pa() against PAGE_OFFSET, just catch
> +	 * these here, then do normal checks, with the exception of
> +	 * MAX_DMA_ADDRESS.
> +	 */
> +	if ((x >= PAGE_OFFSET && !high_memory) ||
> +	   (x >= PAGE_OFFSET &&
> +	    high_memory && x < (unsigned long)high_memory) ||
> +	    x == MAX_DMA_ADDRESS)
> +		return true;

This is difficult to read, it's easier to read if it's split out:

if (!high_memory && x >= PAGE_OFFSET)
	return true;

if (high_memory && x >= PAGE_OFFSET && x < (unsigned long) high_memory)
	return true;

if (x == MAX_DMA_ADDRESS)
	return true;

I'm really not a fan of the check for MAX_DMA_ADDRESS. arm64 gets away
with this because it uses the asm-generic version of dma.h which sets
MAX_DMA_ADDRESS to PAGE_OFFSET. __pa(MAX_DMA_ADDRESS) is used a
bunch of places in the kernel as a lower limit for memblock
allocation. The implication seems to be that MAX_DMA_ADDRESS
corresponds to something that corresponds to a real physical address.
The existing code happens to work because it will simply retry the
allocation if without the lower bound.

I don't see a good way to fix this though. It doesn't look like
MAX_DMA_ADDRESS can be changed if it's actually going to be used
for DMA and there isn't a unified way to just get a physical address.

Thanks,
Laura

> +
> +	return false;
> +}
> +
> +phys_addr_t __virt_to_phys(unsigned long x)
> +{
> +	WARN(!__virt_addr_valid(x),
> +	     "virt_to_phys used for non-linear address: %pK (%pS)\n",
> +	     (void *)x,
> +	     (void *)x);
> +
> +	return __virt_to_phys_nodebug(x);
> +}
> +EXPORT_SYMBOL(__virt_to_phys);
> +
> +phys_addr_t __phys_addr_symbol(unsigned long x)
> +{
> +	/* This is bounds checking against the kernel image only.
> +	 * __pa_symbol should only be used on kernel symbol addresses.
> +	 */
> +	VIRTUAL_BUG_ON(x < (unsigned long)KERNEL_START ||
> +		       x > (unsigned long)KERNEL_END);
> +
> +	return __pa_symbol_nodebug(x);
> +}
> +EXPORT_SYMBOL(__phys_addr_symbol);
> 

  reply	other threads:[~2016-12-22  2:40 UTC|newest]

Thread overview: 35+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-12-06 23:50 [PATCHv5 00/11] CONFIG_DEBUG_VIRTUAL for arm64 Laura Abbott
2016-12-06 23:50 ` [PATCHv5 01/11] lib/Kconfig.debug: Add ARCH_HAS_DEBUG_VIRTUAL Laura Abbott
2016-12-06 23:50 ` [PATCHv5 02/11] mm/cma: Cleanup highmem check Laura Abbott
2016-12-06 23:50 ` [PATCHv5 03/11] arm64: Move some macros under #ifndef __ASSEMBLY__ Laura Abbott
2016-12-06 23:50 ` [PATCHv5 04/11] arm64: Add cast for virt_to_pfn Laura Abbott
2016-12-06 23:50 ` [PATCHv5 05/11] mm: Introduce lm_alias Laura Abbott
2016-12-06 23:50 ` [PATCHv5 06/11] arm64: Use __pa_symbol for kernel symbols Laura Abbott
2016-12-13 12:31   ` Mark Rutland
2016-12-06 23:50 ` [PATCHv5 07/11] drivers: firmware: psci: Use __pa_symbol for kernel symbol Laura Abbott
2016-12-06 23:50 ` [PATCHv5 08/11] kexec: Switch to __pa_symbol Laura Abbott
2016-12-06 23:50 ` [PATCHv5 09/11] mm/kasan: Switch to using __pa_symbol and lm_alias Laura Abbott
2016-12-13 12:31   ` Mark Rutland
2016-12-06 23:50 ` [PATCHv5 10/11] mm/usercopy: Switch to using lm_alias Laura Abbott
2016-12-06 23:50 ` [PATCHv5 11/11] arm64: Add support for CONFIG_DEBUG_VIRTUAL Laura Abbott
2016-12-08 18:59 ` [PATCH v2 0/4] ARM: " Florian Fainelli
2016-12-08 18:59   ` [PATCH v2 1/4] mtd: lart: Rename partition defines to be prefixed with PART_ Florian Fainelli
2016-12-08 18:59   ` [PATCH v2 2/4] ARM: Define KERNEL_START and KERNEL_END Florian Fainelli
2016-12-08 18:59   ` [PATCH v2 3/4] ARM: Add support for CONFIG_DEBUG_VIRTUAL Florian Fainelli
2016-12-08 18:59   ` [PATCH v2 4/4] ARM: treewide: Replace uses of virt_to_phys with __pa_symbol Florian Fainelli
2016-12-08 21:49     ` kbuild test robot
2016-12-09 23:36   ` [PATCH v3 0/4] ARM: Add support for CONFIG_DEBUG_VIRTUAL Florian Fainelli
2016-12-09 23:36     ` [PATCH v3 1/4] mtd: lart: Rename partition defines to be prefixed with PART_ Florian Fainelli
2016-12-14  7:08       ` Boris Brezillon
2016-12-09 23:36     ` [PATCH v3 2/4] ARM: Define KERNEL_START and KERNEL_END Florian Fainelli
2016-12-09 23:36     ` [PATCH v3 3/4] ARM: Add support for CONFIG_DEBUG_VIRTUAL Florian Fainelli
2016-12-22  2:40       ` Laura Abbott [this message]
2016-12-09 23:36     ` [PATCH v3 4/4] ARM: treewide: Replace uses of virt_to_phys with __pa_symbol Florian Fainelli
2016-12-13 20:29     ` [PATCH v3 0/4] ARM: Add support for CONFIG_DEBUG_VIRTUAL Florian Fainelli
2016-12-26 20:38     ` [PATCH v4 " Florian Fainelli
2016-12-26 20:38       ` [PATCH v4 1/4] mtd: lart: Rename partition defines to be prefixed with PART_ Florian Fainelli
2016-12-26 20:38       ` [PATCH v4 2/4] ARM: Define KERNEL_START and KERNEL_END Florian Fainelli
2016-12-26 20:38       ` [PATCH v4 3/4] ARM: Add support for CONFIG_DEBUG_VIRTUAL Florian Fainelli
2016-12-26 20:38       ` [PATCH v4 4/4] ARM: treewide: Replace uses of virt_to_phys with __pa_symbol Florian Fainelli
2017-01-02 14:10       ` [PATCH v4 0/4] ARM: Add support for CONFIG_DEBUG_VIRTUAL Russell King - ARM Linux
2016-12-13 13:50 ` [PATCHv5 00/11] CONFIG_DEBUG_VIRTUAL for arm64 Mark Rutland

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7721bed8-4b08-f5ce-056e-45f02a431e76@redhat.com \
    --to=labbott@redhat.com \
    --cc=ard.biesheuvel@linaro.org \
    --cc=arnd@arndb.de \
    --cc=ben@decadent.org.uk \
    --cc=boris.brezillon@free-electrons.com \
    --cc=chris.brandt@renesas.com \
    --cc=computersforpeace@gmail.com \
    --cc=cyrille.pitchen@atmel.com \
    --cc=dwmw2@infradead.org \
    --cc=f.fainelli@gmail.com \
    --cc=jonathan.austin@arm.com \
    --cc=js07.lee@samsung.com \
    --cc=keescook@chromium.org \
    --cc=kirill.shutemov@linux.intel.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mtd@lists.infradead.org \
    --cc=linux@armlinux.org.uk \
    --cc=mark.rutland@arm.com \
    --cc=matt@codeblueprint.co.uk \
    --cc=nicolas.pitre@linaro.org \
    --cc=panand@redhat.com \
    --cc=pawel.moll@arm.com \
    --cc=richard@nod.at \
    --cc=stefan@agner.ch \
    --cc=vladimir.murzin@arm.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).