On Tue, 27 Sep 2022, Jiri Slaby wrote: > FIELD_GET() can do the job smarter and more readable. We don't even need > ASCFSTAT_TXFREEOFF. So switch to the former and remove the latter. > > Suggested-by: Ilpo Järvinen > Signed-off-by: Jiri Slaby Reviewed-by: Ilpo Järvinen -- i. > --- > drivers/tty/serial/lantiq.c | 4 ++-- > 1 file changed, 2 insertions(+), 2 deletions(-) > > diff --git a/drivers/tty/serial/lantiq.c b/drivers/tty/serial/lantiq.c > index ba9739af30ed..c892f3c7d1ab 100644 > --- a/drivers/tty/serial/lantiq.c > +++ b/drivers/tty/serial/lantiq.c > @@ -8,6 +8,7 @@ > * Copyright (C) 2010 Thomas Langer, > */ > > +#include > #include > #include > #include > @@ -93,7 +94,6 @@ > #define ASCFSTAT_RXFFLMASK 0x003F > #define ASCFSTAT_TXFFLMASK 0x3F00 > #define ASCFSTAT_TXFREEMASK 0x3F000000 > -#define ASCFSTAT_TXFREEOFF 24 > > static void lqasc_tx_chars(struct uart_port *port); > static struct ltq_uart_port *lqasc_port[MAXPORTS]; > @@ -143,7 +143,7 @@ static bool lqasc_tx_ready(struct uart_port *port) > { > u32 fstat = __raw_readl(port->membase + LTQ_ASC_FSTAT); > > - return (fstat & ASCFSTAT_TXFREEMASK) >> ASCFSTAT_TXFREEOFF; > + return FIELD_GET(ASCFSTAT_TXFREEMASK, fstat); > } > > static void >