On Thu, 2 Feb 2012 15:38:14 -0500 (EST), Alan Stern wrote: > - urb->transfer_flags &= allowed; > + allowed &= urb->transfer_flags; Minor bikeshed here, but 'allowed' is not the right name for the value at this point; perhaps just /* warn if submitter gave bogus flags */ if ((urb->transfer_flags & allowed) != urb->transfer_flags) might be better? Otherwise, this looks nice to me. Acked-by: Keith Packard -- keith.packard@intel.com