From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1755098AbcHSNfm (ORCPT ); Fri, 19 Aug 2016 09:35:42 -0400 Received: from fw-tnat.cambridge.arm.com ([217.140.96.140]:59187 "EHLO cam-smtp0.cambridge.arm.com" rhost-flags-OK-OK-OK-FAIL) by vger.kernel.org with ESMTP id S1754043AbcHSNfk (ORCPT ); Fri, 19 Aug 2016 09:35:40 -0400 From: Punit Agrawal To: Will Deacon Cc: kvm@vger.kernel.org, Marc Zyngier , Catalin Marinas , linux-kernel@vger.kernel.org, Steven Rostedt , Ingo Molnar , kvmarm@lists.cs.columbia.edu, linux-arm-kernel@lists.infradead.org Subject: Re: [RFC PATCH 4/7] arm64: tlbflush.h: add __tlbi() macro References: <1471344312-26685-1-git-send-email-punit.agrawal@arm.com> <1471344312-26685-5-git-send-email-punit.agrawal@arm.com> <20160819132427.GD9893@arm.com> Date: Fri, 19 Aug 2016 14:34:56 +0100 In-Reply-To: <20160819132427.GD9893@arm.com> (Will Deacon's message of "Fri, 19 Aug 2016 14:24:28 +0100") Message-ID: <87r39kswzj.fsf@e105922-lin.cambridge.arm.com> User-Agent: Gnus/5.13 (Gnus v5.13) Emacs/24.5 (gnu/linux) MIME-Version: 1.0 Content-Type: text/plain Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org Will Deacon writes: > On Tue, Aug 16, 2016 at 11:45:09AM +0100, Punit Agrawal wrote: >> From: Mark Rutland >> >> As with dsb() and isb(), add a __tbli() helper so that we can avoid > > Minor typo: s/__tbli/__tlbi/ Thanks for spotting. I've fixed this locally now. > >> distracting asm boilerplate every time we want a TLBI. As some TLBI >> operations take an argument while others do not, some pre-processor is >> used to handle these two cases with different assembly blocks. >> >> The existing tlbflush.h code is moved over to use the helper. >> >> Signed-off-by: Mark Rutland >> Cc: Catalin Marinas >> Cc: Marc Zyngier >> Cc: Will Deacon >> [ rename helper to __tlbi, update commit log ] >> Signed-off-by: Punit Agrawal >> --- >> arch/arm64/include/asm/tlbflush.h | 31 +++++++++++++++++++++++-------- >> 1 file changed, 23 insertions(+), 8 deletions(-) >> >> diff --git a/arch/arm64/include/asm/tlbflush.h b/arch/arm64/include/asm/tlbflush.h >> index b460ae2..d57a0be 100644 >> --- a/arch/arm64/include/asm/tlbflush.h >> +++ b/arch/arm64/include/asm/tlbflush.h >> @@ -25,6 +25,21 @@ >> #include >> >> /* >> + * Raw TLBI operations. Drivers and most kernel code should use the TLB >> + * management routines below in preference to these. Where necessary, these can >> + * be used to avoid asm() boilerplate. >> + * >> + * Can be used as __tlbi(op) or __tlbi(op, arg), depending on whether a >> + * particular TLBI op takes an argument or not. The macros below handle invoking >> + * the asm with or without the register argument as appropriate. >> + */ >> +#define TLBI_0(op, arg) asm ("tlbi " #op) >> +#define TLBI_1(op, arg) asm ("tlbi " #op ", %0" : : "r" (arg)) >> +#define TLBI_N(op, arg, n, ...) TLBI_##n(op, arg) > > Should this be prefixed with underscores, too? As these were only used in the definition of __tlbi() I didn't prefix them. I'll add them for the next posting. Thanks for taking a look. Punit > > Will > _______________________________________________ > kvmarm mailing list > kvmarm@lists.cs.columbia.edu > https://lists.cs.columbia.edu/mailman/listinfo/kvmarm