linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Kalle Valo <kvalo@codeaurora.org>
To: Kai-Heng Feng <kai.heng.feng@canonical.com>
Cc: yhchuang@realtek.com, "David S. Miller" <davem@davemloft.net>,
	linux-wireless@vger.kernel.org (open list:REALTEK WIRELESS
	DRIVER (rtw88)),
	netdev@vger.kernel.org (open list:NETWORKING DRIVERS),
	linux-kernel@vger.kernel.org (open list)
Subject: Re: [PATCH] rtw88: Add delay on polling h2c command status bit
Date: Mon, 06 Apr 2020 15:17:02 +0300	[thread overview]
Message-ID: <87v9mczu4h.fsf@kamboji.qca.qualcomm.com> (raw)
In-Reply-To: <20200406093623.3980-1-kai.heng.feng@canonical.com> (Kai-Heng Feng's message of "Mon, 6 Apr 2020 17:36:22 +0800")

Kai-Heng Feng <kai.heng.feng@canonical.com> writes:

> On some systems we can constanly see rtw88 complains:
> [39584.721375] rtw_pci 0000:03:00.0: failed to send h2c command
>
> Increase interval of each check to wait the status bit really changes.
>
> While at it, add some helpers so we can use standarized
> readx_poll_timeout() macro.

One logical change per patch, please.

> --- a/drivers/net/wireless/realtek/rtw88/hci.h
> +++ b/drivers/net/wireless/realtek/rtw88/hci.h
> @@ -253,6 +253,10 @@ rtw_write8_mask(struct rtw_dev *rtwdev, u32 addr, u32 mask, u8 data)
>  	rtw_write8(rtwdev, addr, set);
>  }
>  
> +#define rr8(addr)      rtw_read8(rtwdev, addr)
> +#define rr16(addr)     rtw_read16(rtwdev, addr)
> +#define rr32(addr)     rtw_read32(rtwdev, addr)

For me these macros reduce code readability, not improve anything. They
hide the use of rtwdev variable, which is evil, and a name like rr8() is
just way too vague. Please keep the original function names as is.

-- 
https://wireless.wiki.kernel.org/en/developers/documentation/submittingpatches

  parent reply	other threads:[~2020-04-06 12:17 UTC|newest]

Thread overview: 9+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-04-06  9:36 [PATCH] rtw88: Add delay on polling h2c command status bit Kai-Heng Feng
2020-04-06 11:01 ` Tony Chuang
2020-04-06 11:56   ` Kai-Heng Feng
2020-04-06 12:17 ` Kalle Valo [this message]
2020-04-06 13:18   ` Kai-Heng Feng
2020-04-06 13:24     ` Kalle Valo
2020-04-06 13:35       ` Kai-Heng Feng
2020-04-06 14:03         ` Kalle Valo
2020-04-07  7:20           ` Kai-Heng Feng

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=87v9mczu4h.fsf@kamboji.qca.qualcomm.com \
    --to=kvalo@codeaurora.org \
    --cc=davem@davemloft.net \
    --cc=kai.heng.feng@canonical.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-wireless@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=yhchuang@realtek.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).