linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-01-13 17:01:24 to 2020-01-13 19:28:44 UTC [more...]

[ANNOUNCE] Git v2.25.0
 2020-01-13 19:28 UTC 

[PATCH] hv_netvsc: Fix memory leak when removing rndis device
 2020-01-13 19:27 UTC 

[PATCH 0/4] introduce memory hinting API for external process
 2020-01-13 19:27 UTC  (11+ messages)
` [PATCH 2/4] mm: introduce external memory hinting API

[PATCH -tip V2 0/2] kprobes: Fix RCU warning and cleanup
 2020-01-13 19:23 UTC  (9+ messages)

linux-next: Tree for Jan 13
 2020-01-13 19:23 UTC  (3+ messages)
` BUG_ON hit in "reimplement path_mountpoint() with less magic" [Was: Re: linux-next: Tree for Jan 13]

[PATCH] HID: logitech-dj: add debug msg when exporting a HID++ report descriptors
 2020-01-13 19:23 UTC 

[PATCH v3] media: dvb_dummy_tuner: implement driver skeleton
 2020-01-13 19:19 UTC 

[PATCH v2 0/2] rxe should use same buffer size for SGE's and inline data
 2020-01-13 19:16 UTC  (12+ messages)
` [PATCH v2 1/2] Introduce maximum WQE size to check limits

[PATCHv8 26/34] x86/vdso: Zap vvar pages on switch a time namspace
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] x86/vdso: Zap vvar pages when switching to a time namespace

[PATCHv8 30/34] selftests/timens: Add a test for clock_nanosleep()
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 25/34] x86/vdso: On timens page fault prefault also VVAR page
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 32/34] selftests/timens: Add timer offsets test
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 28/34] selftests/timens: Add Time Namespace test for supported clocks
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 14/34] posix-timers: Make timer_settime() time namespace aware
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 15/34] alarmtimer: Make nanosleep time namespace aware
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] alarmtimer: Make nanosleep() "

[PATCHv8 17/34] posix-timers: Make clock_nanosleep() time namespace aware
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 29/34] selftests/timens: Add a test for timerfd
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 23/34] time: Allocate per-timens vvar page
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 11/34] posix-clocks: Wire up clock_gettime() with timens offsets
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 10/34] posix-timers: Use clock_get_ktime() in common_timer_get()
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 24/34] x86/vdso: Handle faults on timens page
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 08/34] alarmtimer: Provide get_timespec() callback
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 27/34] fs/proc: Introduce /proc/pid/timens_offsets
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 16/34] hrtimers: Prepare hrtimer_nanosleep() for time namespaces
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 12/34] kernel: Add do_timens_ktime_to_host() helper
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] time: "

[PATCHv8 13/34] timerfd: Make timerfd_settime() time namespace aware
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 21/34] x86/vdso: Provide vdso_data offset on vvar_page
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 09/34] posix-clocks: Introduce clock_get_ktime() callback
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCH] MIPS: Loongson: Fix potential NULL dereference in loongson3_platform_init()
 2020-01-13 19:10 UTC  (2+ messages)

[PATCH] MIPS: ip22-gio: Make gio_match_device() static
 2020-01-13 19:10 UTC  (2+ messages)

[PATCH] tc: Make tc_match_device() static
 2020-01-13 19:10 UTC  (2+ messages)

[PATCH 08/10] soc: lantiq: convert to devm_platform_ioremap_resource
 2020-01-13 19:10 UTC  (2+ messages)

[PATCHv8 22/34] x86/vdso: Add timens page
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] x86/vdso: Add time napespace page

[PATCHv8 05/34] posix-clocks: Rename the clock_get() callback to clock_get_timespec()
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCH v2 8/8] x86: vdso: Remove unused VDSO_HAS_32BIT_FALLBACK
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] x86/vdso: "

[PATCHv8 04/34] time: Add timens_offsets to be used for tasks in timens
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] time: Add timens_offsets to be used for tasks in time namespace

[PATCHv8 02/34] lib/vdso: make do_hres and do_coarse as __always_inline
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] lib/vdso: Mark do_hres() and do_coarse() "

[PATCH v2 4/8] lib: vdso: Remove VDSO_HAS_32BIT_FALLBACK
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] lib/vdso: "

[PATCHv8 07/34] alarmtimer: Rename gettime() callback to get_ktime()
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[tip: timers/core] lib/vdso: Avoid duplication in __cvdso_clock_getres()
 2020-01-13 19:09 UTC 

[PATCHv8 03/34] ns: Introduce Time Namespace
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCH v2 7/8] mips: vdso: Remove unused VDSO_HAS_32BIT_FALLBACK
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[tip: timers/core] lib/vdso: Let do_coarse() return 0 to simplify the callsite
 2020-01-13 19:09 UTC 

[PATCHv8 01/34] lib/vdso: Add unlikely() hint into vdso_read_begin()
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCH v2 5/8] lib: vdso: Remove checks on return value for 32 bit vDSO
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] lib/vdso: "

[PATCH v2 1/8] arm64: compat: vdso: Expose BUILD_VDSO32
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCH v2 2/8] lib: vdso: Build 32 bit specific functions in the right context
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] lib/vdso: "

[PATCHv8 18/34] fs/proc: Respect boottime inside time namespace for /proc/uptime
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 06/34] posix-clocks: Rename .clock_get_timespec() callbacks accordingly
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCH v2 6/8] arm64: compat: vdso: Remove unused VDSO_HAS_32BIT_FALLBACK
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 19/34] x86/vdso: Restrict splitting VVAR VMA
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 20/34] lib/vdso: Prepare for time namespace support
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 33/34] selftests/timens: Add a simple perf test for clock_gettime()
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 34/34] selftests/timens: Check for right timens offsets after fork and exec
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCHv8 31/34] selftests/timens: Add procfs selftest
 2020-01-13 19:09 UTC  (2+ messages)
` [tip: timers/core] "

[PATCH] mwifiex: drop most magic numbers from mwifiex_process_tdls_action_frame()
 2020-01-13 19:05 UTC  (2+ messages)

[RESEND PATCH v10 00/10] Enable Sub-Page Write Protection Support
 2020-01-13 18:55 UTC  (6+ messages)
` [RESEND PATCH v10 06/10] vmx: spp: Set up SPP paging table at vmentry/vmexit

[PATCH v2] sched/core: fix illegal RCU from offline CPUs
 2020-01-13 19:03 UTC 

[PATCH 1/1] rcu/tree: support kfree_bulk() interface in kfree_rcu()
 2020-01-13 19:03 UTC  (2+ messages)

[PATCH v1 0/3] scsi: ufs: fix error history and complete device reset history
 2020-01-13 18:59 UTC  (3+ messages)
` [PATCH v1 2/3] scsi: ufs: add device reset history for vendor implementations

[PATCH 1/2] MIPS: Define pgprot_dmacoherent according to coherentio status
 2020-01-13 18:52 UTC  (3+ messages)
` [PATCH 2/2] MIPS: Loongson64: Add dma iocoherency detection support

[PATCH v5 00/19] x86/cpu: Clean up handling of VMX features
 2020-01-13 18:52 UTC  (7+ messages)
` [PATCH v5 17/19] KVM: VMX: Use VMX_FEATURE_* flags to define VMCS control bits
          ` [PATCH] KVM: VMX: Rename define to CPU_BASED_USE_TSC_OFFSETTING

[PATCH v2 0/4] drm/msm: use firmware-name to find zap fw
 2020-01-13 18:46 UTC  (9+ messages)
` [PATCH v2 1/4] drm/msm: support firmware-name for zap fw (v2)
` [PATCH v2 2/4] drm/msm: allow zapfw to not be specified in gpulist
` [PATCH v2 4/4] arm64: dts: sdm845: move gpu zap nodes to per-device dts

[PATCH v4 1/1] usb: gadget: add raw-gadget interface
 2020-01-13 18:45 UTC  (5+ messages)

[PATCH v1 0/3] use UFS device indicated maximum LU number
 2020-01-13 18:45 UTC  (7+ messages)
` [PATCH 1/3] scsi: ufs: add max_lu_supported in struct ufs_dev_info
` [PATCH 2/3] scsi: ufs: initialize max_lu_supported while booting
` [PATCH 3/3] scsi: ufs: use UFS device indicated maximum LU number

[PATCH] arm: dts: Move am33xx and am43xx mmc nodes to sdhci-omap driver
 2020-01-13 18:44 UTC  (3+ messages)

[PATCH v9 1/8] hugetlb_cgroup: Add hugetlb_cgroup reservation counter
 2020-01-13 18:43 UTC  (2+ messages)

[PATCH v5 1/2] perf parse: Refactor struct perf_evsel_config_term
 2020-01-13 18:43 UTC  (3+ messages)

[PATCH v2] media: dvb_dummy_tuner: implement driver skeleton
 2020-01-13 18:43 UTC  (4+ messages)

[GIT PULL rcu/next + kcsan] RCU and KCSAN commits for v5.6
 2020-01-13 18:42 UTC 

[bug report] resctrl high memory comsumption
 2020-01-13 18:38 UTC  (6+ messages)

[WIP PATCH 0/4] Support for UDF 1.01 and 2.60 revisions
 2020-01-13 18:37 UTC  (7+ messages)
` [WIP PATCH 1/4] udf: Do not access LVIDIU revision members when they are not filled
` [WIP PATCH 2/4] udf: Fix reading numFiles and numDirs from UDF 2.00+ VAT discs

[RFC PATCH v1 00/10] Enable RK3066 NANDC for MK808
 2020-01-13 18:33 UTC  (3+ messages)
` [RFC PATCH v1 00/10] Enable RK3066 NANDC for MK808【请注意,邮件由linux-rockchip-bounces+shawn.lin=rock-chips.com@lists.infradead.org代发】

[PATCH net-next] net: phy: Maintain MDIO device and bus statistics
 2020-01-13 18:29 UTC  (4+ messages)

[PATCH 5.4 000/165] 5.4.11-stable review
 2020-01-13 18:27 UTC  (3+ messages)

[PATCH] Input: keyspan-remote: fix control-message timeouts
 2020-01-13 18:26 UTC  (2+ messages)

[PATCH] media: usbtv: fix control-message timeouts
 2020-01-13 18:26 UTC  (3+ messages)

[PATCH] USB: serial: opticon: fix control-message timeouts
 2020-01-13 18:25 UTC  (2+ messages)

[PATCH] NFC: pn533: fix bulk-message timeout
 2020-01-13 18:25 UTC  (2+ messages)

[PATCH 0/2] drm/msm: Add the MSM_WAIT_IOVA ioctl
 2020-01-13 18:23 UTC  (7+ messages)
` [PATCH 1/2] drm/msm: Add a GPU-wide wait queue
  ` [Freedreno] "
` [PATCH 2/2] drm/msm: Add MSM_WAIT_IOVA ioctl
  ` [Freedreno] "

[PATCH 1/4] mm: factor out madvise's core functionality
 2020-01-13 18:22 UTC  (4+ messages)
    `  "

[PATCH v2] PM / devfreq: Add debugfs support with devfreq_summary file
 2020-01-13 18:18 UTC  (2+ messages)

[PATCH v2 0/2] Add mt8173 elm and hana board
 2020-01-13 18:18 UTC  (6+ messages)
` [PATCH v2 2/2] arm64: dts: mediatek: add "

[RFC PATCH 0/3] Add device tree build information
 2020-01-13 18:16 UTC  (4+ messages)
` [RFC PATCH 1/3] dtc: Add dtb build information option
` [RFC PATCH 2/3] of: fdt: print dtb build information
` [RFC PATCH 3/3] scripts: Use -B dtc option to generate "

[PATCH v3 1/2] ARM: dts: Add dtsi files for AM3703, AM3715 and DM3725
 2020-01-13 18:15 UTC  (3+ messages)
` [PATCH v3 2/2] ARM: dts: Add omap3-echo

[PATCH V3 0/5] Add support for PCIe endpoint mode in Tegra194
 2020-01-13 18:14 UTC  (6+ messages)
` [PATCH V3 1/5] soc/tegra: bpmp: Update ABI header
` [PATCH V3 2/5] dt-bindings: PCI: tegra: Add DT support for PCIe EP nodes in Tegra194
` [PATCH V3 3/5] arm64: tegra: Add PCIe endpoint controllers nodes for Tegra194
` [PATCH V3 4/5] arm64: tegra: Add support for PCIe endpoint mode in P2972-0000 platform
` [PATCH V3 5/5] PCI: tegra: Add support for PCIe endpoint mode in Tegra194

[PATCH V2 0/5] Add support for PCIe endpoint mode in Tegra194
 2020-01-13 18:12 UTC  (6+ messages)
` [PATCH V2 3/5] PCI: tegra: "
    `  "

[PATCH] x86/tools/relocs: Add _etext and __end_of_kernel_reserve to S_REL
 2020-01-13 18:08 UTC  (10+ messages)

[PATCH] arm64: dts: allwinner: h6: tanix-tx6: Use internal oscillator
 2020-01-13 18:07 UTC 

[PATCH v4 0/4] Use ARM SMC Calling Convention when OP-TEE is available
 2020-01-13 18:05 UTC  (2+ messages)

[PATCH v2 1/2] platform/x86: Add support for Uncore frequency control
 2020-01-13 18:03 UTC  (3+ messages)

[PATCH v3 0/2] Intel Uncore frequency control
 2020-01-13 18:00 UTC  (3+ messages)
` [PATCH v3 1/2] platform/x86: Add support for "
` [PATCH v3 2/2] MAINTAINERS: Update for the intel uncore "

[PATCH v4 13/14] dt-bindings: phy: Document WIZ (SERDES wrapper) bindings
 2020-01-13 17:59 UTC  (3+ messages)
` [PATCH v5 "

[PATCH v10 0/2] phy: intel-lgm-emmc: Add support for eMMC PHY
 2020-01-13 17:55 UTC  (3+ messages)
` [PATCH v10 1/2] dt-bindings: phy: intel-emmc-phy: Add YAML schema for LGM "

linux-next: Signed-off-by missing for commit in the arm-soc tree
 2020-01-13 17:52 UTC  (6+ messages)

[PATCH 1/2] DT: bindings: Add cooling cells for idle states
 2020-01-13 17:52 UTC  (5+ messages)

[PATCH] arm: dts: am335x-boneblack-common: fix memory size
 2020-01-13 17:50 UTC  (6+ messages)

[PATCH][next][V2] dmaengine: ti: omap-dma: don't allow a null od->plat pointer to be dereferenced
 2020-01-13 17:46 UTC  (4+ messages)

[PATCH] tools: perf: fix augmented syscall format warning
 2020-01-13 17:44 UTC 

[RFC PATCH 0/8] Rework READ_ONCE() to improve codegen
 2020-01-13 17:42 UTC  (5+ messages)
` [RFC PATCH 6/8] READ_ONCE: Drop pointer qualifiers when reading from scalar types

drm_cflush_sg() loops for over 3ms - scheduler not running tasks
 2020-01-13 17:39 UTC 

[PATCH] dt-bindings: pinctrl: intel: Update to use generic bindings
 2020-01-13 17:38 UTC  (2+ messages)

[PATCH 0/2] fs: btrfs: Introduce deleting subvolume by subvolid
 2020-01-13 17:37 UTC  (3+ messages)
` [PATCH 2/2] btrfs: Introduce new BTRFS_IOC_SNAP_DESTROY_V2 ioctl

[PATCH v3 1/3] dt-bindings: vendor-prefixes: Add Shenzhen Frida LCD Co., Ltd
 2020-01-13 17:33 UTC  (6+ messages)
` [PATCH v3 2/3] dt-bindings: panel-simple: Add compatible for Frida FRD350H54004 LCD
` [PATCH v3 3/3] drm/panel: simple: Add support for the Frida FRD350H54004 panel

[PATCH v2 1/4] iio: adc: ad7606: Add support for AD7606B ADC
 2020-01-13 17:32 UTC  (3+ messages)
` [PATCH v2 3/4] dt-bindings: iio: adc: Migrate AD7606 documentation to yaml

[PATCH] i2c: iop3xx: Fix memory leak in probe error path
 2020-01-13 17:29 UTC 

linux-next: build failure after merge of the block tree
 2020-01-13 17:26 UTC  (5+ messages)

[PATCH] net: mellanox: prevent resource leak on htbl
 2020-01-13 17:25 UTC  (3+ messages)

[PATCH v2] rpmsg: core: add API to get MTU
 2020-01-13 17:24 UTC  (2+ messages)

[GIT PULL 00/13] More EFI updates for v5.6
 2020-01-13 17:22 UTC  (14+ messages)
` [PATCH 01/13] efi/libstub/x86: use const attribute for efi_is_64bit()
` [PATCH 02/13] efi/libstub/x86: use mandatory 16-byte stack alignment in mixed mode
` [PATCH 03/13] efi/libstub/x86: fix unused-variable warning
` [PATCH 04/13] x86/mm: fix NX bit clearing issue in kernel_map_pages_in_pgd
` [PATCH 05/13] efi/x86: don't map the entire kernel text RW for mixed mode
` [PATCH 06/13] efi/x86: avoid RWX mappings for all of DRAM
` [PATCH 07/13] efi/x86: limit EFI old memory map to SGI UV machines
` [PATCH 08/13] efi/arm: defer probe of PCIe backed efifb on DT systems
` [PATCH 09/13] efi: Fix comment for efi_mem_type() wrt absent physical addresses
` [PATCH 10/13] efi: Add a flags parameter to efi_memory_map
` [PATCH 11/13] efi: Add tracking for dynamically allocated memmaps
` [PATCH 12/13] efi: Fix efi_memmap_alloc() leaks
` [PATCH 13/13] efi: Fix handling of multiple efi_fake_mem= entries

[PATCH] xfs: Fix xfs_dir2_sf_entry_t size check
 2020-01-13 17:26 UTC  (11+ messages)

[PATCH 1/7] builddeb: remove unneeded files in hdrobjfiles for headers package
 2020-01-13 17:21 UTC  (3+ messages)
` [PATCH 4/7] builddeb: avoid invoking sub-shells where possible

[PATCH] media: davinci: remove self assignment in vpfe
 2020-01-13 17:20 UTC 

[PATCH 0/2] PM / devfreq: Add debugfs support
 2020-01-13 17:19 UTC  (6+ messages)
  ` [PATCH 2/2] PM / devfreq: Add devfreq_transitions debugfs file

[RFC v5 00/57] objtool: Add support for arm64
 2020-01-13 17:18 UTC  (3+ messages)

[PATCH v6 0/4] Add regulator support for mpq7920
 2020-01-13 17:14 UTC  (3+ messages)
` [PATCH v6 1/4] dt-bindings: Add an entry for Monolithic Power System, MPS

[PATCH v3] xen-pciback: optionally allow interrupt enable flag writes
 2020-01-13 17:11 UTC 

[PATCH RFT v1 0/3] devfreq fixes for panfrost
 2020-01-13 17:10 UTC  (5+ messages)
` [PATCH RFT v1 3/3] drm/panfrost: Use the mali-supply regulator for control again

[RFC PATCH v4] ceph: use 'copy-from2' operation in copy_file_range
 2020-01-13 17:10 UTC  (3+ messages)

[RFC PATCH v3 00/12] powerpc: switch VDSO to C implementation
 2020-01-13 17:08 UTC  (13+ messages)
` [RFC PATCH v3 01/12] powerpc/64: Don't provide time functions in compat VDSO32
` [RFC PATCH v3 02/12] powerpc/vdso: Switch VDSO to generic C implementation
` [RFC PATCH v3 03/12] lib: vdso: mark __cvdso_clock_getres() as static
` [RFC PATCH v3 04/12] lib: vdso: inline do_hres() and do_coarse()
` [RFC PATCH v3 05/12] lib: vdso: Avoid duplication in __cvdso_clock_getres()
` [RFC PATCH v3 06/12] lib: vdso: __iter_div_u64_rem() is suboptimal for 32 bit time
` [RFC PATCH v3 07/12] powerpc/vdso: simplify __get_datapage()
` [RFC PATCH v3 08/12] lib: vdso: allow arches to provide vdso data pointer
` [RFC PATCH v3 09/12] powerpc/vdso: provide inline alternative to __get_datapage()
` [RFC PATCH v3 10/12] powerpc/vdso: provide vdso data pointer from the ASM caller
` [RFC PATCH v3 11/12] lib: vdso: split clock verification out of __arch_get_hw_counter()
` [RFC PATCH v3 12/12] powerpc/vdso: provide __arch_is_hw_counter_valid()

[RFC PATCH] PCI, kdump: Clear bus master bit upon shutdown in kdump kernel
 2020-01-13 17:07 UTC  (9+ messages)

[RFC PATCH v3 00/12] Unify SMP stop generic logic to common code
 2020-01-13 17:05 UTC  (3+ messages)

[PATCH 1/2] mfd: madera: Allow more time for hardware reset
 2020-01-13 17:02 UTC  (6+ messages)
` [PATCH 2/2] mfd: madera: Wait for boot done before accessing any other registers


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).