linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2020-03-13 23:54:09 to 2020-03-15 01:36:04 UTC [more...]

[PATCH] mm/swap_state.c: use the same way to count page in [add_to|delete_from]_swap_cache
 2020-03-15  1:23 UTC  (3+ messages)

[PATCH] perf mem2node: avoid double free related to realloc
 2020-03-14 14:23 UTC  (2+ messages)

[PATCH] perf parse-events: fix 3 use after frees
 2020-03-14 16:54 UTC  (3+ messages)

[PATCH v6 0/3] Add modem Clock controller (MSS CC) driver for SC7180
 2020-03-14 18:39 UTC  (2+ messages)
` [PATCH v6 3/3] clk: qcom: Add modem clock controller "

[PATCH v4 00/18] x86: syscall wrapper cleanups
 2020-03-14 13:42 UTC  (5+ messages)
` [PATCH v4 07/18] x86-64: Split X32 syscall table into its own file
` [PATCH v4 09/18] x86-64: Remove ptregs qualifier from syscall table

[PATCH v3 0/3] drm: Add support for Chrontel CH7033 VGA/DVI Encoder
 2020-03-14 10:16 UTC  (3+ messages)
` [PATCH v3 1/3] dt-bindings: Add vendor prefix for Chrontel, Inc
` [PATCH v3 3/3] drm/bridge: chrontel-ch7033: Add a new driver

[PATCH v3 00/12] NXP DSPI bugfixes and support for LS1028A
 2020-03-14 22:43 UTC  (4+ messages)
` [PATCH v3 07/12] spi: spi-fsl-dspi: Avoid NULL pointer in dspi_slave_abort for non-DMA mode
` [PATCH v3 08/12] spi: spi-fsl-dspi: Fix interrupt-less DMA mode taking an XSPI code path
` [PATCH v3 11/12] arm64: dts: ls1028a: Specify the DMA channels for the DSPI controllers

[PATCHv2] exec: Fix a deadlock in ptrace
 2020-03-14 10:02 UTC  (23+ messages)
` [PATCHv5] "
          ` [PATCHv6] "
              ` [PATCH 0/2] Infrastructure to allow fixing exec deadlocks
                ` [PATCH 0/5] "
                  ` [PATCH v2 5/5] exec: Add a exec_update_mutex to replace cred_guard_mutex
                                ` [PATCH v3 "
                                ` [PATCH 0/2] exec: Fix dead-lock in de_thread with ptrace_attach
                                ` [PATCH 1/2] "
                                ` [PATCH 2/2] doc: Update documentation of ->exec_*_mutex

[PATCH] x86/acpi: make "asmlinkage" part first thing in the function definition
 2020-03-14  9:33 UTC  (2+ messages)

[PATCH] rtc: snvs: remove redundant error message
 2020-03-15  0:47 UTC 

[PATCH v6 00/10] Subject: Enable Linux guests on Hyper-V on ARM64
 2020-03-14 15:35 UTC  (11+ messages)
` [PATCH v6 01/10] arm64: hyperv: Add core Hyper-V include files
` [PATCH v6 02/10] arm/arm64: smccc-1.1: Add vendor specific owner definition
` [PATCH v6 03/10] arm64: hyperv: Add hypercall and register access functions
` [PATCH v6 04/10] arm64: hyperv: Add memory alloc/free functions for Hyper-V size pages
` [PATCH v6 05/10] arm64: hyperv: Add interrupt handlers for VMbus and stimer
` [PATCH v6 06/10] arm64: hyperv: Add kexec and panic handlers
` [PATCH v6 07/10] arm64: hyperv: Initialize hypervisor on boot
` [PATCH v6 08/10] Drivers: hv: vmbus: Add hooks for per-CPU IRQ
` [PATCH v6 09/10] arm64: efi: Export screen_info
` [PATCH v6 10/10] Drivers: hv: Enable Hyper-V code to be built on ARM64

How to create a Bootable Live CD/DVD from your Linux From Scratch (LFS) build
 2020-03-14 16:04 UTC 

[PATCH] add ALWAYS_POLL quirk to lenovo pixart mouse
 2020-03-15  1:07 UTC  (5+ messages)

[PATCH v2 3/5] exec: Move cleanup of posix timers on exec out of de_thread
 2020-03-14  9:12 UTC  (12+ messages)
      ` [PATCH] pidfd: Stop taking cred_guard_mutex
                    ` [PATCH] pidfd: Use new infrastructure to fix deadlocks in execve

[PATCH] x86/module: Fixed bug allowing invalid relocation addresses
 2020-03-14 21:36 UTC 

[PATCH] locking/lockdep: Avoid recursion in lockdep_count_{for,back}ward_deps()
 2020-03-15  1:04 UTC  (3+ messages)

[Patch v2] mm/swap_state.c: use the same way to count page in [add_to|delete_from]_swap_cache
 2020-03-15  1:29 UTC 

[PATCH v6 0/3] Add modem Clock controller (MSS CC) driver for SC7180
 2020-03-14 18:49 UTC 

[PATCH v28 00/22] Intel SGX foundations
 2020-03-15  1:25 UTC  (4+ messages)
` [PATCH v28 21/22] x86/vdso: Implement a vDSO for Intel SGX enclave call

WARNING in idr_destroy
 2020-03-14  4:02 UTC  (4+ messages)

WARNING in call_rcu
 2020-03-14  3:52 UTC  (2+ messages)

[PATCH net-next 00/11] net: ethernet: ti: cpts: add irq and HW_TS_PUSH events
 2020-03-14  3:50 UTC  (5+ messages)
` [PATCH net-next 06/11] net: ethernet: ti: cpts: move tx timestamp processing to ptp worker only
` [PATCH net-next 09/11] net: ethernet: ti: cpts: add irq support

[RFC bpf-next 0/2] sharing bpf runtime stats with /dev/bpf_stats
 2020-03-14  3:47 UTC  (2+ messages)

[PATCH v6 00/11] Add the multiple PF support for DWC and Layerscape
 2020-03-14  3:30 UTC  (12+ messages)
` [PATCH v6 01/11] PCI: designware-ep: Add multiple PFs support for DWC
` [PATCH v6 02/11] PCI: designware-ep: Add the doorbell mode of MSI-X in EP mode
` [PATCH v6 03/11] PCI: designware-ep: Move the function of getting MSI capability forward
` [PATCH v6 04/11] PCI: designware-ep: Modify MSI and MSIX CAP way of finding
` [PATCH v6 05/11] dt-bindings: pci: layerscape-pci: Add compatible strings for ls1088a and ls2088a
` [PATCH v6 06/11] PCI: layerscape: Fix some format issue of the code
` [PATCH v6 07/11] PCI: layerscape: Modify the way of getting capability with different PEX
` [PATCH v6 08/11] PCI: layerscape: Modify the MSIX to the doorbell mode
` [PATCH v6 09/11] PCI: layerscape: Add EP mode support for ls1088a and ls2088a
` [PATCH v6 10/11] arm64: dts: layerscape: Add PCIe EP node for ls1088a
` [PATCH v6 11/11] misc: pci_endpoint_test: Add LS1088a in pci_device_id table

[PATCH 1/2] cdc_ncm: Implement the 32-bit version of NCM Transfer Block
 2020-03-14  3:43 UTC  (4+ messages)
` [PATCH 2/2] cdc_ncm: Fix the build warning

WARNING: ODEBUG bug in route4_change
 2020-03-14  3:36 UTC  (2+ messages)

[PATCH 0/3] arm64: tlb: skip tlbi broadcast v2
 2020-03-14  3:16 UTC  (4+ messages)
` [PATCH 3/3] arm64: tlb: skip tlbi broadcast

[PATCH v1 0/2] scsi: ufs: add error recovery for suspend and resume in ufs-mediatek
 2020-03-14  3:16 UTC  (3+ messages)
` [PATCH v1 1/2] scsi: ufs: export ufshcd_link_recovery for vendor's error recovery
` [PATCH v1 2/2] scsi: ufs-mediatek: add error recovery for suspend and resume

[PATCH v3 0/3] update to latest PMU events for zen1/zen2
 2020-03-14  3:13 UTC  (4+ messages)
` [PATCH v3 3/3] perf vendor events amd: update Zen1 events to V2

[PATCH] kernel/hung_task.c: Introduce sysctl to print all traces when a hung task is detected
 2020-03-14  3:12 UTC  (3+ messages)

WARNING: ODEBUG bug in tcf_queue_work
 2020-03-14  3:06 UTC  (2+ messages)

WARNING: refcount bug in sctp_wfree
 2020-03-14  2:59 UTC  (6+ messages)

[PATCH] timer: silenct a lockdep splat with debugobjects
 2020-03-14  2:53 UTC  (7+ messages)

[locks] 6d390e4b5d: will-it-scale.per_process_ops -96.6% regression
 2020-03-14  2:31 UTC  (25+ messages)

[RFC][PATCHSET] sanitized pathwalk machinery (v2)
 2020-03-14  2:27 UTC  (80+ messages)
` [RFC][PATCHSET] sanitized pathwalk machinery (v3)
  ` [RFC][PATCHSET] sanitized pathwalk machinery (v4)
    ` [RFC][PATCH v4 01/69] do_add_mount(): lift lock_mount/unlock_mount into callers
      ` [RFC][PATCH v4 02/69] fix automount/automount race properly
      ` [RFC][PATCH v4 03/69] follow_automount(): get rid of dead^Wstillborn code
      ` [RFC][PATCH v4 05/69] make build_open_flags() treat O_CREAT | O_EXCL as implying O_NOFOLLOW
      ` [RFC][PATCH v4 06/69] handle_mounts(): start building a sane wrapper for follow_managed()
      ` [RFC][PATCH v4 07/69] atomic_open(): saner calling conventions (return dentry on success)
      ` [RFC][PATCH v4 08/69] lookup_open(): "
      ` [RFC][PATCH v4 09/69] do_last(): collapse the call of path_to_nameidata()
      ` [RFC][PATCH v4 10/69] handle_mounts(): pass dentry in, turn path into a pure out argument
      ` [RFC][PATCH v4 11/69] lookup_fast(): consolidate the RCU success case
      ` [RFC][PATCH v4 12/69] teach handle_mounts() to handle RCU mode
      ` [RFC][PATCH v4 13/69] lookup_fast(): take mount traversal into callers
      ` [RFC][PATCH v4 14/69] step_into() callers: dismiss the symlink earlier
      ` [RFC][PATCH v4 15/69] new step_into() flag: WALK_NOFOLLOW
      ` [RFC][PATCH v4 16/69] fold handle_mounts() into step_into()
      ` [RFC][PATCH v4 17/69] LOOKUP_MOUNTPOINT: fold path_mountpointat() into path_lookupat()
      ` [RFC][PATCH v4 18/69] expand the only remaining call of path_lookup_conditional()
      ` [RFC][PATCH v4 19/69] merging pick_link() with get_link(), part 1
      ` [RFC][PATCH v4 20/69] merging pick_link() with get_link(), part 2
      ` [RFC][PATCH v4 21/69] merging pick_link() with get_link(), part 3
      ` [RFC][PATCH v4 22/69] merging pick_link() with get_link(), part 4
      ` [RFC][PATCH v4 23/69] merging pick_link() with get_link(), part 5
      ` [RFC][PATCH v4 24/69] merging pick_link() with get_link(), part 6
      ` [RFC][PATCH v4 25/69] finally fold get_link() into pick_link()
      ` [RFC][PATCH v4 26/69] sanitize handling of nd->last_type, kill LAST_BIND
      ` [RFC][PATCH v4 27/69] namei: invert the meaning of WALK_FOLLOW
      ` [RFC][PATCH v4 28/69] pick_link(): check for WALK_TRAILING, not LOOKUP_PARENT
      ` [RFC][PATCH v4 29/69] link_path_walk(): simplify stack handling
      ` [RFC][PATCH v4 30/69] namei: have link_path_walk() maintain LOOKUP_PARENT
      ` [RFC][PATCH v4 31/69] massage __follow_mount_rcu() a bit
      ` [RFC][PATCH v4 32/69] new helper: traverse_mounts()
      ` [RFC][PATCH v4 33/69] atomic_open(): return the right dentry in FMODE_OPENED case
      ` [RFC][PATCH v4 34/69] atomic_open(): lift the call of may_open() into do_last()
      ` [RFC][PATCH v4 35/69] do_last(): merge the may_open() calls
      ` [RFC][PATCH v4 36/69] do_last(): don't bother with keeping got_write in FMODE_OPENED case
      ` [RFC][PATCH v4 37/69] do_last(): rejoing the common path earlier in FMODE_{OPENED,CREATED} case
      ` [RFC][PATCH v4 38/69] do_last(): simplify the liveness analysis past finish_open_created
      ` [RFC][PATCH v4 39/69] do_last(): rejoin the common path even earlier in FMODE_{OPENED,CREATED} case
      ` [RFC][PATCH v4 40/69] split the lookup-related parts of do_last() into a separate helper
      ` [RFC][PATCH v4 41/69] path_connected(): pass mount and dentry separately
      ` [RFC][PATCH v4 42/69] path_parent_directory(): leave changing path->dentry to callers
      ` [RFC][PATCH v4 43/69] expand path_parent_directory() in its callers
      ` [RFC][PATCH v4 44/69] follow_dotdot{,_rcu}(): lift switching nd->path to parent out of loop
      ` [RFC][PATCH v4 45/69] follow_dotdot{,_rcu}(): lift LOOKUP_BENEATH checks "
      ` [RFC][PATCH v4 46/69] move handle_dots(), follow_dotdot() and follow_dotdot_rcu() past step_into()
      ` [RFC][PATCH v4 47/69] handle_dots(), follow_dotdot{,_rcu}(): preparation to switch to step_into()
      ` [RFC][PATCH v4 48/69] follow_dotdot{,_rcu}(): switch to use of step_into()
      ` [RFC][PATCH v4 49/69] lift all calls of step_into() out of follow_dotdot/follow_dotdot_rcu
      ` [RFC][PATCH v4 50/69] follow_dotdot{,_rcu}(): massage loops
      ` [RFC][PATCH v4 51/69] follow_dotdot_rcu(): be lazy about changing nd->path
      ` [RFC][PATCH v4 52/69] follow_dotdot(): "
      ` [RFC][PATCH v4 53/69] helper for mount rootwards traversal
      ` [RFC][PATCH v4 54/69] non-RCU analogue of the previous commit
      ` [RFC][PATCH v4 55/69] fs/namei.c: kill follow_mount()
      ` [RFC][PATCH v4 56/69] pick_link(): more straightforward handling of allocation failures
      ` [RFC][PATCH v4 57/69] pick_link(): pass it struct path already with normal refcounting rules
      ` [RFC][PATCH v4 58/69] fold path_to_nameidata() into its only remaining caller
      ` [RFC][PATCH v4 59/69] pick_link(): take reserving space on stack into a new helper
      ` [RFC][PATCH v4 60/69] reserve_stack(): switch to __nd_alloc_stack()
      ` [RFC][PATCH v4 61/69] __nd_alloc_stack(): make it return bool
      ` [RFC][PATCH v4 62/69] link_path_walk(): sample parent's i_uid and i_mode for the last component
      ` [RFC][PATCH v4 63/69] take post-lookup part of do_last() out of loop
      ` [RFC][PATCH v4 64/69] open_last_lookups(): consolidate fsnotify_create() calls
      ` [RFC][PATCH v4 65/69] open_last_lookups(): don't abuse complete_walk() when all we want is unlazy
      ` [RFC][PATCH v4 66/69] open_last_lookups(): lift O_EXCL|O_CREAT handling into do_open()
      ` [RFC][PATCH v4 67/69] open_last_lookups(): move complete_walk() "
      ` [RFC][PATCH v4 68/69] atomic_open(): no need to pass struct open_flags anymore
      ` [RFC][PATCH v4 69/69] lookup_open(): don't bother with fallbacks to lookup+create

[PATCH kcsan 0/32] KCSAN commits for v5.7
 2020-03-14  2:22 UTC  (5+ messages)
` [PATCH kcsan 17/32] kcsan: Introduce ASSERT_EXCLUSIVE_* macros

[PATCH v2] modpost: move the namespace field in Module.symvers last
 2020-03-14  2:11 UTC  (2+ messages)

[PATCH] x86/vector: Allow to free vector for managed IRQ
 2020-03-14  2:04 UTC  (3+ messages)

[PATCH] fs: Fix missing 'bit' in comment
 2020-03-14  1:34 UTC 

[PATCH] kbuild: Disable -Wpointer-to-enum-cast
 2020-03-14  1:32 UTC  (3+ messages)
` [PATCH v2] "

[PATCH] kbuild: fix references to other documents
 2020-03-14  1:29 UTC  (2+ messages)

[GIT PULL] clk fixes for v5.6-rc5
 2020-03-14  1:27 UTC 

[PATCH -next 000/491] treewide: use fallthrough;
 2020-03-14  1:17 UTC  (3+ messages)
` [PATCH -next 010/491] ARM/SAMSUNG EXYNOS ARM ARCHITECTURES: Use fallthrough;

[PATCH] ipq806x: gcc: Added the enable regs and mask for PRNG
 2020-03-14  1:15 UTC  (4+ messages)
  ` R: "

[PATCH 0/6] Replace private domain with per-group default
 2020-03-14  1:13 UTC  (5+ messages)

[PATCH v2] mm/sparse.c: Use kvmalloc_node/kvfree to alloc/free memmap for the classic sparse
 2020-03-14  1:12 UTC  (5+ messages)
` [PATCH v3] "

[PATCH v2 0/6] Replace private domain with per-group default domain
 2020-03-14  1:07 UTC  (7+ messages)
` [PATCH v2 1/6] iommu: Add def_domain_type() callback in iommu_ops
` [PATCH v2 2/6] iommu: Configure default domain with def_domain_type
` [PATCH v2 3/6] iommu/vt-d: Don't force 32bit devices to uses DMA domain
` [PATCH v2 4/6] iommu/vt-d: Don't force PCI sub-hierarchy to use "
` [PATCH v2 5/6] iommu/vt-d: Add def_domain_type callback
` [PATCH v2 6/6] iommu/vt-d: Apply per-device dma_ops

[PATCH v3] MIPS: Replace setup_irq() by request_irq()
 2020-03-14  1:07 UTC  (4+ messages)
` [PATCH v4] "

[PATCH v2 0/4] kselftest: add fixture parameters
 2020-03-14  0:55 UTC  (5+ messages)
` [PATCH v2 1/4] selftests/seccomp: use correct FIXTURE macro
` [PATCH v2 2/4] kselftest: create fixture objects
` [PATCH v2 3/4] kselftest: add fixture parameters
` [PATCH v2 4/4] selftests: tls: run all tests for TLS 1.2 and TLS 1.3

[PATCH 0/4] Add SS/HS-USB changes for Qualcomm SM8150 chipset
 2020-03-14  0:54 UTC  (5+ messages)
` [PATCH 1/4] dt-bindings: phy: Add binding for qcom,usb-hs-7nm
` [PATCH 2/4] phy: qcom-snps: Add SNPS USB PHY driver for QCOM based SOCs
` [PATCH 3/4] phy: qcom-qmp: Add SM8150 QMP USB3 PHY support
` [PATCH 4/4] phy: qcom-qmp: Use proper PWRDOWN offset for sm8150 USB

[PATCHv8 05/15] remoteproc/omap: Add the rproc ops .da_to_va() implementation
 2020-03-14  0:43 UTC  (2+ messages)
` [PATCHv8 RESEND "

[PATCHv8 03/15] remoteproc/omap: Add a sanity check for DSP boot address alignment
 2020-03-14  0:43 UTC  (2+ messages)
` [PATCHv8 RESEND "

linux-next: build warning after merge of the akpm-current tree
 2020-03-14  0:35 UTC  (4+ messages)

[PATCH 0/1] Bluetooth: Prioritize sco traffic on slow interfaces
 2020-03-14  0:30 UTC  (4+ messages)
` [PATCH 1/1] Bluetooth: Prioritize SCO "

[PATCH] sched: Use RCU-sched in core-scheduling balancing logic
 2020-03-14  0:30 UTC  (2+ messages)

[PATCH 0/1] coredump: Fix null pointer dereference when kernel.core_pattern is "|"
 2020-03-14  0:28 UTC  (4+ messages)

[PATCH 0/9] Lock ordering documentation and annotation for lockdep
 2020-03-14  0:26 UTC  (6+ messages)
` [PATCH 3/9] pci/switchtec: Don't abuse completion wait queue for poll
` [PATCH 4/9] sched/swait: Prepare usage in completions

[PATCH 0/5] kselftest: add fixture parameters
 2020-03-14  0:05 UTC  (8+ messages)
` [PATCH 3/5] kselftest: run tests by fixture
` [PATCH 4/5] kselftest: add fixture parameters

[PATCH v7 kunit-next 0/4] kunit: add debugfs representation to show results
 2020-03-14  0:03 UTC  (4+ messages)
` [PATCH v7 kunit-next 3/4] kunit: subtests should be indented 4 spaces according to TAP

[RFC][PATCH] dma-mapping: align default segment_boundary_mask with dma_mask
 2020-03-14  0:00 UTC 

[PATCH] x86/vector: Allow to free vector for managed IRQ
 2020-03-13 23:54 UTC  (2+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).