linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
 messages from 2022-06-23 16:42:30 to 2022-06-23 17:08:58 UTC [more...]

[PATCH 4.9 000/264] 4.9.320-rc1 review
 2022-06-23 16:43 UTC  (185+ messages)
` [PATCH 4.9 001/264] 9p: missing chunk of "fs/9p: Dont update file type when updating file attributes"
` [PATCH 4.9 002/264] random: remove stale maybe_reseed_primary_crng
` [PATCH 4.9 003/264] random: remove stale urandom_init_wait
` [PATCH 4.9 004/264] random: remove variable limit
` [PATCH 4.9 005/264] random: fix comment for unused random_min_urandom_seed
` [PATCH 4.9 006/264] random: convert get_random_int/long into get_random_u32/u64
` [PATCH 4.9 007/264] random: move random_min_urandom_seed into CONFIG_SYSCTL ifdef block
` [PATCH 4.9 008/264] random: invalidate batched entropy after crng init
` [PATCH 4.9 009/264] random: silence compiler warnings and fix race
` [PATCH 4.9 010/264] random: add wait_for_random_bytes() API
` [PATCH 4.9 011/264] random: add get_random_{bytes,u32,u64,int,long,once}_wait family
` [PATCH 4.9 012/264] random: warn when kernel uses unseeded randomness
` [PATCH 4.9 013/264] random: do not ignore early device randomness
` [PATCH 4.9 014/264] random: suppress spammy warnings about unseeded randomness
` [PATCH 4.9 015/264] random: reorder READ_ONCE() in get_random_uXX
` [PATCH 4.9 016/264] random: fix warning message on ia64 and parisc
` [PATCH 4.9 017/264] random: use a different mixing algorithm for add_device_randomness()
` [PATCH 4.9 018/264] random: set up the NUMA crng instances after the CRNG is fully initialized
` [PATCH 4.9 019/264] random: fix possible sleeping allocation from irq context
` [PATCH 4.9 020/264] random: rate limit unseeded randomness warnings
` [PATCH 4.9 021/264] random: add a spinlock_t to struct batched_entropy
` [PATCH 4.9 022/264] char/random: silence a lockdep splat with printk()
` [PATCH 4.9 023/264] Revert "char/random: silence a lockdep splat with printk()"
` [PATCH 4.9 024/264] random: always use batched entropy for get_random_u{32,64}
` [PATCH 4.9 025/264] random: fix data race on crng_node_pool
` [PATCH 4.9 026/264] crypto: chacha20 - Fix keystream alignment for chacha20_block()
` [PATCH 4.9 027/264] random: always fill buffer in get_random_bytes_wait
` [PATCH 4.9 028/264] random: optimize add_interrupt_randomness
` [PATCH 4.9 029/264] drivers/char/random.c: remove unused dont_count_entropy
` [PATCH 4.9 030/264] random: Fix whitespace pre random-bytes work
` [PATCH 4.9 031/264] random: Return nbytes filled from hw RNG
` [PATCH 4.9 032/264] random: add a config option to trust the CPUs hwrng
` [PATCH 4.9 033/264] random: remove preempt disabled region
` [PATCH 4.9 034/264] random: Make crng state queryable
` [PATCH 4.9 035/264] random: make CPU trust a boot parameter
` [PATCH 4.9 036/264] drivers/char/random.c: constify poolinfo_table
` [PATCH 4.9 037/264] drivers/char/random.c: remove unused stuct poolinfo::poolbits
` [PATCH 4.9 038/264] drivers/char/random.c: make primary_crng static
` [PATCH 4.9 039/264] random: only read from /dev/random after its pool has received 128 bits
` [PATCH 4.9 040/264] random: move rand_initialize() earlier
` [PATCH 4.9 041/264] random: document get_random_int() family
` [PATCH 4.9 042/264] latent_entropy: avoid build error when plugin cflags are not set
` [PATCH 4.9 043/264] random: fix soft lockup when trying to read from an uninitialized blocking pool
` [PATCH 4.9 044/264] random: Support freezable kthreads in add_hwgenerator_randomness()
` [PATCH 4.9 045/264] fdt: add support for rng-seed
` [PATCH 4.9 046/264] random: Use wait_event_freezable() in add_hwgenerator_randomness()
` [PATCH 4.9 047/264] char/random: Add a newline at the end of the file
` [PATCH 4.9 048/264] Revert "hwrng: core - Freeze khwrng thread during suspend"
` [PATCH 4.9 049/264] crypto: Deduplicate le32_to_cpu_array() and cpu_to_le32_array()
` [PATCH 4.9 050/264] crypto: blake2s - generic C library implementation and selftest
` [PATCH 4.9 051/264] lib/crypto: blake2s: move hmac construction into wireguard
` [PATCH 4.9 052/264] lib/crypto: sha1: re-roll loops to reduce code size
` [PATCH 4.9 053/264] random: Dont wake crng_init_wait when crng_init == 1
` [PATCH 4.9 054/264] random: Add a urandom_read_nowait() for random APIs that dont warn
` [PATCH 4.9 055/264] random: add GRND_INSECURE to return best-effort non-cryptographic bytes
` [PATCH 4.9 056/264] random: ignore GRND_RANDOM in getentropy(2)
` [PATCH 4.9 057/264] random: make /dev/random be almost like /dev/urandom
` [PATCH 4.9 058/264] random: fix crash on multiple early calls to add_bootloader_randomness()
` [PATCH 4.9 059/264] random: remove the blocking pool
` [PATCH 4.9 060/264] random: delete code to pull data into pools
` [PATCH 4.9 061/264] random: remove kernel.random.read_wakeup_threshold
` [PATCH 4.9 062/264] random: remove unnecessary unlikely()
` [PATCH 4.9 063/264] random: convert to ENTROPY_BITS for better code readability
` [PATCH 4.9 064/264] random: Add and use pr_fmt()
` [PATCH 4.9 065/264] random: fix typo in add_timer_randomness()
` [PATCH 4.9 066/264] random: remove some dead code of poolinfo
` [PATCH 4.9 067/264] random: split primary/secondary crng init paths
` [PATCH 4.9 068/264] random: avoid warnings for !CONFIG_NUMA builds
` [PATCH 4.9 069/264] x86: Remove arch_has_random, arch_has_random_seed
` [PATCH 4.9 070/264] powerpc: "
` [PATCH 4.9 071/264] linux/random.h: "
` [PATCH 4.9 072/264] linux/random.h: Use false with bool
` [PATCH 4.9 073/264] linux/random.h: Mark CONFIG_ARCH_RANDOM functions __must_check
` [PATCH 4.9 074/264] powerpc: Use bool in archrandom.h
` [PATCH 4.9 075/264] random: add arch_get_random_*long_early()
` [PATCH 4.9 076/264] random: avoid arch_get_random_seed_long() when collecting IRQ randomness
` [PATCH 4.9 077/264] random: remove dead code left over from blocking pool
` [PATCH 4.9 078/264] MAINTAINERS: co-maintain random.c
` [PATCH 4.9 079/264] crypto: blake2s - include <linux/bug.h> instead of <asm/bug.h>
` [PATCH 4.9 080/264] crypto: blake2s - adjust include guard naming
` [PATCH 4.9 081/264] random: document add_hwgenerator_randomness() with other input functions
` [PATCH 4.9 082/264] random: remove unused irq_flags argument from add_interrupt_randomness()
` [PATCH 4.9 083/264] random: use BLAKE2s instead of SHA1 in extraction
` [PATCH 4.9 084/264] random: do not sign extend bytes for rotation when mixing
` [PATCH 4.9 086/264] random: mix bootloader randomness into pool
` [PATCH 4.9 087/264] random: harmonize "crng init done" messages
` [PATCH 4.9 088/264] random: use IS_ENABLED(CONFIG_NUMA) instead of ifdefs
` [PATCH 4.9 090/264] random: early initialization of ChaCha constants
` [PATCH 4.9 091/264] random: avoid superfluous call to RDRAND in CRNG extraction
` [PATCH 4.9 092/264] random: dont reset crng_init_cnt on urandom_read()
` [PATCH 4.9 093/264] random: fix typo in comments
` [PATCH 4.9 094/264] random: cleanup poolinfo abstraction
` [PATCH 4.9 095/264] crypto: chacha20 - Fix chacha20_block() keystream alignment (again)
` [PATCH 4.9 096/264] random: cleanup integer types
` [PATCH 4.9 097/264] random: remove incomplete last_data logic
` [PATCH 4.9 098/264] random: remove unused extract_entropy() reserved argument
` [PATCH 4.9 099/264] random: try to actively add entropy rather than passively wait for it
` [PATCH 4.9 100/264] random: rather than entropy_store abstraction, use global
` [PATCH 4.9 101/264] random: remove unused OUTPUT_POOL constants
` [PATCH 4.9 102/264] random: de-duplicate INPUT_POOL constants
` [PATCH 4.9 103/264] random: prepend remaining pool constants with POOL_
` [PATCH 4.9 104/264] random: cleanup fractional entropy shift constants
` [PATCH 4.9 106/264] random: simplify arithmetic function flow in account()
` [PATCH 4.9 108/264] random: access primary_pool directly rather than through pointer
` [PATCH 4.9 109/264] random: only call crng_finalize_init() for primary_crng
` [PATCH 4.9 111/264] random: simplify entropy debiting
` [PATCH 4.9 112/264] random: use linear min-entropy accumulation crediting
` [PATCH 4.9 113/264] random: always wake up entropy writers after extraction
` [PATCH 4.9 115/264] random: remove use_input_pool parameter from crng_reseed()
` [PATCH 4.9 116/264] random: remove batched entropy locking
` [PATCH 4.9 117/264] random: fix locking in crng_fast_load()
` [PATCH 4.9 118/264] random: use RDSEED instead of RDRAND in entropy extraction
` [PATCH 4.9 120/264] random: ensure early RDSEED goes through mixer on init
` [PATCH 4.9 122/264] random: absorb fast pool into input pool after fast load
` [PATCH 4.9 123/264] random: use hash function for crng_slow_load()
` [PATCH 4.9 125/264] random: zero buffer after reading entropy from userspace
` [PATCH 4.9 126/264] random: tie batched entropy generation to base_crng generation
` [PATCH 4.9 127/264] random: remove ifdefd out interrupt bench
` [PATCH 4.9 128/264] random: remove unused tracepoints
` [PATCH 4.9 129/264] random: add proper SPDX header
` [PATCH 4.9 130/264] random: deobfuscate irq u32/u64 contributions
` [PATCH 4.9 131/264] random: introduce drain_entropy() helper to declutter crng_reseed()
` [PATCH 4.9 132/264] random: remove useless header comment
` [PATCH 4.9 133/264] random: remove whitespace and reorder includes
` [PATCH 4.9 134/264] random: group initialization wait functions
` [PATCH 4.9 135/264] random: group entropy extraction functions
` [PATCH 4.9 136/264] random: group entropy collection functions
` [PATCH 4.9 142/264] random: do not take pool spinlock at boot
` [PATCH 4.9 143/264] random: unify early init crng load accounting
` [PATCH 4.9 144/264] random: check for crng_init == 0 in add_device_randomness()
` [PATCH 4.9 145/264] hwrng: core - do not use multiple blank lines
` [PATCH 4.9 146/264] hwrng: core - rewrite better comparison to NULL
` [PATCH 4.9 147/264] hwrng: core - Rewrite the header
` [PATCH 4.9 148/264] hwrng: core - Move hwrng miscdev minor number to include/linux/miscdevice.h
` [PATCH 4.9 149/264] hwrng: core - remove unused PFX macro
` [PATCH 4.9 150/264] hwrng: use rng source with best quality
` [PATCH 4.9 151/264] hwrng: remember rng chosen by user
` [PATCH 4.9 152/264] random: pull add_hwgenerator_randomness() declaration into random.h
` [PATCH 4.9 153/264] random: clear fast pool, crng, and batches in cpuhp bring up
` [PATCH 4.9 154/264] random: round-robin registers as ulong, not u32
` [PATCH 4.9 155/264] random: only wake up writers after zap if threshold was passed
` [PATCH 4.9 156/264] random: cleanup UUID handling
` [PATCH 4.9 157/264] random: unify cycles_t and jiffies usage and types
` [PATCH 4.9 158/264] random: do crng pre-init loading in worker rather than irq
` [PATCH 4.9 159/264] random: give sysctl_random_min_urandom_seed a more sensible value
` [PATCH 4.9 160/264] random: dont let 644 read-only sysctls be written to
` [PATCH 4.9 161/264] random: replace custom notifier chain with standard one
` [PATCH 4.9 162/264] random: use SipHash as interrupt entropy accumulator
` [PATCH 4.9 163/264] random: make consistent usage of crng_ready()
` [PATCH 4.9 164/264] random: reseed more often immediately after booting
` [PATCH 4.9 165/264] random: check for signal and try earlier when generating entropy
` [PATCH 4.9 166/264] random: skip fast_init if hwrng provides large chunk of entropy
` [PATCH 4.9 167/264] random: treat bootloader trust toggle the same way as cpu trust toggle
` [PATCH 4.9 168/264] random: re-add removed comment about get_random_{u32,u64} reseeding
` [PATCH 4.9 170/264] random: do not split fast init input in add_hwgenerator_randomness()
` [PATCH 4.9 171/264] random: do not allow user to keep crng key around on stack
` [PATCH 4.9 172/264] random: check for signal_pending() outside of need_resched() check
` [PATCH 4.9 179/264] s390: define get_cycles macro for arch-override
` [PATCH 4.9 180/264] parisc: "
` [PATCH 4.9 181/264] alpha: "
` [PATCH 4.9 182/264] powerpc: "
` [PATCH 4.9 183/264] timekeeping: Add raw clock fallback for random_get_entropy()
` [PATCH 4.9 184/264] m68k: use fallback for random_get_entropy() instead of zero
` [PATCH 4.9 185/264] mips: use fallback for random_get_entropy() instead of just c0 random
` [PATCH 4.9 186/264] arm: use fallback for random_get_entropy() instead of zero
` [PATCH 4.9 187/264] nios2: "
` [PATCH 4.9 188/264] x86/tsc: Use "
` [PATCH 4.9 189/264] um: use "
` [PATCH 4.9 190/264] sparc: "
` [PATCH 4.9 191/264] xtensa: "
` [PATCH 4.9 192/264] uapi: rename ext2_swab() to swab() and share globally in swab.h
` [PATCH 4.9 193/264] random: insist on random_get_entropy() existing in order to simplify
` [PATCH 4.9 194/264] random: do not use batches when !crng_ready()
` [PATCH 4.9 195/264] random: do not pretend to handle premature next security model
` [PATCH 4.9 196/264] random: order timer entropy functions below interrupt functions
` [PATCH 4.9 197/264] random: do not use input pool from hard IRQs
` [PATCH 4.9 198/264] random: help compiler out with fast_mix() by using simpler arguments
` [PATCH 4.9 200/264] random: use symbolic constants for crng_init states
` [PATCH 4.9 202/264] random: remove ratelimiting for in-kernel unseeded randomness
` [PATCH 4.9 203/264] random: use proper jiffies comparison macro
` [PATCH 4.9 204/264] random: handle latent entropy and command line from random_init()
` [PATCH 4.9 205/264] random: credit architectural init the exact amount
` [PATCH 4.9 206/264] random: use static branch for crng_ready()
` [PATCH 4.9 207/264] random: remove extern from functions in header

[PATCH mm v4 0/9] memcg: accounting for objects allocated by mkdir cgroup
 2022-06-23 16:55 UTC  (5+ messages)
` [PATCH mm v5 0/9] memcg: accounting for objects allocated by mkdir, cgroup

[PATCH] timekeeping: contribute wall clock to rng on time change
 2022-06-23 16:52 UTC 

[PATCH][next] drm/amdgpu/display: Fix spelling mistake "supporing" -> "supporting"
 2022-06-23 16:52 UTC  (3+ messages)

[PATCH 0/2] x86: notify hypervisor/VMM about guest entering s2idle
 2022-06-23 16:50 UTC  (14+ messages)
` [PATCH 1/2] x86: notify hypervisor about guest entering s2idle state

[PATCH] PCI: mvebu: Use devm_request_irq() for registering interrupt handler
 2022-06-23 16:49 UTC  (2+ messages)

[PATCH] mm: vmpressure: don't count userspace-induced reclaim as memory pressure
 2022-06-23 16:49 UTC  (8+ messages)

[PATCH] drm/amdgpu: drop unexpected word 'for' in comments
 2022-06-23 16:51 UTC  (2+ messages)

[PATCH][next] drm/amdkfd: Fix spelling mistake "mechanim" -> "mechanism"
 2022-06-23 16:49 UTC  (2+ messages)

[PATCH] scsi: fcoe: remove redundant assignment to variable wlen
 2022-06-23 16:47 UTC 

[PATCH] drm/rockchip: vop: Don't crash for invalid duplicate_state()
 2022-06-23 16:46 UTC  (2+ messages)

[bvanassche:block-bitwise-opf 11/50] drivers/scsi/device_handler/scsi_dh_rdac.c:539:67: sparse: sparse: incorrect type in initializer (different base types)
 2022-06-23 16:44 UTC 

[GIT PULL] Pagecache fixes for 5.19-rc4
 2022-06-23 16:42 UTC 

[PATCH V4 00/20] The Runtime Verification (RV) interface
 2022-06-23 16:41 UTC  (3+ messages)


This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).