From: Krishna Reddy <vdumpa@nvidia.com>
To: Sai Prakash Ranjan <saiprakash.ranjan@codeaurora.org>,
Robin Murphy <robin.murphy@arm.com>
Cc: "linux-arm-msm@vger.kernel.org" <linux-arm-msm@vger.kernel.org>,
"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
"iommu@lists.linux-foundation.org"
<iommu@lists.linux-foundation.org>, Will Deacon <will@kernel.org>,
"linux-arm-kernel@lists.infradead.org"
<linux-arm-kernel@lists.infradead.org>,
Thierry Reding <treding@nvidia.com>
Subject: RE: [PATCH] iommu/io-pgtable-arm: Optimize partial walk flush for large scatter-gather list
Date: Thu, 17 Jun 2021 21:18:34 +0000 [thread overview]
Message-ID: <BY5PR12MB37641A153EAAC556C85A411FB30E9@BY5PR12MB3764.namprd12.prod.outlook.com> (raw)
In-Reply-To: <d9226f4349c445c6ca63dc632b29e3e0@codeaurora.org>
> Instead of flush_ops in init_context hook, perhaps a io_pgtable quirk since this is
> related to tlb, probably a bad name but IO_PGTABLE_QUIRK_TLB_INV which will
> be set in init_context impl hook and the prev condition in
> io_pgtable_tlb_flush_walk()
> becomes something like below. Seems very minimal and neat instead of poking
> into tlb_flush_walk functions or touching dma strict with some flag?
>
> if (iop->cfg.quirks & IO_PGTABLE_QUIRK_NON_STRICT ||
> iop->cfg.quirks & IO_PGTABLE_QUIRK_TLB_INV) {
> iop->cfg.tlb->tlb_flush_all(iop->cookie);
> return;
> }
Can you name it as IO_PGTABLE_QUIRK_TLB_INV_ASID or IO_PGTABLE_QUIRK_TLB_INV_ALL_ASID?
-KR
next prev parent reply other threads:[~2021-06-17 21:18 UTC|newest]
Thread overview: 22+ messages / expand[flat|nested] mbox.gz Atom feed top
2021-06-09 14:53 [PATCH] iommu/io-pgtable-arm: Optimize partial walk flush for large scatter-gather list Sai Prakash Ranjan
2021-06-09 18:44 ` Robin Murphy
2021-06-10 5:24 ` Sai Prakash Ranjan
2021-06-10 9:08 ` Robin Murphy
2021-06-10 9:36 ` Sai Prakash Ranjan
2021-06-10 11:33 ` Robin Murphy
2021-06-10 11:54 ` Sai Prakash Ranjan
2021-06-10 15:29 ` Robin Murphy
2021-06-10 15:51 ` Sai Prakash Ranjan
2021-06-11 0:37 ` Krishna Reddy
2021-06-11 0:54 ` Sai Prakash Ranjan
2021-06-11 16:49 ` Krishna Reddy
2021-06-12 2:46 ` Sai Prakash Ranjan
2021-06-14 17:48 ` Krishna Reddy
2021-06-15 11:51 ` Sai Prakash Ranjan
2021-06-15 13:53 ` Robin Murphy
2021-06-16 6:58 ` Sai Prakash Ranjan
2021-06-16 9:03 ` Sai Prakash Ranjan
2021-06-17 21:18 ` Krishna Reddy [this message]
2021-06-18 2:47 ` Sai Prakash Ranjan
2021-06-18 4:04 ` Sai Prakash Ranjan
2021-06-10 12:03 ` Thierry Reding
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=BY5PR12MB37641A153EAAC556C85A411FB30E9@BY5PR12MB3764.namprd12.prod.outlook.com \
--to=vdumpa@nvidia.com \
--cc=iommu@lists.linux-foundation.org \
--cc=linux-arm-kernel@lists.infradead.org \
--cc=linux-arm-msm@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=robin.murphy@arm.com \
--cc=saiprakash.ranjan@codeaurora.org \
--cc=treding@nvidia.com \
--cc=will@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).