linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Pavel Tatashin <pasha.tatashin@soleen.com>
To: James Morse <james.morse@arm.com>
Cc: James Morris <jmorris@namei.org>, Sasha Levin <sashal@kernel.org>,
	"Eric W. Biederman" <ebiederm@xmission.com>,
	kexec mailing list <kexec@lists.infradead.org>,
	LKML <linux-kernel@vger.kernel.org>,
	Jonathan Corbet <corbet@lwn.net>,
	Catalin Marinas <catalin.marinas@arm.com>,
	will@kernel.org, Linux ARM <linux-arm-kernel@lists.infradead.org>,
	Marc Zyngier <marc.zyngier@arm.com>,
	Vladimir Murzin <vladimir.murzin@arm.com>,
	Matthias Brugger <matthias.bgg@gmail.com>,
	Bhupesh Sharma <bhsharma@redhat.com>,
	linux-mm <linux-mm@kvack.org>,
	Mark Rutland <mark.rutland@arm.com>
Subject: Re: [PATCH v6 15/17] arm64: kexec: add expandable argument to relocation function
Date: Mon, 14 Oct 2019 19:35:51 -0400	[thread overview]
Message-ID: <CA+CK2bBRRQsepxrWnOUOnFfPUe5SYsOurQ3kL_P1ghxze77RFQ@mail.gmail.com> (raw)
In-Reply-To: <fe5a4aae-fae3-f30f-db15-f3eced229a6e@arm.com>

> > +struct kern_reloc_arg {
> > +     unsigned long   head;
> > +     unsigned long   entry_addr;
> > +     unsigned long   kern_arg0;
> > +     unsigned long   kern_arg1;
> > +     unsigned long   kern_arg2;
> > +     unsigned long   kern_arg3;
>
> ... at least one of these should by phys_addr_t!

OK, changed them to phys_addr_t

>
> While the sizes are the same on arm64, this reminds the reader what kind of address this
> is, and lets the compiler warn you if you make a mistake.

OK

>
>
> > +};
>
> > diff --git a/arch/arm64/kernel/asm-offsets.c b/arch/arm64/kernel/asm-offsets.c
> > index 214685760e1c..900394907fd8 100644
> > --- a/arch/arm64/kernel/asm-offsets.c
> > +++ b/arch/arm64/kernel/asm-offsets.c
> > @@ -23,6 +23,7 @@
> >  #include <asm/suspend.h>
> >  #include <linux/kbuild.h>
> >  #include <linux/arm-smccc.h>
> > +#include <linux/kexec.h>
> >
> >  int main(void)
> >  {
> > @@ -126,6 +127,14 @@ int main(void)
> >  #ifdef CONFIG_ARM_SDE_INTERFACE
> >    DEFINE(SDEI_EVENT_INTREGS, offsetof(struct sdei_registered_event, interrupted_regs));
> >    DEFINE(SDEI_EVENT_PRIORITY,        offsetof(struct sdei_registered_event, priority));
> > +#endif
> > +#ifdef CONFIG_KEXEC_CORE
> > +  DEFINE(KRELOC_HEAD,                offsetof(struct kern_reloc_arg, head));
> > +  DEFINE(KRELOC_ENTRY_ADDR,  offsetof(struct kern_reloc_arg, entry_addr));
> > +  DEFINE(KRELOC_KERN_ARG0,   offsetof(struct kern_reloc_arg, kern_arg0));
> > +  DEFINE(KRELOC_KERN_ARG1,   offsetof(struct kern_reloc_arg, kern_arg1));
> > +  DEFINE(KRELOC_KERN_ARG2,   offsetof(struct kern_reloc_arg, kern_arg2));
> > +  DEFINE(KRELOC_KERN_ARG3,   offsetof(struct kern_reloc_arg, kern_arg3));
>
> Please use kexec as the prefix. The kernel also applies relocations during early boot.
> These are global values, and in isolation doesn't imply kexec.

OK
> >  .align 3     /* To keep the 64-bit values below naturally aligned. */
> > -
> >  .Lcopy_end:
> >  .org KEXEC_CONTROL_PAGE_SIZE
> >
>
> My eyes!
>
> Please don't make unnecessary changes. Its hard enough to read the assembly, moving
> whitespace, comments and re-allocating the register guarantees that no-one can work out
> what is happening.
>
> If something needs cleaning up to make the change obvious, it needs doing as a previous
> patch. Mechanical changes are fairly easy to review.
> Functional changes behind a whirlwind of mechanical changes will cause the reviewer to
> give up.

Sure, I have split this patch into several patches, and moved
clean-ups into separate patches.

Thank you,
Pasha

  reply	other threads:[~2019-10-14 23:36 UTC|newest]

Thread overview: 30+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-10-04 18:52 [PATCH v6 00/17] arm64: MMU enabled kexec relocation Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 01/17] kexec: quiet down kexec reboot Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 02/17] arm64: hibernate: pass the allocated pgdp to ttbr0 Pavel Tatashin
2019-10-11 18:17   ` James Morse
2019-10-14 14:11     ` Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 03/17] arm64: hibernate: check pgd table allocation Pavel Tatashin
2019-10-11 18:17   ` James Morse
2019-10-14 14:51     ` Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 04/17] arm64: hibernate: use get_safe_page directly Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 05/17] arm64: hibernate: remove gotos as they are not needed Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 06/17] arm64: hibernate: rename dst to page in create_safe_exec_page Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 07/17] arm64: hibernate: add PUD_SECT_RDONLY Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 08/17] arm64: hibernate: add trans_pgd public functions Pavel Tatashin
2019-10-11 18:18   ` James Morse
2019-10-14 15:34     ` Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 09/17] arm64: hibernate: move page handling function to new trans_pgd.c Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 10/17] arm64: trans_pgd: make trans_pgd_map_page generic Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 11/17] arm64: trans_pgd: pass allocator trans_pgd_create_copy Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 12/17] arm64: trans_pgd: pass NULL instead of init_mm to *_populate functions Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 13/17] kexec: add machine_kexec_post_load() Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 14/17] arm64: kexec: move relocation function setup and clean up Pavel Tatashin
2019-10-11 18:19   ` James Morse
2019-10-14 19:29     ` Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 15/17] arm64: kexec: add expandable argument to relocation function Pavel Tatashin
2019-10-11 18:19   ` James Morse
2019-10-14 23:35     ` Pavel Tatashin [this message]
2019-10-04 18:52 ` [PATCH v6 16/17] arm64: kexec: configure trans_pgd page table for kexec Pavel Tatashin
2019-10-11 18:21   ` James Morse
2019-10-15  2:12     ` Pavel Tatashin
2019-10-04 18:52 ` [PATCH v6 17/17] arm64: kexec: enable MMU during kexec relocation Pavel Tatashin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CA+CK2bBRRQsepxrWnOUOnFfPUe5SYsOurQ3kL_P1ghxze77RFQ@mail.gmail.com \
    --to=pasha.tatashin@soleen.com \
    --cc=bhsharma@redhat.com \
    --cc=catalin.marinas@arm.com \
    --cc=corbet@lwn.net \
    --cc=ebiederm@xmission.com \
    --cc=james.morse@arm.com \
    --cc=jmorris@namei.org \
    --cc=kexec@lists.infradead.org \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-mm@kvack.org \
    --cc=marc.zyngier@arm.com \
    --cc=mark.rutland@arm.com \
    --cc=matthias.bgg@gmail.com \
    --cc=sashal@kernel.org \
    --cc=vladimir.murzin@arm.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).