linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Bjorn Helgaas <bhelgaas@google.com>
To: Yinghai Lu <yinghai@kernel.org>
Cc: Jesse Barnes <jbarnes@virtuousgeek.org>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Tony Luck <tony.luck@intel.com>,
	Linus Torvalds <torvalds@linux-foundation.org>,
	linux-pci@vger.kernel.org, linux-kernel@vger.kernel.org,
	linux-arch@vger.kernel.org
Subject: Re: [PATCH 10/13] PCI: Strict checking of valid range for bridge
Date: Mon, 30 Jan 2012 08:04:39 -0800	[thread overview]
Message-ID: <CAErSpo7RsR+2gDJvWic4ta-_SWfUwECaVxRrCVnTFZyFG5RCkw@mail.gmail.com> (raw)
In-Reply-To: <1327718971-9598-11-git-send-email-yinghai@kernel.org>

On Fri, Jan 27, 2012 at 6:49 PM, Yinghai Lu <yinghai@kernel.org> wrote:
> children bridges busn range should be able to be allocated from parent bus range.
>
> to avoid overlapping between sibling bridges on same bus.
>
> Signed-off-by: Yinghai Lu <yinghai@kernel.org>
> ---
>  drivers/pci/probe.c |   27 +++++++++++++++++++++++++++
>  1 files changed, 27 insertions(+), 0 deletions(-)
>
> diff --git a/drivers/pci/probe.c b/drivers/pci/probe.c
> index 83df3fb..e12f65f0 100644
> --- a/drivers/pci/probe.c
> +++ b/drivers/pci/probe.c
> @@ -791,6 +791,33 @@ reduce_needed_size:
>        return ret;
>  }
>
> +static int __devinit pci_bridge_check_busn_res(struct pci_bus *bus,
> +                               struct pci_dev *dev,
> +                               int secondary, int subordinate)

This function returns a boolean, but the function name doesn't give
any clue about what a true/false return means.  Something like
"busn_valid" would make the callers more readable.

> +{
> +       int broken = 0;
> +
> +       struct resource busn_res;
> +       int ret;
> +
> +       memset(&busn_res, 0, sizeof(struct resource));
> +       dev_printk(KERN_DEBUG, &dev->dev,
> +                "check if busn %02x-%02x is in busn_res: %06llx-%06llx\n",
> +                secondary, subordinate,
> +                (unsigned long long)bus->busn_res.start,
> +                (unsigned long long)bus->busn_res.end);
> +       ret = allocate_resource(&bus->busn_res, &busn_res,
> +                        (subordinate - secondary + 1),
> +                        (pci_domain_nr(bus)<<8) | secondary,
> +                        (pci_domain_nr(bus)<<8) | subordinate,

I think this "(pci_domain_nr(bus)<<8) | secondary" stuff needs to be a
macro or something.

> +                        1, NULL, NULL);
> +       if (ret)
> +               broken = 1;
> +       else
> +               release_resource(&busn_res);
> +
> +       return broken;
> +}
>  /*
>  * If it's a bridge, configure it and scan the bus behind it.
>  * For CardBus bridges, we don't scan behind as the devices will
> --
> 1.7.7
>

  reply	other threads:[~2012-01-30 16:05 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2012-01-28  2:49 [PATCH -v2 0/13] PCI: allocate pci bus num range for unassigned bridge busn Yinghai Lu
2012-01-28  2:49 ` [PATCH 01/13] PCI: Add iobusn_resource Yinghai Lu
2012-01-28  2:49 ` [PATCH 02/13] PCI: Add busn_res operation functions Yinghai Lu
2012-01-30 15:28   ` Bjorn Helgaas
2012-01-30 18:32     ` Yinghai Lu
2012-01-28  2:49 ` [PATCH 03/13] PCI: Add busn_res tracking in core Yinghai Lu
2012-01-30 15:35   ` Bjorn Helgaas
2012-01-30 18:39     ` Yinghai Lu
2012-01-28  2:49 ` [PATCH 04/13] PCI, x86: Register busn_res for root buses Yinghai Lu
2012-01-28  2:49 ` [PATCH 05/13] PCI, ia64: " Yinghai Lu
2012-01-28  2:49 ` [PATCH 06/13] PCI, powerpc: " Yinghai Lu
2012-01-30 15:44   ` Bjorn Helgaas
2012-01-28  2:49 ` [PATCH 07/13] PCI, parisc: " Yinghai Lu
2012-01-28  2:49 ` [PATCH 08/13] PCI: Add pci_bus_extend/shrink_top() Yinghai Lu
2012-01-30 15:50   ` Bjorn Helgaas
2012-01-30 18:42     ` Yinghai Lu
2012-01-28  2:49 ` [PATCH 09/13] PCI: Probe safe range that we can use for unassigned bridge Yinghai Lu
2012-01-30 15:59   ` Bjorn Helgaas
2012-01-30 18:51     ` Yinghai Lu
2012-01-28  2:49 ` [PATCH 10/13] PCI: Strict checking of valid range for bridge Yinghai Lu
2012-01-30 16:04   ` Bjorn Helgaas [this message]
2012-01-30 18:52     ` Yinghai Lu
2012-01-28  2:49 ` [PATCH 11/13] PCI: Allocate bus range instead of use max blindly Yinghai Lu
2012-01-28  2:49 ` [PATCH 12/13] PCI: kill pci_fixup_parent_subordinate_busnr() Yinghai Lu
2012-01-30 16:09   ` Bjorn Helgaas
2012-01-28  2:49 ` [PATCH 13/13] PCI: Seperate child bus scanning to two passes overall Yinghai Lu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAErSpo7RsR+2gDJvWic4ta-_SWfUwECaVxRrCVnTFZyFG5RCkw@mail.gmail.com \
    --to=bhelgaas@google.com \
    --cc=benh@kernel.crashing.org \
    --cc=jbarnes@virtuousgeek.org \
    --cc=linux-arch@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=tony.luck@intel.com \
    --cc=torvalds@linux-foundation.org \
    --cc=yinghai@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).