linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Robert Foss <robert.foss@linaro.org>
To: Bjorn Andersson <bjorn.andersson@linaro.org>
Cc: Rob Clark <robdclark@gmail.com>, Sean Paul <sean@poorly.run>,
	David Airlie <airlied@linux.ie>, Daniel Vetter <daniel@ffwll.ch>,
	Dmitry Baryshkov <dmitry.baryshkov@linaro.org>,
	Abhinav Kumar <abhinavk@codeaurora.org>,
	linux-arm-msm@vger.kernel.org, dri-devel@lists.freedesktop.org,
	freedreno@lists.freedesktop.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH] drm/msm/dpu: Add more of the INTF interrupt regions
Date: Tue, 23 Nov 2021 16:50:34 +0100	[thread overview]
Message-ID: <CAG3jFytT1Bvagn8hQnVvE48X-jR+pyNuQtjcgJAYmBC97=BL7g@mail.gmail.com> (raw)
In-Reply-To: <20211123154050.40984-1-bjorn.andersson@linaro.org>

On Tue, 23 Nov 2021 at 16:39, Bjorn Andersson
<bjorn.andersson@linaro.org> wrote:
>
> In addition to the other 7xxx INTF interrupt regions, SM8350 has
> additional INTF regions at 0x0ae37000, 0x0ae38000 and 0x0ae39000, define
> these. The 7xxx naming scheme of the bits are kept for consistency.
>
> Signed-off-by: Bjorn Andersson <bjorn.andersson@linaro.org>
> ---
>  .../gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c  | 18 ++++++++++++++++++
>  .../gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.h  |  3 +++
>  2 files changed, 21 insertions(+)
>
> diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c b/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c
> index d2b6dca487e3..a77a5eaa78ad 100644
> --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c
> +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.c
> @@ -30,6 +30,9 @@
>  #define MDP_AD4_INTR_STATUS_OFF                0x420
>  #define MDP_INTF_0_OFF_REV_7xxx             0x34000
>  #define MDP_INTF_1_OFF_REV_7xxx             0x35000
> +#define MDP_INTF_2_OFF_REV_7xxx             0x36000
> +#define MDP_INTF_3_OFF_REV_7xxx             0x37000
> +#define MDP_INTF_4_OFF_REV_7xxx             0x38000
>  #define MDP_INTF_5_OFF_REV_7xxx             0x39000
>
>  /**
> @@ -110,6 +113,21 @@ static const struct dpu_intr_reg dpu_intr_set[] = {
>                 MDP_INTF_1_OFF_REV_7xxx+INTF_INTR_EN,
>                 MDP_INTF_1_OFF_REV_7xxx+INTF_INTR_STATUS
>         },
> +       {
> +               MDP_INTF_2_OFF_REV_7xxx+INTF_INTR_CLEAR,
> +               MDP_INTF_2_OFF_REV_7xxx+INTF_INTR_EN,
> +               MDP_INTF_2_OFF_REV_7xxx+INTF_INTR_STATUS
> +       },
> +       {
> +               MDP_INTF_3_OFF_REV_7xxx+INTF_INTR_CLEAR,
> +               MDP_INTF_3_OFF_REV_7xxx+INTF_INTR_EN,
> +               MDP_INTF_3_OFF_REV_7xxx+INTF_INTR_STATUS
> +       },
> +       {
> +               MDP_INTF_4_OFF_REV_7xxx+INTF_INTR_CLEAR,
> +               MDP_INTF_4_OFF_REV_7xxx+INTF_INTR_EN,
> +               MDP_INTF_4_OFF_REV_7xxx+INTF_INTR_STATUS
> +       },
>         {
>                 MDP_INTF_5_OFF_REV_7xxx+INTF_INTR_CLEAR,
>                 MDP_INTF_5_OFF_REV_7xxx+INTF_INTR_EN,
> diff --git a/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.h b/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.h
> index d50e78c9f148..1ab75cccd145 100644
> --- a/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.h
> +++ b/drivers/gpu/drm/msm/disp/dpu1/dpu_hw_interrupts.h
> @@ -26,6 +26,9 @@ enum dpu_hw_intr_reg {
>         MDP_AD4_1_INTR,
>         MDP_INTF0_7xxx_INTR,
>         MDP_INTF1_7xxx_INTR,
> +       MDP_INTF2_7xxx_INTR,
> +       MDP_INTF3_7xxx_INTR,
> +       MDP_INTF4_7xxx_INTR,
>         MDP_INTF5_7xxx_INTR,
>         MDP_INTR_MAX,
>  };

Reviewed-by: Robert Foss <robert.foss@linaro.org>

  reply	other threads:[~2021-11-23 15:50 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-11-23 15:40 [PATCH] drm/msm/dpu: Add more of the INTF interrupt regions Bjorn Andersson
2021-11-23 15:50 ` Robert Foss [this message]
2021-11-23 20:54 ` [Freedreno] " Abhinav Kumar
2021-11-23 21:17   ` Bjorn Andersson

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAG3jFytT1Bvagn8hQnVvE48X-jR+pyNuQtjcgJAYmBC97=BL7g@mail.gmail.com' \
    --to=robert.foss@linaro.org \
    --cc=abhinavk@codeaurora.org \
    --cc=airlied@linux.ie \
    --cc=bjorn.andersson@linaro.org \
    --cc=daniel@ffwll.ch \
    --cc=dmitry.baryshkov@linaro.org \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=freedreno@lists.freedesktop.org \
    --cc=linux-arm-msm@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=robdclark@gmail.com \
    --cc=sean@poorly.run \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).