linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Daniel Latypov <dlatypov@google.com>
To: "André Almeida" <andrealmeid@riseup.net>
Cc: "Maíra Canal" <mairacanal@riseup.net>,
	melissa.srw@gmail.com, daniel@ffwll.ch, javierm@redhat.com,
	siqueirajordao@riseup.net,
	"Isabella Basso" <isabbasso@riseup.net>,
	jose.exposito89@gmail.com, magalilemes00@gmail.com,
	tales.aparecida@gmail.com, davidgow@google.com,
	davem@davemloft.net,
	"Brendan Higgins" <brendanhiggins@google.com>,
	linux-kselftest@vger.kernel.org, kunit-dev@googlegroups.com,
	linux-kernel@vger.kernel.org, airlied@linux.ie, kuba@kernel.org
Subject: Re: [PATCH 2/3] kunit: add KUnit array assertions to the example_all_expect_macros_test
Date: Tue, 2 Aug 2022 11:15:30 -0700	[thread overview]
Message-ID: <CAGS_qxodPndQZ_ypy-QP=ViNUvwZk1z1u8EAv9k5XzDEC4WSGQ@mail.gmail.com> (raw)
In-Reply-To: <5c9038fd-a247-d0d3-841c-ba1e606bc309@riseup.net>

On Tue, Aug 2, 2022 at 9:19 AM André Almeida <andrealmeid@riseup.net> wrote:
> Às 13:12 de 02/08/22, Maíra Canal escreveu:
> > Increament the example_all_expect_macros_test with the
> > KUNIT_EXPECT_ARREQ and KUNIT_EXPECT_ARRNEQ macros by creating a test
> > with array assertions.
> >
> > Signed-off-by: Maíra Canal <mairacanal@riseup.net>
> > ---
> >  lib/kunit/kunit-example-test.c | 7 +++++++
> >  1 file changed, 7 insertions(+)
> >
> > diff --git a/lib/kunit/kunit-example-test.c b/lib/kunit/kunit-example-test.c
> > index f8fe582c9e36..fc81a45d9cbc 100644
> > --- a/lib/kunit/kunit-example-test.c
> > +++ b/lib/kunit/kunit-example-test.c
> > @@ -86,6 +86,9 @@ static void example_mark_skipped_test(struct kunit *test)
> >   */
> >  static void example_all_expect_macros_test(struct kunit *test)
> >  {
> > +     const u32 array[] = { 0x0F, 0xFF };
> > +     const u32 expected[] = { 0x1F, 0xFF };

Given the distance between the definition and their use, perhaps we
can give them clearer names.
E.g. array + diff_array, or array1 + array2, etc.

I think something to indicate they're arrays and that they're different.
The current name `expected` is a bit unclear.

> > +
> >       /* Boolean assertions */
> >       KUNIT_EXPECT_TRUE(test, true);
> >       KUNIT_EXPECT_FALSE(test, false);
> > @@ -109,6 +112,10 @@ static void example_all_expect_macros_test(struct kunit *test)
> >       KUNIT_EXPECT_STREQ(test, "hi", "hi");
> >       KUNIT_EXPECT_STRNEQ(test, "hi", "bye");
> >
> > +     /* Array assertions */
> > +     KUNIT_EXPECT_ARREQ(test, expected, expected, 2);
> > +     KUNIT_EXPECT_ARRNEQ(test, array, expected, 2);
>
> ARRAY_SIZE() is usually better than constants is this case.

Note: that's actually incorrect!

Ah right, this was the other blocker I had in mind.
I wasn't sure how we'd handle the size parameter.

Users might think ARRAY_SIZE() is fine and copy-paste it.
But the size parameter is in units of bytes, not array elements!
If the element types are not 1 byte, it'll silently not compare the full array.

We'd want people to use
KUNIT_EXPECT_ARREQ(test, expected, expected, sizeof(expected));

But this doesn't work for `u32 *array`, since it'll silently just
compare 1 byte if people get them mixed up.

I don't know how we make a maximally fool-proof version of this macro :\

  reply	other threads:[~2022-08-02 18:15 UTC|newest]

Thread overview: 13+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-08-02 16:12 [PATCH 0/3] Introduce KUNIT_EXPECT_ARREQ and KUNIT_EXPECT_ARRNEQ macros Maíra Canal
2022-08-02 16:12 ` [PATCH 1/3] kunit: " Maíra Canal
2022-08-02 16:17   ` André Almeida
2022-08-02 18:19   ` Daniel Latypov
2022-08-02 16:12 ` [PATCH 2/3] kunit: add KUnit array assertions to the example_all_expect_macros_test Maíra Canal
2022-08-02 16:19   ` André Almeida
2022-08-02 18:15     ` Daniel Latypov [this message]
2022-08-02 19:00       ` Maíra Canal
2022-08-02 19:56         ` Daniel Latypov
2022-08-02 16:12 ` [PATCH 3/3] kunit: use KUNIT_EXPECT_ARREQ macro Maíra Canal
2022-08-02 16:59 ` [PATCH 0/3] Introduce KUNIT_EXPECT_ARREQ and KUNIT_EXPECT_ARRNEQ macros Daniel Latypov
2022-08-02 18:43   ` Maíra Canal
2022-08-02 19:36     ` Daniel Latypov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAGS_qxodPndQZ_ypy-QP=ViNUvwZk1z1u8EAv9k5XzDEC4WSGQ@mail.gmail.com' \
    --to=dlatypov@google.com \
    --cc=airlied@linux.ie \
    --cc=andrealmeid@riseup.net \
    --cc=brendanhiggins@google.com \
    --cc=daniel@ffwll.ch \
    --cc=davem@davemloft.net \
    --cc=davidgow@google.com \
    --cc=isabbasso@riseup.net \
    --cc=javierm@redhat.com \
    --cc=jose.exposito89@gmail.com \
    --cc=kuba@kernel.org \
    --cc=kunit-dev@googlegroups.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-kselftest@vger.kernel.org \
    --cc=magalilemes00@gmail.com \
    --cc=mairacanal@riseup.net \
    --cc=melissa.srw@gmail.com \
    --cc=siqueirajordao@riseup.net \
    --cc=tales.aparecida@gmail.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).