From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751092AbcGLSmb (ORCPT ); Tue, 12 Jul 2016 14:42:31 -0400 Received: from mail-wm0-f44.google.com ([74.125.82.44]:38383 "EHLO mail-wm0-f44.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750838AbcGLSma (ORCPT ); Tue, 12 Jul 2016 14:42:30 -0400 MIME-Version: 1.0 In-Reply-To: <20160707181435.GA20948@www.outflux.net> References: <20160707181435.GA20948@www.outflux.net> From: Kees Cook Date: Tue, 12 Jul 2016 14:42:22 -0400 X-Google-Sender-Auth: qfTjV4vKP13Jsoa3j0YPoUlAk70 Message-ID: Subject: Re: [PULL] lkdtm update (next) To: Greg KH Cc: LKML Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Jul 7, 2016 at 2:14 PM, Kees Cook wrote: > Hi, > > Please pull these lkdtm changes for next. Friendly ping... I'd like this refactor to make it in time for the 4.8 merge window. :) -Kees > > Thanks! > > -Kees > > The following changes since commit e2402b1d214e5d50e807773563d590115a161f45: > > nvmem: imx-ocotp: Fix assignment warning. (2016-06-25 07:42:55 -0700) > > are available in the git repository at: > > git://git.kernel.org/pub/scm/linux/kernel/git/kees/linux.git tags/lkdtm-next > > for you to fetch changes up to c479e3fd88703c4b1049d7102a3fa8c6b3affef5: > > lkdtm: use struct arrays instead of enums (2016-07-07 11:09:27 -0700) > > ---------------------------------------------------------------- > refactoring for multiple source files and better layout > > ---------------------------------------------------------------- > Kees Cook (12): > lkdtm: add usercopy test for blocking kernel text > lkdtm: drop "alloc_size" parameter > lkdtm: split usercopy tests to separate file > lkdtm: split memory permissions tests to separate file > lkdtm: split heap corruption tests to separate file > lkdtm: split remaining logic bug tests to separate file > lkdtm: remove intentional off-by-one array access > lkdtm: rename "count" to "crash_count" > lkdtm: rename globals for clarity > lkdtm: reorganize module paramaters > lkdtm: move jprobe entry points to start of source > lkdtm: use struct arrays instead of enums > > drivers/misc/Makefile | 4 + > drivers/misc/lkdtm.h | 51 ++ > drivers/misc/lkdtm_bugs.c | 152 +++++ > drivers/misc/lkdtm_core.c | 1246 ++++++++--------------------------------- > drivers/misc/lkdtm_heap.c | 146 +++++ > drivers/misc/lkdtm_perms.c | 203 +++++++ > drivers/misc/lkdtm_usercopy.c | 315 +++++++++++ > 7 files changed, 1106 insertions(+), 1011 deletions(-) > create mode 100644 drivers/misc/lkdtm_bugs.c > create mode 100644 drivers/misc/lkdtm_heap.c > create mode 100644 drivers/misc/lkdtm_perms.c > create mode 100644 drivers/misc/lkdtm_usercopy.c > > -- > Kees Cook > Chrome OS & Brillo Security -- Kees Cook Chrome OS & Brillo Security