linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Linus Torvalds <torvalds@linux-foundation.org>
To: Christoph Hellwig <hch@lst.de>
Cc: Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	"H. Peter Anvin" <hpa@zytor.com>, Song Liu <song@kernel.org>,
	Al Viro <viro@zeniv.linux.org.uk>,
	linux-raid@vger.kernel.org,
	linux-fsdevel <linux-fsdevel@vger.kernel.org>
Subject: Re: [PATCH 15/17] initramfs: switch initramfs unpacking to struct file based APIs
Date: Thu, 9 Jul 2020 11:23:03 -0700	[thread overview]
Message-ID: <CAHk-=wgXtjWb_sVfaSGTaCToHZmxRs4EHpQ1ck=6B=zGTLuQdQ@mail.gmail.com> (raw)
In-Reply-To: <20200709181227.GA20954@lst.de>

On Thu, Jul 9, 2020 at 11:12 AM Christoph Hellwig <hch@lst.de> wrote:
>
> On Thu, Jul 09, 2020 at 11:07:08AM -0700, Linus Torvalds wrote:
> > On Thu, Jul 9, 2020 at 8:18 AM Christoph Hellwig <hch@lst.de> wrote:
> > >
> > > There is no good reason to mess with file descriptors from in-kernel
> > > code, switch the initramfs unpacking to struct file based write
> > > instead.  As we don't have nice helper for chmod or chown on a struct
> > > file or struct path use the pathname based ones instead there.  This
> > > causes additional (cached) lookups, but keeps the code much simpler.
> >
> > This is the only one I'm not a huge fan of.
> >
> > I agree about moving to 'struct file'. But then you could just do the
> > chown/chmod using chown/chmod_common() on file->f_path.
> >
> > That would keep the same semantics, and it feels like a more
> > straightforward patch.
> >
> > It would still remove the nasty ksys_fchmod/fchmod, it would just
> > require our - already existing - *_common() functions to be non-static
> > (and maybe renamed to "vfs_chown/chmod()" instead, that "*_common()"
> > naming looks a bit odd compared to all our other "vfs_operation()"
> > helpers).
>
> Sure, we can do that.  It requires a little more boilerplate that I
> thought we could just skip.

Yeah, it makes the patch perhaps a bit larger (or rather, it adds one
new patch to do that "introduce new names for *_common() and add them
to the headers"), but just looking at your current patch:

+                       ksys_chown(collected, uid, gid);
+                       ksys_chmod(collected, mode);
+                       if (body_len)
+                               vfs_truncate(&wfile->f_path, body_len);

and I go "wouldn't that look a _lot_ more regular something like this":

+                       vfs_chown(&wfile->f_path, uid, gid);
+                       vfs_chmod(&wfile->f_path, mode);
+                       if (body_len)
+                               vfs_truncate(&wfile->f_path, body_len);

so I think that I'd prefer it simply because it makes all our
interfaces much more natural.

I note that we still need that ksys_chown() because of disgusting
issues with the legacy 16-bit uid support. Which is likely not used
any more now that a.out support is gone (well, alpha and m68k still
define HAVE_AOUT, so it's not "gone" gone, but it's gone).

I can't imagine that anybody would have ELF and 16-bit uid's.

Except users are crazy. So who knows. But it might definitely be time
to deprecate UID16.

That's a separate issue, though, it just came up because of that ksys_chown().

                Linus

  reply	other threads:[~2020-07-09 18:23 UTC|newest]

Thread overview: 26+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-07-09 15:17 decruft the early init / initrd / initramfs code v2 Christoph Hellwig
2020-07-09 15:17 ` [PATCH 01/17] init: remove the bstat helper Christoph Hellwig
2020-07-09 15:17 ` [PATCH 02/17] md: move the early init autodetect code to drivers/md/ Christoph Hellwig
2020-07-09 15:18 ` [PATCH 03/17] md: replace the RAID_AUTORUN ioctl with a direct function call Christoph Hellwig
2020-07-09 15:18 ` [PATCH 04/17] md: remove the autoscan partition re-read Christoph Hellwig
2020-07-09 15:18 ` [PATCH 05/17] md: remove the kernel version of md_u.h Christoph Hellwig
2020-07-09 15:18 ` [PATCH 06/17] md: simplify md_setup_drive Christoph Hellwig
2020-07-09 15:18 ` [PATCH 07/17] md: rewrite md_setup_drive to avoid ioctls Christoph Hellwig
2020-07-09 15:18 ` [PATCH 08/17] initrd: remove support for multiple floppies Christoph Hellwig
2020-07-09 15:18 ` [PATCH 09/17] initrd: remove the BLKFLSBUF call in handle_initrd Christoph Hellwig
2020-07-09 15:18 ` [PATCH 10/17] initrd: switch initrd loading to struct file based APIs Christoph Hellwig
2020-07-09 15:18 ` [PATCH 11/17] initrd: mark init_linuxrc as __init Christoph Hellwig
2020-07-09 15:18 ` [PATCH 12/17] initrd: mark initrd support as deprecated Christoph Hellwig
2020-07-09 15:18 ` [PATCH 13/17] initramfs: remove the populate_initrd_image and clean_rootfs stubs Christoph Hellwig
2020-07-09 15:18 ` [PATCH 14/17] initramfs: simplify clean_rootfs Christoph Hellwig
2020-07-09 15:18 ` [PATCH 15/17] initramfs: switch initramfs unpacking to struct file based APIs Christoph Hellwig
2020-07-09 18:07   ` Linus Torvalds
2020-07-09 18:12     ` Christoph Hellwig
2020-07-09 18:23       ` Linus Torvalds [this message]
2020-07-09 15:18 ` [PATCH 16/17] init: open code setting up stdin/stdout/stderr Christoph Hellwig
2020-07-09 18:32   ` Brian Gerst
2020-07-09 15:18 ` [PATCH 17/17] fs: remove ksys_open Christoph Hellwig
2020-07-09 18:08 ` decruft the early init / initrd / initramfs code v2 Linus Torvalds
2020-07-09 23:32 ` hpa
2020-07-14  6:41   ` Christoph Hellwig
2020-07-14 16:20     ` Song Liu

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAHk-=wgXtjWb_sVfaSGTaCToHZmxRs4EHpQ1ck=6B=zGTLuQdQ@mail.gmail.com' \
    --to=torvalds@linux-foundation.org \
    --cc=hch@lst.de \
    --cc=hpa@zytor.com \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-raid@vger.kernel.org \
    --cc=song@kernel.org \
    --cc=viro@zeniv.linux.org.uk \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).