linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rafael@kernel.org>
To: Huang Rui <ray.huang@amd.com>
Cc: "Rafael J . Wysocki" <rafael.j.wysocki@intel.com>,
	"linux-pm@vger.kernel.org" <linux-pm@vger.kernel.org>,
	"linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] cpufreq: enhance the sequency of governor change
Date: Wed, 4 Aug 2021 19:00:23 +0200	[thread overview]
Message-ID: <CAJZ5v0gMqFBDubQyG3YSnt1RcGzfjnxvLtTNpCdqZDjdAMJh=w@mail.gmail.com> (raw)
In-Reply-To: <20210803001339.GG2563957@hr-amd>

On Tue, Aug 3, 2021 at 2:13 AM Huang Rui <ray.huang@amd.com> wrote:
>
> Ping~

I prefer the existing code, sorry.

> On Wed, Jul 21, 2021 at 06:16:58PM +0800, Huang, Ray wrote:
> > Keep the "success" case of governor change in the mainline of the
> > function not in "if" case. And using restart_old_gov flag to indicate
> > the fallback case to old governor. This is more readable and no function
> > change.
> >
> > Signed-off-by: Huang Rui <ray.huang@amd.com>
> > ---
> >  drivers/cpufreq/cpufreq.c | 23 +++++++++++++++--------
> >  1 file changed, 15 insertions(+), 8 deletions(-)
> >
> > diff --git a/drivers/cpufreq/cpufreq.c b/drivers/cpufreq/cpufreq.c
> > index 802abc925b2a..4f7005ddb70c 100644
> > --- a/drivers/cpufreq/cpufreq.c
> > +++ b/drivers/cpufreq/cpufreq.c
> > @@ -2545,18 +2545,25 @@ static int cpufreq_set_policy(struct cpufreq_policy *policy,
> >       /* start new governor */
> >       policy->governor = new_gov;
> >       ret = cpufreq_init_governor(policy);
> > -     if (!ret) {
> > -             ret = cpufreq_start_governor(policy);
> > -             if (!ret) {
> > -                     pr_debug("governor change\n");
> > -                     sched_cpufreq_governor_change(policy, old_gov);
> > -                     return 0;
> > -             }
> > +     if (ret)
> > +             goto restart_old_gov;
> > +
> > +     ret = cpufreq_start_governor(policy);
> > +     if (ret) {
> >               cpufreq_exit_governor(policy);
> > +             goto restart_old_gov;
> >       }
> >
> > +     pr_debug("governor change\n");
> > +
> > +     sched_cpufreq_governor_change(policy, old_gov);
> > +
> > +     return 0;
> > +
> > +restart_old_gov:
> >       /* new governor failed, so re-start old one */
> > -     pr_debug("starting governor %s failed\n", policy->governor->name);
> > +     pr_debug("starting governor %s failed\n",
> > +              policy->governor->name);
> >       if (old_gov) {
> >               policy->governor = old_gov;
> >               if (cpufreq_init_governor(policy))
> > --

  reply	other threads:[~2021-08-04 17:00 UTC|newest]

Thread overview: 4+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-21 10:16 [PATCH] cpufreq: enhance the sequency of governor change Huang Rui
2021-08-03  0:13 ` Huang Rui
2021-08-04 17:00   ` Rafael J. Wysocki [this message]
2021-08-05  6:39     ` Huang Rui

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAJZ5v0gMqFBDubQyG3YSnt1RcGzfjnxvLtTNpCdqZDjdAMJh=w@mail.gmail.com' \
    --to=rafael@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=rafael.j.wysocki@intel.com \
    --cc=ray.huang@amd.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).