linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rafael@kernel.org>
To: Daniel Lezcano <daniel.lezcano@linexp.org>
Cc: "Rafael J. Wysocki" <rafael@kernel.org>,
	Daniel Lezcano <daniel.lezcano@linaro.org>,
	"Zhang, Rui" <rui.zhang@intel.com>,
	Linux PM <linux-pm@vger.kernel.org>,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>,
	Kevin Hilman <khilman@baylibre.com>,
	Alexandre Bailon <abailon@baylibre.com>,
	Lukasz Luba <lukasz.luba@arm.com>,
	Amit Kucheria <amitk@kernel.org>
Subject: Re: [PATCH v5 10/12] thermal/of: Store the trips in the thermal zone
Date: Fri, 22 Jul 2022 18:59:51 +0200	[thread overview]
Message-ID: <CAJZ5v0gOeoz7ifDWwKW0D2h8WUJmLeDCF2bD8hu5Sm--BOPLVA@mail.gmail.com> (raw)
In-Reply-To: <c75d5dca-17d5-6542-b0aa-46ed036567c7@linexp.org>

On Thu, Jul 21, 2022 at 11:31 PM Daniel Lezcano
<daniel.lezcano@linexp.org> wrote:
>
> On 19/07/2022 20:24, Rafael J. Wysocki wrote:
> > On Sun, Jul 10, 2022 at 2:35 PM Daniel Lezcano
> > <daniel.lezcano@linexp.org> wrote:
> >> As the thermal zone contains the trip point, we can store them
> >> directly when registering the thermal zone. That will allow another
> >> step forward to remove the duplicate thermal zone structure we find in
> >> the thermal_of code.
> >>
> >> Cc: Alexandre Bailon <abailon@baylibre.com>
> >> Cc: Kevin Hilman <khilman@baylibre.com>
> >> Signed-off-by: Daniel Lezcano <daniel.lezcano@linexp.org>
> >> ---
> >>   drivers/thermal/thermal_of.c | 8 +++-----
> >>   1 file changed, 3 insertions(+), 5 deletions(-)
> >>
> >> diff --git a/drivers/thermal/thermal_of.c b/drivers/thermal/thermal_of.c
> >> index 19243c57b3f4..e187461dd396 100644
> >> --- a/drivers/thermal/thermal_of.c
> >> +++ b/drivers/thermal/thermal_of.c
> >> @@ -1119,11 +1119,9 @@ int __init of_parse_thermal_zones(void)
> >>                  tzp->slope = tz->slope;
> >>                  tzp->offset = tz->offset;
> >>
> >> -               zone = thermal_zone_device_register(child->name, tz->ntrips,
> >> -                                                   mask, tz,
> >> -                                                   ops, tzp,
> >> -                                                   tz->passive_delay,
> >> -                                                   tz->polling_delay);
> >> +               zone = thermal_zone_device_register_with_trips(child->name, tz->trips, tz->ntrips,
> >> +                                                              mask, tz, ops, tzp, tz->passive_delay,
> >> +                                                              tz->polling_delay);
> >>                  if (IS_ERR(zone)) {
> >>                          pr_err("Failed to build %pOFn zone %ld\n", child,
> >>                                 PTR_ERR(zone));
> >> --
> > IMO it would be less confusing if this was merged with the patch
> > introducing thermal_zone_device_register_with_trips().
>
> You suggest to merge 8,9 and 10, right ?

Yes, if that makes sense.

Generally speaking, I prefer the changes in every patch to be
self-contained, unless the patch would be too large this way or it
would cross boundaries of many subsystems.

  reply	other threads:[~2022-07-22 17:00 UTC|newest]

Thread overview: 25+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-07-10 12:34 [PATCH v5 00/12] thermal OF rework Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 01/12] thermal/core: Remove duplicate information when an error occurs Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 02/12] thermal/of: Replace device node match with device node search Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 03/12] thermal/of: Remove the device node pointer for thermal_trip Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 04/12] thermal/of: Move thermal_trip structure to thermal.h Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 05/12] thermal/core: Remove unneeded EXPORT_SYMBOLS Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 06/12] thermal/core: Move thermal_set_delay_jiffies to static Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 07/12] thermal/core: Rename trips to ntrips Daniel Lezcano
2022-07-19 18:15   ` Rafael J. Wysocki
2022-07-10 12:35 ` [PATCH v5 07/12] thermal/core: Rename 'trips' to 'num_trips' Daniel Lezcano
2022-07-19 18:16   ` Rafael J. Wysocki
2022-07-10 12:35 ` [PATCH v5 08/12] thermal/core: Add thermal_trip in thermal_zone Daniel Lezcano
2022-07-19 18:18   ` Rafael J. Wysocki
2022-07-10 12:35 ` [PATCH v5 09/12] thermal/core: Register with the trip points Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 10/12] thermal/of: Store the trips in the thermal zone Daniel Lezcano
2022-07-19 18:24   ` Rafael J. Wysocki
2022-07-21 21:31     ` Daniel Lezcano
2022-07-22 16:59       ` Rafael J. Wysocki [this message]
2022-07-10 12:35 ` [PATCH v5 11/12] thermal/of: Use thermal trips stored " Daniel Lezcano
2022-07-19 18:26   ` Rafael J. Wysocki
2022-07-21 21:29     ` Daniel Lezcano
2022-07-22 16:50       ` Rafael J. Wysocki
2022-07-22 17:25         ` Daniel Lezcano
2022-07-10 12:35 ` [PATCH v5 12/12] thermal/of: Initialize trip points separately Daniel Lezcano
2022-07-16 21:56 ` [PATCH v5 00/12] thermal OF rework Daniel Lezcano

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAJZ5v0gOeoz7ifDWwKW0D2h8WUJmLeDCF2bD8hu5Sm--BOPLVA@mail.gmail.com \
    --to=rafael@kernel.org \
    --cc=abailon@baylibre.com \
    --cc=amitk@kernel.org \
    --cc=daniel.lezcano@linaro.org \
    --cc=daniel.lezcano@linexp.org \
    --cc=khilman@baylibre.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=lukasz.luba@arm.com \
    --cc=rui.zhang@intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).