From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-14.0 required=3.0 tests=BAYES_00,INCLUDES_CR_TRAILER, INCLUDES_PATCH,MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS,URIBL_BLOCKED autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id CACEDC433E6 for ; Tue, 12 Jan 2021 19:31:16 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id A33F323125 for ; Tue, 12 Jan 2021 19:31:16 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S2437097AbhALTal (ORCPT ); Tue, 12 Jan 2021 14:30:41 -0500 Received: from mail-ot1-f51.google.com ([209.85.210.51]:37312 "EHLO mail-ot1-f51.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1732921AbhALTaj (ORCPT ); Tue, 12 Jan 2021 14:30:39 -0500 Received: by mail-ot1-f51.google.com with SMTP id o11so3403074ote.4; Tue, 12 Jan 2021 11:30:23 -0800 (PST) X-Google-DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed; d=1e100.net; s=20161025; h=x-gm-message-state:mime-version:references:in-reply-to:from:date :message-id:subject:to:cc; bh=dBLiJeNQADKjUgSbhzyFOUFac404UUfzi1rI55CmkHI=; b=PNO63moDBC4c2m9l6EqU/kyXT7aItHwIoLUrrtMagN3mD505VbIJuNn/nAqzT9snP0 /M3LeRNzExzUz+/vWMquYI1q8NIWKlRwhTKz2k8uJYI91hxLq6SwTY+wqkteuu/hnLBE Odd2zifHVg4vx18IcS5YFOuuX2vBwaJWshL/92pQ4D136AcjhPvkjmk/wZ0B5LKALtAs bHzktdQ8vNlgFL1k+M9GjZ7U8E4mjPRccA+1WKEZKf6/HFL62p08V26N0ItDkZ6RuBem M4QgMBxO9fF1X2ktS3YsueOgASHEjbLaKPDbhrZwZkr1UaRuToZaT3s/0i/KHG3dPSH6 UF3w== X-Gm-Message-State: AOAM531Wos61s7WIt8jsTQK3GgLlLu1uPnSC9IighVn97ZQnl+CwH0GT 1DcuAHcazu6YcncSVAfbvXI3NQRTBnti2CNrqOk= X-Google-Smtp-Source: ABdhPJy/n4CyOG7sST+sBvOp4dcWNxGAIaKS2+2pUstHMvFelSX1gYALDbvieubLL47HjuuhD8Y/beILkYvFHG1IyX0= X-Received: by 2002:a9d:208a:: with SMTP id x10mr652265ota.260.1610479797900; Tue, 12 Jan 2021 11:29:57 -0800 (PST) MIME-Version: 1.0 References: <20210107132838.396641-1-djrscally@gmail.com> <20210107132838.396641-8-djrscally@gmail.com> In-Reply-To: <20210107132838.396641-8-djrscally@gmail.com> From: "Rafael J. Wysocki" Date: Tue, 12 Jan 2021 20:29:46 +0100 Message-ID: Subject: Re: [PATCH v5 07/15] device property: Define format macros for ports and endpoints To: Daniel Scally Cc: Linux Kernel Mailing List , ACPI Devel Maling List , Linux Media Mailing List , "open list:ACPI COMPONENT ARCHITECTURE (ACPICA)" , "Rafael J. Wysocki" , Len Brown , Greg Kroah-Hartman , Mauro Carvalho Chehab , Sergey Senozhatsky , yong.zhi@intel.com, Sakari Ailus , Bingbu Cao , tian.shu.qiu@intel.com, Robert Moore , Erik Kaneda , Petr Mladek , Steven Rostedt , Andy Shevchenko , Rasmus Villemoes , Laurent Pinchart , Jacopo Mondi , Kieran Bingham , hverkuil-cisco@xs4all.nl, m.felsch@pengutronix.de, Niklas Soderlund , prabhakar.mahadev-lad.rj@bp.renesas.com, Steve Longerbeam , Heikki Krogerus , Andy Shevchenko , Laurent Pinchart Content-Type: text/plain; charset="UTF-8" Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Jan 7, 2021 at 2:31 PM Daniel Scally wrote: > > OF, ACPI and software_nodes all implement graphs including nodes for ports > and endpoints. These are all intended to be named with a common schema, > as "port@n" and "endpoint@n" where n is an unsigned int representing the > index of the node. To ensure commonality across the subsystems, provide a > set of macros to define the format. > > Suggested-by: Andy Shevchenko > Reviewed-by: Andy Shevchenko > Reviewed-by: Laurent Pinchart > Signed-off-by: Daniel Scally Acked-by: Rafael J. Wysocki > --- > Changes in v5: > > - Changed commit subject > > include/linux/fwnode.h | 7 +++++++ > 1 file changed, 7 insertions(+) > > diff --git a/include/linux/fwnode.h b/include/linux/fwnode.h > index fde4ad97564c..77414e431e89 100644 > --- a/include/linux/fwnode.h > +++ b/include/linux/fwnode.h > @@ -50,6 +50,13 @@ struct fwnode_endpoint { > const struct fwnode_handle *local_fwnode; > }; > > +/* > + * ports and endpoints defined as software_nodes should all follow a common > + * naming scheme; use these macros to ensure commonality. > + */ > +#define SWNODE_GRAPH_PORT_NAME_FMT "port@%u" > +#define SWNODE_GRAPH_ENDPOINT_NAME_FMT "endpoint@%u" > + > #define NR_FWNODE_REFERENCE_ARGS 8 > > /** > -- > 2.25.1 >