linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Rafael J. Wysocki" <rafael@kernel.org>
To: Len Baker <len.baker@gmx.com>
Cc: "Rafael J. Wysocki" <rjw@rjwysocki.net>,
	Viresh Kumar <viresh.kumar@linaro.org>,
	Kees Cook <keescook@chromium.org>,
	Linux PM <linux-pm@vger.kernel.org>,
	linux-hardening@vger.kernel.org,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH] cpufreq: powernow: Prefer kcalloc over open coded arithmetic
Date: Mon, 6 Sep 2021 19:05:06 +0200	[thread overview]
Message-ID: <CAJZ5v0inR2Sj3cRXYa3ip3hG1-1Gbv3QHExQmGO12AJmUjYB5w@mail.gmail.com> (raw)
In-Reply-To: <20210904151628.6618-1-len.baker@gmx.com>

On Sat, Sep 4, 2021 at 5:16 PM Len Baker <len.baker@gmx.com> wrote:
>
> As noted in the "Deprecated Interfaces, Language Features, Attributes,
> and Conventions" documentation [1], size calculations (especially
> multiplication) should not be performed in memory allocator (or similar)
> function arguments due to the risk of them overflowing. This could lead
> to values wrapping around and a smaller allocation being made than the
> caller was expecting. Using those allocations could lead to linear
> overflows of heap memory and other misbehaviors.
>
> So, use the purpose specific kcalloc() function instead of the argument
> size * count in the kzalloc() function.
>
> [1] https://www.kernel.org/doc/html/v5.14/process/deprecated.html#open-coded-arithmetic-in-allocator-arguments
>
> Signed-off-by: Len Baker <len.baker@gmx.com>

I'm assuming that this patch will be picked up by the powerpc arch maintainers.

> ---
>  drivers/cpufreq/powernow-k7.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/cpufreq/powernow-k7.c b/drivers/cpufreq/powernow-k7.c
> index 5d515fc34836..a9d2c7bae235 100644
> --- a/drivers/cpufreq/powernow-k7.c
> +++ b/drivers/cpufreq/powernow-k7.c
> @@ -174,8 +174,8 @@ static int get_ranges(unsigned char *pst)
>         unsigned int speed;
>         u8 fid, vid;
>
> -       powernow_table = kzalloc((sizeof(*powernow_table) *
> -                               (number_scales + 1)), GFP_KERNEL);
> +       powernow_table = kcalloc(number_scales + 1, sizeof(*powernow_table),
> +                                GFP_KERNEL);
>         if (!powernow_table)
>                 return -ENOMEM;
>
> --
> 2.25.1
>

      reply	other threads:[~2021-09-06 17:05 UTC|newest]

Thread overview: 2+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-09-04 15:16 [PATCH] cpufreq: powernow: Prefer kcalloc over open coded arithmetic Len Baker
2021-09-06 17:05 ` Rafael J. Wysocki [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAJZ5v0inR2Sj3cRXYa3ip3hG1-1Gbv3QHExQmGO12AJmUjYB5w@mail.gmail.com \
    --to=rafael@kernel.org \
    --cc=keescook@chromium.org \
    --cc=len.baker@gmx.com \
    --cc=linux-hardening@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pm@vger.kernel.org \
    --cc=rjw@rjwysocki.net \
    --cc=viresh.kumar@linaro.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).