linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Arnd Bergmann <arnd@arndb.de>
To: Boqun Feng <boqun.feng@gmail.com>
Cc: "Bjorn Helgaas" <helgaas@kernel.org>,
	"Bjorn Helgaas" <bhelgaas@google.com>,
	"Arnd Bergmann" <arnd@arndb.de>, "Marc Zyngier" <maz@kernel.org>,
	"Catalin Marinas" <catalin.marinas@arm.com>,
	"Will Deacon" <will@kernel.org>,
	"K. Y. Srinivasan" <kys@microsoft.com>,
	"Haiyang Zhang" <haiyangz@microsoft.com>,
	"Stephen Hemminger" <sthemmin@microsoft.com>,
	"Wei Liu" <wei.liu@kernel.org>,
	"Dexuan Cui" <decui@microsoft.com>,
	"Lorenzo Pieralisi" <lorenzo.pieralisi@arm.com>,
	"Rob Herring" <robh@kernel.org>,
	"Krzysztof Wilczyński" <kw@linux.com>,
	"Linux ARM" <linux-arm-kernel@lists.infradead.org>,
	"Linux Kernel Mailing List" <linux-kernel@vger.kernel.org>,
	"Linux on Hyper-V List" <linux-hyperv@vger.kernel.org>,
	linux-pci <linux-pci@vger.kernel.org>,
	"Sunil Muthuswamy" <sunilmut@microsoft.com>,
	"Mike Rapoport" <rppt@kernel.org>
Subject: Re: [RFC v4 1/7] PCI: Introduce domain_nr in pci_host_bridge
Date: Thu, 15 Jul 2021 21:11:42 +0200	[thread overview]
Message-ID: <CAK8P3a3H38aeO6hUNeLAxV4ypfX+qTaCoRAJWYdP9wbvc9HuVQ@mail.gmail.com> (raw)
In-Reply-To: <YPBwzO7c/rw09IkE@boqun-archlinux>

On Thu, Jul 15, 2021 at 7:30 PM Boqun Feng <boqun.feng@gmail.com> wrote:
> On Wed, Jul 14, 2021 at 02:33:19PM -0500, Bjorn Helgaas wrote:
> > On Wed, Jul 14, 2021 at 06:27:31PM +0800, Boqun Feng wrote:
> > >  #ifdef CONFIG_PCI_DOMAINS_GENERIC
> > > -   bus->domain_nr = pci_bus_find_domain_nr(bus, parent);
> > > +   if (bridge->domain_nr == PCI_DOMAIN_NR_NOT_SET)
> > > +           bus->domain_nr = pci_bus_find_domain_nr(bus, parent);
> > > +   else
> > > +           bus->domain_nr = bridge->domain_nr;
> >
> > The domain_nr in struct pci_bus is really only used by
> > pci_domain_nr().  It seems like it really belongs in the struct
> > pci_host_bridge and probably doesn't need to be duplicated in the
> > struct pci_bus.  But that's probably a project for the future.
> >

+1

> Agreed. Maybe we can define pci_bus_domain_nr() as:
>
>         static inline int pci_domain_nr(struct pci_bus *bus)
>         {
>                 struct device *bridge = bus->bridge;
>                 struct pci_host_bridge *b = container_of(bridge, struct pci_host_bridge, dev);
>
>                 return b->domain_nr;
>         }
>
> but apart from corretness (e.g. should we use get_device() for
> bus->bridge?), it makes more sense if ->domain_nr of pci_host_bridge
> is used (as a way to set domain number at probing time) for most of
> drivers and archs. ;-)

It needs to be "pci_find_host_bridge(bus)" instead of bus->bridge
and container_of().

Then again, if we get pci_domain_nr() to be completely generic, I'd
prefer to change most callers to just open-code the bridge->domain_nr
access, as most of them will already have a pointer to the pci_host_bridge
when calling this.

       Arnd

  parent reply	other threads:[~2021-07-15 19:38 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2021-07-14 10:27 [RFC v4 0/7] PCI: hv: Support host bridge probing on ARM64 Boqun Feng
2021-07-14 10:27 ` [RFC v4 1/7] PCI: Introduce domain_nr in pci_host_bridge Boqun Feng
2021-07-14 19:33   ` Bjorn Helgaas
2021-07-15 17:30     ` Boqun Feng
2021-07-15 19:07       ` Bjorn Helgaas
2021-07-15 19:11       ` Arnd Bergmann [this message]
2021-07-14 10:27 ` [RFC v4 2/7] PCI: Allow msi domain set-up at host probing time Boqun Feng
2021-07-14 19:39   ` Bjorn Helgaas
2021-07-14 10:27 ` [RFC v4 3/7] arm64: PCI: Support root bridge preparation for Hyper-V PCI Boqun Feng
2021-07-14 19:46   ` Bjorn Helgaas
2021-07-14 10:27 ` [RFC v4 4/7] PCI: hv: Generify PCI probing Boqun Feng
2021-07-14 19:49   ` Bjorn Helgaas
2021-07-14 10:27 ` [RFC v4 5/7] PCI: hv: Use pci_host_bridge::domain_nr for PCI domain Boqun Feng
2021-07-14 17:04   ` [EXTERNAL] " Sunil Muthuswamy
2021-07-15  3:59     ` Boqun Feng
2021-07-14 10:27 ` [RFC v4 6/7] PCI: hv: Set up msi domain at bridge probing time Boqun Feng
2021-07-14 10:27 ` [RFC v4 7/7] PCI: hv: Turn on the host bridge probing on ARM64 Boqun Feng

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAK8P3a3H38aeO6hUNeLAxV4ypfX+qTaCoRAJWYdP9wbvc9HuVQ@mail.gmail.com \
    --to=arnd@arndb.de \
    --cc=bhelgaas@google.com \
    --cc=boqun.feng@gmail.com \
    --cc=catalin.marinas@arm.com \
    --cc=decui@microsoft.com \
    --cc=haiyangz@microsoft.com \
    --cc=helgaas@kernel.org \
    --cc=kw@linux.com \
    --cc=kys@microsoft.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-hyperv@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-pci@vger.kernel.org \
    --cc=lorenzo.pieralisi@arm.com \
    --cc=maz@kernel.org \
    --cc=robh@kernel.org \
    --cc=rppt@kernel.org \
    --cc=sthemmin@microsoft.com \
    --cc=sunilmut@microsoft.com \
    --cc=wei.liu@kernel.org \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).