linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Vincent Guittot <vincent.guittot@linaro.org>
To: Vincent Donnefort <vdonnefort@google.com>
Cc: Dietmar Eggemann <dietmar.eggemann@arm.com>,
	peterz@infradead.org, mingo@redhat.com,
	linux-kernel@vger.kernel.org, morten.rasmussen@arm.com,
	chris.redpath@arm.com, qperret@google.com, tao.zhou@linux.dev,
	kernel-team@android.com
Subject: Re: [PATCH v9 2/7] sched/fair: Decay task PELT values during wakeup migration
Date: Tue, 7 Jun 2022 12:19:14 +0200	[thread overview]
Message-ID: <CAKfTPtC1OQVLpHm3Qmj0bD0fZKp76DQf9tNruNMG57u4yv42sQ@mail.gmail.com> (raw)
In-Reply-To: <Yp8ico+B8USmi7fY@google.com>

On Tue, 7 Jun 2022 at 12:03, Vincent Donnefort <vdonnefort@google.com> wrote:
>
> [...]
>
> > > >
> > > > > diff --git a/kernel/sched/sched.h b/kernel/sched/sched.h
> > > > > index bf4a0ec98678..97bc26e5c8af 100644
> > > > > --- a/kernel/sched/sched.h
> > > > > +++ b/kernel/sched/sched.h
> > > > > @@ -648,6 +648,10 @@ struct cfs_rq {
> > > > >     int                     runtime_enabled;
> > > > >     s64                     runtime_remaining;
> > > > >
> > > > > +   u64                     throttled_pelt_idle;
> > > > > +#ifndef CONFIG_64BIT
> > > > > +   u64                     throttled_pelt_idle_copy;
> > > > > +#endif
> > > > >     u64                     throttled_clock;
> > > > >     u64                     throttled_clock_pelt;
> > > > >     u64                     throttled_clock_pelt_time;
> > > > > @@ -1020,6 +1024,12 @@ struct rq {
> > > > >     u64                     clock_task ____cacheline_aligned;
> > > > >     u64                     clock_pelt;
> > > > >     unsigned long           lost_idle_time;
> > > > > +   u64                     clock_pelt_idle;
> > > > > +   u64                     enter_idle;
> > > > > +#ifndef CONFIG_64BIT
> > > > > +   u64                     clock_pelt_idle_copy;
> > > > > +   u64                     enter_idle_copy;
> > > > > +#endif
> > > > >
> > > > >     atomic_t                nr_iowait;
> > > >
> > > > `throttled_pelt_idle`, `clock_pelt_idle` and `enter_idle` are clock
> > > > snapshots when cfs_rq resp. rq go idle. But the naming does not really
> > > > show this relation. And this makes reading those equations rather difficult.
> > > >
> > > > What about something like `throttled_clock_pelt_time_enter_idle`,
> > > > `clock_pelt_enter_idle`, `clock_enter_idle`? Especially the first one is
> > > > too long but something which shows that those are clock snapshots when
> > > > enter idle would IMHO augment readability in migrate_se_pelt_lag().
> > >
> > > What if I drop the "enter"?
> > >
> > >  clock_idle;
> > >  clock_pelt_idle;
> > >  throttled_clock_pelt_time_idle;
> >
> > and you can even remove the _time for throttled_clock_pelt_idle
> >
>
> Hum, "throttled_clock_pelt" already exists, while what we really snapshot is
> "throttled_clock_pelt_time".

What is snapshot is throttled_clock_pelt when entering idle so my
proposal of "throttled_clock_pelt_idle"
throttled_clock_pelt_idle doesn't exist and reflect  that it's
throttled_clock_pelt when cfs_rq enter idle just like clock_pelt_idle
reflect clock_pelt when entering idle

  reply	other threads:[~2022-06-07 10:19 UTC|newest]

Thread overview: 22+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2022-05-23 15:51 [PATCH v9 0/7] feec() energy margin removal Vincent Donnefort
2022-05-23 15:51 ` [PATCH v9 1/7] sched/fair: Provide u64 read for 32-bits arch helper Vincent Donnefort
2022-05-23 15:51 ` [PATCH v9 2/7] sched/fair: Decay task PELT values during wakeup migration Vincent Donnefort
2022-05-30 16:31   ` Vincent Guittot
2022-05-31  8:16   ` Dietmar Eggemann
2022-06-06  9:31     ` Vincent Donnefort
2022-06-07  6:57       ` Vincent Guittot
2022-06-07 10:03         ` Vincent Donnefort
2022-06-07 10:19           ` Vincent Guittot [this message]
2022-05-23 15:51 ` [PATCH v9 3/7] sched, drivers: Remove max param from effective_cpu_util()/sched_cpu_util() Vincent Donnefort
2022-05-31  7:59   ` Vincent Guittot
2022-05-23 15:51 ` [PATCH v9 4/7] sched/fair: Rename select_idle_mask to select_rq_mask Vincent Donnefort
2022-06-02 13:07   ` Vincent Guittot
2022-05-23 15:51 ` [PATCH v9 5/7] sched/fair: Use the same cpumask per-PD throughout find_energy_efficient_cpu() Vincent Donnefort
2022-06-02 13:16   ` Vincent Guittot
2022-05-23 15:51 ` [PATCH v9 6/7] sched/fair: Remove task_util from effective utilization in feec() Vincent Donnefort
2022-05-31  8:17   ` Dietmar Eggemann
2022-06-06  9:32     ` Vincent Donnefort
2022-06-02 13:58   ` Vincent Guittot
2022-06-06  9:41     ` Vincent Donnefort
2022-06-07  6:59       ` Vincent Guittot
2022-05-23 15:51 ` [PATCH v9 7/7] sched/fair: Remove the energy margin " Vincent Donnefort

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=CAKfTPtC1OQVLpHm3Qmj0bD0fZKp76DQf9tNruNMG57u4yv42sQ@mail.gmail.com \
    --to=vincent.guittot@linaro.org \
    --cc=chris.redpath@arm.com \
    --cc=dietmar.eggemann@arm.com \
    --cc=kernel-team@android.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=morten.rasmussen@arm.com \
    --cc=peterz@infradead.org \
    --cc=qperret@google.com \
    --cc=tao.zhou@linux.dev \
    --cc=vdonnefort@google.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).