linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Ard Biesheuvel <ard.biesheuvel@linaro.org>
To: Arnd Bergmann <arnd@arndb.de>
Cc: Kees Cook <keescook@chromium.org>,
	Herbert Xu <herbert@gondor.apana.org.au>,
	"Gustavo A. R. Silva" <gustavo@embeddedor.com>,
	Eric Biggers <ebiggers@google.com>,
	Alasdair Kergon <agk@redhat.com>,
	Giovanni Cabiddu <giovanni.cabiddu@intel.com>,
	Lars Persson <larper@axis.com>, Mike Snitzer <snitzer@redhat.com>,
	Rabin Vincent <rabinv@axis.com>,
	Tim Chen <tim.c.chen@linux.intel.com>,
	"David S. Miller" <davem@davemloft.net>,
	Masahiro Yamada <yamada.masahiro@socionext.com>,
	"open list:HARDWARE RANDOM NUMBER GENERATOR CORE" 
	<linux-crypto@vger.kernel.org>,
	qat-linux@intel.com, dm-devel@redhat.com,
	Linux Kernel Mailing List <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v4 11/14] treewide: Prepare to remove VLA usage for AHASH_REQUEST_ON_STACK
Date: Thu, 19 Jul 2018 00:33:54 +0900	[thread overview]
Message-ID: <CAKv+Gu-NBKxzV5PYAuzeP5xXfsk=Kw41677ASzRkD6=xO23zeQ@mail.gmail.com> (raw)
In-Reply-To: <CAK8P3a3C1ihC=X=kZ0S836xeMJSGSy6OLNAcBEkdZ35N04bAMw@mail.gmail.com>

On 19 July 2018 at 00:33, Arnd Bergmann <arnd@arndb.de> wrote:
> On Wed, Jul 18, 2018 at 5:19 PM, Ard Biesheuvel
> <ard.biesheuvel@linaro.org> wrote:
>> On 18 July 2018 at 23:50, Ard Biesheuvel <ard.biesheuvel@linaro.org> wrote:
>>> On 18 July 2018 at 05:59, Arnd Bergmann <arnd@arndb.de> wrote:
>>>> On Sun, Jul 15, 2018 at 6:28 AM, Kees Cook <keescook@chromium.org> wrote:
>>>>>
>>>>> After my ahash to shash conversions, only ccm is left as an ahash
>>>>> user, since it actually uses sg. But with the hard-coded value reduced
>>>>> to 376, this doesn't trip the frame warnings any more. :)
>>>>>
>>>>> I'll send an updated series soon.
>>>>
>>>> Maybe we should get rid of that one as well then and remove
>>>> AHASH_REQUEST_ON_STACK()?
>>>>
>>>> I see that Ard (now on Cc) added this usage only recently. Looking
>>>> at the code some more, I also find that the descsize is probably
>>>> much smaller than 376 for all possible cases   of "cbcmac(*)",
>>>> either alg->cra_blocksize plus a few bytes or sizeof(mac_desc_ctx)
>>>> (i.e. 20) for arch/arm64/crypto/aes-glue.c.
>>>>
>>>> Walking the sglist here means open-coding a shash_ahash_update()
>>>> implementation in crypto_ccm_auth(), that that doesn't seem to
>>>> add much complexity over what it already has to do to chain
>>>> the sglist today.
>>>>
>>>
>>> It would be better to add a variably sized ahash request member to
>>> struct crypto_ccm_req_priv_ctx, the only problem is that the last
>>> member of that struct (skreq) is variably sized already, so it would
>>> involve having a struct ahash_request pointer pointing into the same
>>> struct, after the skreq member.
>>
>> Actually, I think the below should already do the trick: ahreq and
>> skreq are not used at the same time, so we can stick them in a union,
>> and take the max() of the reqsize to ensure there's enough empty space
>> after it.
>
> This looks very nice indeed.
>
>> --------8<----------
>> diff --git a/crypto/ccm.c b/crypto/ccm.c
>> index 0a083342ec8c..b242fd0d3262 100644
>> --- a/crypto/ccm.c
>> +++ b/crypto/ccm.c
>> @@ -50,7 +50,10 @@ struct crypto_ccm_req_priv_ctx {
>>         u32 flags;
>>         struct scatterlist src[3];
>>         struct scatterlist dst[3];
>> -       struct skcipher_request skreq;
>> +       union {
>> +               struct ahash_request ahreq;
>> +               struct skcipher_request skreq;
>> +       };
>>  };
>>
>
> And this structure is never put on the stack anywhere but
> always dynamically allocated anyway, right?
>

Yes.

  reply	other threads:[~2018-07-18 15:33 UTC|newest]

Thread overview: 53+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-07-11 20:36 [PATCH v4 00/14] crypto: Remove VLA usage Kees Cook
2018-07-11 20:36 ` [PATCH v4 01/14] crypto: xcbc: " Kees Cook
2018-07-11 20:36 ` [PATCH v4 02/14] crypto: cbc: " Kees Cook
2018-07-11 20:36 ` [PATCH v4 03/14] crypto: shash: " Kees Cook
2018-07-11 20:36 ` [PATCH v4 04/14] dm integrity: " Kees Cook
2018-07-11 20:36 ` [PATCH v4 05/14] crypto: ahash: " Kees Cook
2018-07-11 20:36 ` [PATCH v4 06/14] dm verity fec: " Kees Cook
2018-07-11 20:36 ` [PATCH v4 07/14] crypto alg: Introduce generic max blocksize and alignmask Kees Cook
2018-07-11 20:36 ` [PATCH v4 08/14] crypto: qat: Remove VLA usage Kees Cook
2018-07-11 20:36 ` [PATCH v4 09/14] crypto: shash: Remove VLA usage in unaligned hashing Kees Cook
2018-07-11 20:36 ` [PATCH v4 10/14] kbuild: Introduce FRAME_WARN_BUMP_FLAG Kees Cook
2018-07-11 20:36 ` [PATCH v4 11/14] treewide: Prepare to remove VLA usage for AHASH_REQUEST_ON_STACK Kees Cook
2018-07-12 16:02   ` Arnd Bergmann
2018-07-12 20:17     ` Kees Cook
2018-07-12 21:38       ` Arnd Bergmann
2018-07-13  0:40     ` Herbert Xu
2018-07-13  3:33       ` Kees Cook
2018-07-13  3:44         ` Herbert Xu
2018-07-13  5:17           ` Kees Cook
2018-07-13  5:20             ` Herbert Xu
2018-07-13  6:00               ` Kees Cook
2018-07-13 10:14                 ` Arnd Bergmann
2018-07-15  4:28                   ` Kees Cook
2018-07-17 20:59                     ` Arnd Bergmann
2018-07-18 14:50                       ` Ard Biesheuvel
2018-07-18 15:19                         ` Ard Biesheuvel
2018-07-18 15:33                           ` Arnd Bergmann
2018-07-18 15:33                             ` Ard Biesheuvel [this message]
2018-07-19  2:51                           ` Kees Cook
2018-07-19  2:55                             ` Ard Biesheuvel
2018-07-19  3:09                               ` Kees Cook
2018-07-19  3:13                                 ` Ard Biesheuvel
2018-07-19 14:54                                   ` Ard Biesheuvel
2018-07-19 18:44                                     ` Kees Cook
2018-07-13  6:16       ` Kees Cook
2018-07-13  6:22         ` Herbert Xu
2018-07-14  3:07           ` Kees Cook
2018-07-15  2:44             ` Herbert Xu
2018-07-15  2:59               ` Kees Cook
2018-07-16  0:01                 ` Herbert Xu
2018-07-16  3:39                   ` Kees Cook
2018-07-16  7:24                     ` Arnd Bergmann
2018-07-11 20:36 ` [PATCH v4 12/14] crypto: ahash: Remove " Kees Cook
2018-07-11 20:36 ` [PATCH v4 13/14] rxrpc: Prepare to remove VLA usage for SKCIPHER_REQUEST_ON_STACK Kees Cook
2018-07-12 15:11   ` Arnd Bergmann
2018-07-12 20:23     ` Kees Cook
2018-07-12 20:30       ` Kees Cook
2018-07-12 21:15         ` Arnd Bergmann
2018-07-12 21:38           ` Kees Cook
2018-07-12 21:28   ` David Howells
2018-07-12 21:34     ` Kees Cook
2018-07-12 22:05   ` David Howells
2018-07-11 20:36 ` [PATCH v4 14/14] crypto: skcipher: Remove " Kees Cook

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='CAKv+Gu-NBKxzV5PYAuzeP5xXfsk=Kw41677ASzRkD6=xO23zeQ@mail.gmail.com' \
    --to=ard.biesheuvel@linaro.org \
    --cc=agk@redhat.com \
    --cc=arnd@arndb.de \
    --cc=davem@davemloft.net \
    --cc=dm-devel@redhat.com \
    --cc=ebiggers@google.com \
    --cc=giovanni.cabiddu@intel.com \
    --cc=gustavo@embeddedor.com \
    --cc=herbert@gondor.apana.org.au \
    --cc=keescook@chromium.org \
    --cc=larper@axis.com \
    --cc=linux-crypto@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=qat-linux@intel.com \
    --cc=rabinv@axis.com \
    --cc=snitzer@redhat.com \
    --cc=tim.c.chen@linux.intel.com \
    --cc=yamada.masahiro@socionext.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).