From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1753032AbdKXERx (ORCPT ); Thu, 23 Nov 2017 23:17:53 -0500 Received: from mail.kernel.org ([198.145.29.99]:41866 "EHLO mail.kernel.org" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1751859AbdKXERw (ORCPT ); Thu, 23 Nov 2017 23:17:52 -0500 DMARC-Filter: OpenDMARC Filter v1.3.2 mail.kernel.org DA41F2199F Authentication-Results: mail.kernel.org; dmarc=none (p=none dis=none) header.from=kernel.org Authentication-Results: mail.kernel.org; spf=none smtp.mailfrom=luto@kernel.org X-Google-Smtp-Source: AGs4zMaylYfMA+YY6YzusCQrv6OMeD11GCxM5ckoMFCXbsXmm9GcwWuJebwt5T4nKG2f8IJK6aaDtUvIIAtD+v18ows= MIME-Version: 1.0 In-Reply-To: References: <07895bbccbff01d5c6ba3b1a5bf48fab34b92eae.1511325444.git.luto@kernel.org> <20171123195555.ct72tiphayavkffq@pd.tnic> <20171123203758.j2tazdpstvhhmpmd@pd.tnic> From: Andy Lutomirski Date: Thu, 23 Nov 2017 20:17:30 -0800 X-Gmail-Original-Message-ID: Message-ID: Subject: Re: [PATCH v2 10/18] x86/asm: Remap the TSS into the cpu entry area To: Andy Lutomirski Cc: Borislav Petkov , X86 ML , "linux-kernel@vger.kernel.org" , Brian Gerst , Dave Hansen , Linus Torvalds , Josh Poimboeuf Content-Type: text/plain; charset="UTF-8" Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, Nov 23, 2017 at 6:40 PM, Andy Lutomirski wrote: > On Thu, Nov 23, 2017 at 12:37 PM, Borislav Petkov wrote: >> On Thu, Nov 23, 2017 at 12:15:14PM -0800, Andy Lutomirski wrote: >>> >> diff --git a/arch/x86/kernel/asm-offsets.c b/arch/x86/kernel/asm-offsets.c >>> >> index b275863128eb..55858b277cf6 100644 >>> >> --- a/arch/x86/kernel/asm-offsets.c >>> >> +++ b/arch/x86/kernel/asm-offsets.c >>> >> @@ -98,4 +98,7 @@ void common(void) { >>> >> OFFSET(CPU_TSS_SYSENTER_stack, tss_struct, SYSENTER_stack); >>> >> /* Size of SYSENTER_stack */ >>> >> DEFINE(SIZEOF_SYSENTER_stack, sizeof(((struct tss_struct *)0)->SYSENTER_stack)); >>> >> + >>> >> + /* Layout info for cpu_entry_area */ >>> >> + OFFSET(CPU_ENTRY_AREA_tss, cpu_entry_area, tss); >>> > >>> > The naming convention of those looks really strange. The beginning is in >>> > all caps and then small. Can we choose a convention pls. >>> >>> This is actually consistent with the rest of the offsets. The >>> convention is STRUCT_field. >> >> Except CPU_TSS_SYSENTER_stack. TSS_STRUCT_SYSENTER_stack I guess. > > Hmm, that name predates this series. I'll clean it up in a new patch > at the end of the series. I'm also going to leave the end-of-line comment alone for now. We can maybe make that change to a bunch of comments later on.