From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1760031AbcCDQac (ORCPT ); Fri, 4 Mar 2016 11:30:32 -0500 Received: from mail-lb0-f173.google.com ([209.85.217.173]:35726 "EHLO mail-lb0-f173.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1759731AbcCDQa1 convert rfc822-to-8bit (ORCPT ); Fri, 4 Mar 2016 11:30:27 -0500 MIME-Version: 1.0 In-Reply-To: References: <00e9fa7d4adeac2d37a42cf613837e74850d929a.1456504662.git.glider@google.com> <56D471F5.3010202@gmail.com> <56D58398.2010708@gmail.com> Date: Fri, 4 Mar 2016 19:30:24 +0300 Message-ID: Subject: Re: [PATCH v4 5/7] mm, kasan: Stackdepot implementation. Enable stackdepot for SLAB From: Andrey Ryabinin To: Alexander Potapenko Cc: Dmitry Vyukov , Andrey Konovalov , Christoph Lameter , Andrew Morton , Steven Rostedt , Joonsoo Kim , JoonSoo Kim , Kostya Serebryany , kasan-dev , LKML , "linux-mm@kvack.org" Content-Type: text/plain; charset=UTF-8 Content-Transfer-Encoding: 8BIT Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org 2016-03-04 18:06 GMT+03:00 Alexander Potapenko : > On Fri, Mar 4, 2016 at 4:01 PM, Andrey Ryabinin wrote: >> 2016-03-04 17:52 GMT+03:00 Alexander Potapenko : >>> On Tue, Mar 1, 2016 at 12:57 PM, Andrey Ryabinin wrote: >>>>>>> + >>>>>>> + stack->hash = hash; >>>>>>> + stack->size = size; >>>>>>> + stack->handle.slabindex = depot_index; >>>>>>> + stack->handle.offset = depot_offset >> STACK_ALLOC_ALIGN; >>>>>>> + __memcpy(stack->entries, entries, size * sizeof(unsigned long)); >>>>>> >>>>>> s/__memcpy/memcpy/ >>>>> >>>>> memcpy should be instrumented by asan/tsan, and we would like to avoid >>>>> that instrumentation here. >>>> >>>> KASAN_SANITIZE_* := n already takes care about this. >>>> __memcpy() is a special thing solely for kasan internals and some assembly code. >>>> And it's not available generally. >>> As far as I can see, KASAN_SANITIZE_*:=n does not guarantee it. >>> It just removes KASAN flags from GCC command line, it does not >>> necessarily replace memcpy() calls with some kind of a >>> non-instrumented memcpy(). >>> >> >> With removed kasan cflags '__SANITIZE_ADDRESS__' is not defined, >> hence enable the following defines from arch/x86/include/asm/string_64.h: >> >> #if defined(CONFIG_KASAN) && !defined(__SANITIZE_ADDRESS__) >> >> /* >> * For files that not instrumented (e.g. mm/slub.c) we >> * should use not instrumented version of mem* functions. >> */ >> >> #undef memcpy >> #define memcpy(dst, src, len) __memcpy(dst, src, len) >> #define memmove(dst, src, len) __memmove(dst, src, len) >> #define memset(s, c, n) __memset(s, c, n) >> #endif > Nice! > What do you think about providing stub .c files to decouple the shared > code used by KASAN runtime from the rest of kernel? Actually, I'm not quite understand why you need that at all, but your idea will not link due to multiple definitions of the same functions. Link problem should be easy to workaround with 'objcopy --prefix-symbol=' though. > (This is a completely different story though and can be done separately). > > > -- > Alexander Potapenko > Software Engineer > > Google Germany GmbH > Erika-Mann-Straße, 33 > 80636 München > > Geschäftsführer: Matthew Scott Sucherman, Paul Terence Manicle > Registergericht und -nummer: Hamburg, HRB 86891 > Sitz der Gesellschaft: Hamburg