From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751940AbaIYIOA (ORCPT ); Thu, 25 Sep 2014 04:14:00 -0400 Received: from mail-qc0-f181.google.com ([209.85.216.181]:39386 "EHLO mail-qc0-f181.google.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750984AbaIYIN4 (ORCPT ); Thu, 25 Sep 2014 04:13:56 -0400 MIME-Version: 1.0 In-Reply-To: <1411575342-31048-2-git-send-email-vinod.koul@intel.com> References: <1411575342-31048-1-git-send-email-vinod.koul@intel.com> <1411575342-31048-2-git-send-email-vinod.koul@intel.com> Date: Thu, 25 Sep 2014 10:13:55 +0200 Message-ID: Subject: Re: [PATCH 01/27] PM: Add helper pm_runtime_last_busy_and_autosuspend() From: Ulf Hansson To: Vinod Koul Cc: "linux-kernel@vger.kernel.org" , subhransu.s.prusty@intel.com, "Rafael J. Wysocki" , Len Brown , Pavel Machek , Randy Dunlap , Alan Stern , "linux-pm@vger.kernel.org" , "linux-doc@vger.kernel.org" Content-Type: text/plain; charset=UTF-8 Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On 24 September 2014 18:14, Vinod Koul wrote: > From: Subhransu S. Prusty > > pm_runtime_mark_last_busy and pm_runtime_put_autosuspend are used together > in quite a lot of places. Add a helper for these. > Also updated Documentation for this > > Signed-off-by: Subhransu S. Prusty > Signed-off-by: Vinod Koul > --- > Documentation/power/runtime_pm.txt | 4 ++++ > include/linux/pm_runtime.h | 6 ++++++ > 2 files changed, 10 insertions(+), 0 deletions(-) > > diff --git a/Documentation/power/runtime_pm.txt b/Documentation/power/runtime_pm.txt > index f32ce54..5d9565b 100644 > --- a/Documentation/power/runtime_pm.txt > +++ b/Documentation/power/runtime_pm.txt > @@ -490,6 +490,10 @@ drivers/base/power/runtime.c and include/linux/pm_runtime.h: > power.use_autosuspend isn't set, otherwise returns the expiration time > in jiffies > > + int pm_runtime_last_busy_and_autosuspend(struct device *dev); > + - invoke pm_runtime_mark_last_busy(dev) and then run > + pm_runtime_put_autosuspend(dev) and return its result > + > It is safe to execute the following helper functions from interrupt context: > > pm_request_idle() > diff --git a/include/linux/pm_runtime.h b/include/linux/pm_runtime.h > index 367f49b..256ec50 100644 > --- a/include/linux/pm_runtime.h > +++ b/include/linux/pm_runtime.h > @@ -277,4 +277,10 @@ static inline void pm_runtime_dont_use_autosuspend(struct device *dev) > __pm_runtime_use_autosuspend(dev, false); > } > > +static inline int pm_runtime_last_busy_and_autosuspend(struct device *dev) This doesn't help code readability I think. The function name is quite long as Pavel also pointed out. :-) And, I also lack the "put" prefix, following the other functions in the runtime PM API - which would make the name even longer. :-) Kind regards Uffe