From: Ulf Hansson <firstname.lastname@example.org> To: Ezequiel Garcia <email@example.com> Cc: Zhou Yanjie <firstname.lastname@example.org>, Paul Cercueil <email@example.com>, firstname.lastname@example.org, Linux Kernel Mailing List <email@example.com>, "firstname.lastname@example.org" <email@example.com>, DTML <firstname.lastname@example.org>, Rob Herring <email@example.com>, Paul Burton <firstname.lastname@example.org>, Mark Rutland <email@example.com>, firstname.lastname@example.org, Linus Walleij <email@example.com>, firstname.lastname@example.org, Thomas Gleixner <email@example.com>, YueHaibing <firstname.lastname@example.org>, Mathieu Malaterre <email@example.com> Subject: Re: [PATCH 6/6 v2] MMC: JZ4740: Add support for LPM. Date: Mon, 21 Oct 2019 16:57:26 +0200 [thread overview] Message-ID: <CAPDyKFqzT5Gf1R_26Hzyt-_xEshk4k-EW3yUSKw1MVi7ayh3QA@mail.gmail.com> (raw) In-Reply-To: <47f6-5dab7580-33-5680128@176712317> On Sat, 19 Oct 2019 at 22:44, Ezequiel Garcia <firstname.lastname@example.org> wrote: > > On Friday, October 18, 2019 13:54 -03, Zhou Yanjie <email@example.com> wrote: > > > > > > > > > > I also have a general question. Should we perhaps rename the driver > > > from jz4740_mmc.c to ingenic.c (and the file for the DT bindings, the > > > Kconfig, etc), as that seems like a more appropriate name? No? > > > > I am very much in favor of this proposal. Now jz4740_mmc.c is not only used > > for the JZ4740 processor, it is also used for JZ4725, JZ4760, JZ4770, JZ4780 > > and X1000, and now Ingenic's processor is no longer named after JZ47xx, > > it is divided into three product lines: M, T, and X. It is easy to cause > > some > > misunderstandings by using jz4740_mmc.c. At the same time, I think that > > some register names also need to be adjusted. For example, the STLPPL > > register name has only appeared in JZ4730 and JZ4740, and this register > > in all subsequent processors is called CTRL. This time I was confused by > > the STLPPL when I added drivers for the JZ4760's and X1000's LPM. > > > > I am very much against renamings, for several reasons. As Paul already mentioned, it's pointless and just adds noise to the git-log, making history harder to recover. Driver file names don't really have to reflect the device > > exactly. For the compatibility list, it's far easier to just git-grep for compatible strings, or git-grep Documentation and/or Kconfig. I have no strong opinions. What matters to me, is that people agree on the best option, based on a case by case discussion. > > Renaming macros and register names, is equally pointless and equally git-history invasive. Simply adding some documentation is enough. Sounds like documentation is what people prefer here - and the DT doc seems already fine in regards to that. Perhaps some more words added to the header in driver's c-file could be and option to consider, as today it only mentions "JZ4740 SD/MMC controller driver". Anyway, it's up to you. :-) Kind regards Uffe
prev parent reply other threads:[~2019-10-21 14:58 UTC|newest] Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top 2019-09-05 7:38 MMC: Ingenic: Add support for 8bit mode and LPM and JZ4760 Soc Zhou Yanjie 2019-09-05 7:38 ` [PATCH 1/4] MMC: Ingenic: Adjust the macro definition name Zhou Yanjie 2019-09-13 15:32 ` Ezequiel Garcia 2019-09-13 15:59 ` Zhou Yanjie 2019-09-05 7:38 ` [PATCH 2/4] MMC: Ingenic: Add 8bit mode support Zhou Yanjie 2019-09-05 7:38 ` [PATCH 3/4] dt-bindings: MMC: Add JZ4760 bindings Zhou Yanjie 2019-09-13 14:36 ` Rob Herring 2019-09-05 7:38 ` [PATCH 4/4] MMC: Ingenic: Add support for JZ4760 and support for LPM Zhou Yanjie 2019-10-03 10:00 ` Ulf Hansson 2019-10-06 5:58 ` Zhou Yanjie 2019-10-12 5:13 ` MMC: JZ4740: Add support for 8bit mode and LPM and JZ4760 Soc v2 Zhou Yanjie 2019-10-12 5:13 ` [PATCH 1/6 v2] MMC: Ingenic: Add 8bit mode support Zhou Yanjie 2019-10-12 5:13 ` [PATCH 2/6 v2] dt-bindings: MMC: Add JZ4760 bindings Zhou Yanjie 2019-10-12 5:13 ` [PATCH 3/6 v2] MMC: JZ4740: Add support for the JZ4760 Zhou Yanjie 2019-10-12 5:13 ` [PATCH 4/6 v2] dt-bindings: MMC: Add X1000 bindings Zhou Yanjie 2019-10-14 18:15 ` Rob Herring 2019-10-12 5:13 ` [PATCH 5/6 v2] MMC: JZ4740: Add support for the X1000 Zhou Yanjie 2019-10-12 5:13 ` [PATCH 6/6 v2] MMC: JZ4740: Add support for LPM Zhou Yanjie 2019-10-18 8:52 ` Ulf Hansson 2019-10-18 15:37 ` Paul Cercueil 2019-10-18 16:54 ` Zhou Yanjie 2019-10-19 20:44 ` Ezequiel Garcia 2019-10-21 14:57 ` Ulf Hansson [this message]
Reply instructions: You may reply publicly to this message via plain-text email using any one of the following methods: * Save the following mbox file, import it into your mail client, and reply-to-all from there: mbox Avoid top-posting and favor interleaved quoting: https://en.wikipedia.org/wiki/Posting_style#Interleaved_style * Reply using the --to, --cc, and --in-reply-to switches of git-send-email(1): git send-email \ --in-reply-to=CAPDyKFqzT5Gf1R_26Hzyt-_xEshk4k-EW3yUSKw1MVi7ayh3QA@mail.gmail.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --email@example.com \ --firstname.lastname@example.org \ --subject='Re: [PATCH 6/6 v2] MMC: JZ4740: Add support for LPM.' \ /path/to/YOUR_REPLY https://kernel.org/pub/software/scm/git/docs/git-send-email.html * If your mail client supports setting the In-Reply-To header via mailto: links, try the mailto: link
This is a public inbox, see mirroring instructions for how to clone and mirror all data and code used for this inbox; as well as URLs for NNTP newsgroup(s).