linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Pallala, Ramakrishna" <ramakrishna.pallala@intel.com>
To: Lee Jones <lee.jones@linaro.org>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	"MyungJoo Ham" <myungjoo.ham@samsung.com>,
	Chanwoo Choi <cw00.choi@samsung.com>,
	"Samuel Ortiz" <sameo@linux.intel.com>,
	Carlo Caione <carlo@caione.org>,
	Jacob Pan <jacob.jun.pan@linux.intel.com>
Subject: RE: [PATCH 1/2] mfd/axp20x: add support for extcon cell
Date: Wed, 1 Apr 2015 16:33:38 +0000	[thread overview]
Message-ID: <D854C92F57B1B347B57E531E78D05EAD5780A585@BGSMSX104.gar.corp.intel.com> (raw)
In-Reply-To: <20150401114125.GU9447@x1>

[-- Warning: decoded text below may be mangled, UTF-8 assumed --]
[-- Attachment #1: Type: text/plain; charset="utf-8", Size: 2574 bytes --]

> On Thu, 02 Apr 2015, Ramakrishna Pallala wrote:
> 
> > This patch adds the mfd cell info for axp288 extcon device.
> >
> > Signed-off-by: Ramakrishna Pallala <ramakrishna.pallala@intel.com>
> > ---
> >  drivers/mfd/axp20x.c       |   28 ++++++++++++++++++++++++++++
> >  include/linux/mfd/axp20x.h |    5 +++++
> >  2 files changed, 33 insertions(+)
> >
> > diff --git a/drivers/mfd/axp20x.c b/drivers/mfd/axp20x.c index
> > 0acbe52..30af1a3 100644
> > --- a/drivers/mfd/axp20x.c
> > +++ b/drivers/mfd/axp20x.c
> > @@ -290,6 +290,29 @@ static struct resource axp288_adc_resources[] = {
> >  	},
> >  };
> >
> > +static struct resource axp288_extcon_resources[] = {
> > +	{
> > +		.start = AXP288_IRQ_VBUS_FALL,
> > +		.end   = AXP288_IRQ_VBUS_FALL,
> > +		.flags = IORESOURCE_IRQ,
> > +	},
> > +	{
> > +		.start = AXP288_IRQ_VBUS_RISE,
> > +		.end   = AXP288_IRQ_VBUS_RISE,
> > +		.flags = IORESOURCE_IRQ,
> > +	},
> > +	{
> > +		.start = AXP288_IRQ_MV_CHNG,
> > +		.end   = AXP288_IRQ_MV_CHNG,
> > +		.flags = IORESOURCE_IRQ,
> > +	},
> > +	{
> > +		.start = AXP288_IRQ_BC_USB_CHNG,
> > +		.end   = AXP288_IRQ_BC_USB_CHNG,
> > +		.flags = IORESOURCE_IRQ,
> > +	},
> > +};
> > +
> >  static struct resource axp288_charger_resources[] = {
> >  	{
> >  		.start = AXP288_IRQ_OV,
> > @@ -345,6 +368,11 @@ static struct mfd_cell axp288_cells[] = {
> >  		.resources = axp288_adc_resources,
> >  	},
> >  	{
> > +		.name = "extcon-axp288",
> 
> This naming convention is not consistent with the others in the container.
Ok agreed. I will fix it.


> > +		.num_resources = ARRAY_SIZE(axp288_extcon_resources),
> > +		.resources = axp288_extcon_resources,
> > +	},
> > +	{
> >  		.name = "axp288_charger",
> >  		.num_resources = ARRAY_SIZE(axp288_charger_resources),
> >  		.resources = axp288_charger_resources, diff --git
> > a/include/linux/mfd/axp20x.h b/include/linux/mfd/axp20x.h index
> > dfabd6d..4ed8071 100644
> > --- a/include/linux/mfd/axp20x.h
> > +++ b/include/linux/mfd/axp20x.h
> > @@ -275,4 +275,9 @@ struct axp20x_fg_pdata {
> >  	int thermistor_curve[MAX_THERM_CURVE_SIZE][2];
> >  };
> >
> > +struct axp288_extcon_pdata {
> > +	/* GPIO pin control to switch D+/D- lines b/w PMIC and SOC */
> > +	struct gpio_desc *gpio_mux_cntl;
> > +};
> 
> Is this going to be added to?  Seems like overkill to have a struct with only one
> attribute.
Yes, I will be adding to this struct in future.

Thanks,
Ram
ÿôèº{.nÇ+‰·Ÿ®‰­†+%ŠËÿ±éݶ\x17¥Šwÿº{.nÇ+‰·¥Š{±þG«éÿŠ{ayº\x1dʇڙë,j\a­¢f£¢·hšïêÿ‘êçz_è®\x03(­éšŽŠÝ¢j"ú\x1a¶^[m§ÿÿ¾\a«þG«éÿ¢¸?™¨è­Ú&£ø§~á¶iO•æ¬z·švØ^\x14\x04\x1a¶^[m§ÿÿÃ\fÿ¶ìÿ¢¸?–I¥

  reply	other threads:[~2015-04-01 16:33 UTC|newest]

Thread overview: 5+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2015-04-01 18:43 [PATCH 0/2] Add extcon support for AXP288 PMIC Ramakrishna Pallala
2015-04-01 18:43 ` [PATCH 1/2] mfd/axp20x: add support for extcon cell Ramakrishna Pallala
2015-04-01 11:41   ` Lee Jones
2015-04-01 16:33     ` Pallala, Ramakrishna [this message]
2015-04-01 18:43 ` [PATCH 2/2] extcon-axp288: Add axp288 extcon driver support Ramakrishna Pallala

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=D854C92F57B1B347B57E531E78D05EAD5780A585@BGSMSX104.gar.corp.intel.com \
    --to=ramakrishna.pallala@intel.com \
    --cc=carlo@caione.org \
    --cc=cw00.choi@samsung.com \
    --cc=jacob.jun.pan@linux.intel.com \
    --cc=lee.jones@linaro.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=myungjoo.ham@samsung.com \
    --cc=sameo@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).