linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Miklos Szeredi <miklos@szeredi.hu>
To: Michael.Waychison@Sun.COM
Cc: akpm@osdl.org, torvalds@osdl.org, linux-fsdevel@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 2/11] FUSE - core
Date: Mon, 10 Jan 2005 23:28:59 +0100	[thread overview]
Message-ID: <E1Co81z-0004ef-00@dorka.pomaz.szeredi.hu> (raw)
In-Reply-To: <41E2F654.5090707@sun.com> (message from Mike Waychison on Mon, 10 Jan 2005 16:40:36 -0500)

> > + *
> > + *  - the private_data field of the device file
> > + *  - the s_fs_info field of the super block
> > + *  - unused_list, pending, processing lists in fuse_conn
> > + *  - the unique request ID counter reqctr in fuse_conn
> > + *  - the sb (super_block) field in fuse_conn
> > + *  - the file (device file) field in fuse_conn
> > + */
> 
> These comments seem out of date.  There is no unused_lsit, pending or
> processing lists in fuse_conn.  Nor is there a reqctr or file.
> 

[...]

> > +		return NULL;
> > +	spin_lock(&fuse_lock);
> > +	fc->sb = sb;
> > +	spin_unlock(&fuse_lock);
> 
> The lock here looks unnessary, fc is private to this function at this point.

Yes, well these are caused by the split.  Later patches will explain
these.  I could split up the comment too...

> > +static int fuse_read_super(struct super_block *sb, void *data, int silent)
> 
> Can you rename this to fuse_fill_super so its consistent with what the
> VFS calls it?

Yes.

> > +		fuse_inode_cachep = kmem_cache_create("fuse_inode",
> > +						      sizeof(struct inode) + sizeof(struct fuse_inode) ,
> 
> I'm not convinced this will get the right alignments in the case where
> struct inode ever changes size.  You're better off using a new struct
> that contains both and using the size of it here, as well as using it
> for calculating the offset in get_fuse_inode instead of &inode[1].

Good point. I haven't thought of this.

> > +int __init fuse_init(void)
> 
> static?

OK.

> > +{
> > +	printk(KERN_DEBUG "fuse exit\n");
> > +
> > +	fuse_fs_cleanup();
> > +}
> 
> Why not just do the cleanup here?  If you still want to keep fuse_exit
> seperate from fuse_fs_cleanup, may I suggest marking the former __exit?

Again, later patches explain this.

> > +/** Version number of this interface */
> > +#define FUSE_KERNEL_VERSION 5
> > +
> > +/** Minor version number of this interface */
> > +#define FUSE_KERNEL_MINOR_VERSION 1
> 
> I haven't yet looked at the other patches, but is this VERSION info
> negotiated with userspace?

Yes.

Thanks for the comments!

Miklos

  reply	other threads:[~2005-01-10 22:42 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2005-01-10 18:58 [PATCH 2/11] FUSE - core Miklos Szeredi
2005-01-10 21:40 ` Mike Waychison
2005-01-10 22:28   ` Miklos Szeredi [this message]
2005-02-14 22:43 ` Faraz Ahmed
2005-01-11 16:25 Miklos Szeredi
2005-01-12 22:36 ` Andrew Morton
2005-01-13  5:31   ` Miklos Szeredi
2005-01-14 13:55 ` Anton Altaparmakov
2005-01-14 14:07   ` Miklos Szeredi
2005-01-14 14:14     ` Anton Altaparmakov
2005-01-14 14:32       ` Miklos Szeredi

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=E1Co81z-0004ef-00@dorka.pomaz.szeredi.hu \
    --to=miklos@szeredi.hu \
    --cc=Michael.Waychison@Sun.COM \
    --cc=akpm@osdl.org \
    --cc=linux-fsdevel@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=torvalds@osdl.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).