linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: "Grover, Andrew" <andrew.grover@intel.com>
To: daveman@bellatlantic.net, linux-kernel@vger.kernel.org
Subject: RE: Missing keypress when ACPI enabled
Date: Thu, 6 Mar 2003 09:24:34 -0800	[thread overview]
Message-ID: <F760B14C9561B941B89469F59BA3A847E96CCB@orsmsx401.jf.intel.com> (raw)

> From: daveman@bellatlantic.net [mailto:daveman@bellatlantic.net] 
> Since about 2.5.60, the first 2.5 kernel that has 
> built/booted for me, I've noticed X/Kscreensaver fails to 
> capture a keystroke after about 20 minutes of inactivity, in 
> the password login prompt. It is only the first keypress that 
> is lost, all later keypresses work fine. I believe I've 
> narrowed it down to an interaction with having ACPI enabled, 
> as booting the kernel with 'acpi=off' seems to make the 
> problem go away. I've attached dmesg and .config output. 
> Please let me know if I can assist further.

Aha, you have an IBM A20 (or similar). You are not the first one to
report this, and indeed this happens on my T20, even under Windows.
Given that, I would suspect this is a side effect of some unknown IBM
BIOS enhancement, so I don't know what we can do without IBM telling us
more about what's going on.

Regards -- Andy

             reply	other threads:[~2003-03-06 17:14 UTC|newest]

Thread overview: 3+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2003-03-06 17:24 Grover, Andrew [this message]
  -- strict thread matches above, loose matches on Subject: below --
2003-03-06 16:48 daveman
2003-03-06 21:41 ` Pavel Machek

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=F760B14C9561B941B89469F59BA3A847E96CCB@orsmsx401.jf.intel.com \
    --to=andrew.grover@intel.com \
    --cc=daveman@bellatlantic.net \
    --cc=linux-kernel@vger.kernel.org \
    --subject='RE: Missing keypress when ACPI enabled' \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).