linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
* [PATCH][0/4] let's kill verify_area
@ 2005-01-07  1:18 Jesper Juhl
  2005-01-07  1:26 ` Andrew Morton
  0 siblings, 1 reply; 5+ messages in thread
From: Jesper Juhl @ 2005-01-07  1:18 UTC (permalink / raw)
  To: linux-kernel; +Cc: Andrew Morton


verify_area() if just a wrapper for access_ok() (or similar function or 
dummy function) for all arch's. I say it's time we just get rid of it as 
it no longer serves any purpose and it's easy to convert to access_ok. 
Converting all users may take some time, so initially deprecate it (which 
will get the janitors attention as well as maintainers and ordinary users) 
and then when all users of the function are converted we can kill it and 
all comments related to it.

The following patches deprecate the function for all arch's and then do a 
few initial conversions just to get things moving.

Comments are welcome.


-- 
Jesper Juhl

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH][0/4] let's kill verify_area
  2005-01-07  1:18 [PATCH][0/4] let's kill verify_area Jesper Juhl
@ 2005-01-07  1:26 ` Andrew Morton
  2005-01-07  1:49   ` Jesper Juhl
  0 siblings, 1 reply; 5+ messages in thread
From: Andrew Morton @ 2005-01-07  1:26 UTC (permalink / raw)
  To: Jesper Juhl; +Cc: linux-kernel

Jesper Juhl <juhl-lkml@dif.dk> wrote:
>
> verify_area() if just a wrapper for access_ok() (or similar function or 
> dummy function) for all arch's.

This sounds more like "let's kill Andrew".  I count 489 instances in the
tree.  Please don't expect this activity to take top priority ;)

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH][0/4] let's kill verify_area
  2005-01-07  1:26 ` Andrew Morton
@ 2005-01-07  1:49   ` Jesper Juhl
  2005-01-07  1:56     ` Andrew Morton
  0 siblings, 1 reply; 5+ messages in thread
From: Jesper Juhl @ 2005-01-07  1:49 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Jesper Juhl, linux-kernel

On Thu, 6 Jan 2005, Andrew Morton wrote:

> Jesper Juhl <juhl-lkml@dif.dk> wrote:
> >
> > verify_area() if just a wrapper for access_ok() (or similar function or 
> > dummy function) for all arch's.
> 
> This sounds more like "let's kill Andrew".  I count 489 instances in the
> tree.  Please don't expect this activity to take top priority ;)
> 
Heh, right, there's an aspect I hadn't really considered.
I'm not expecting top priority, not at all. This is nowhere near being 
anything important, just something that should happen eventually - so I 
thought, why not just deprecate it now and let it be cleaned up over time 
(and I'll do my share, don't worry :)

Accept the patch if you think it makes sense, drop it if you think it does 
not (or should wait). 


-- 
Jesper Juhl



^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH][0/4] let's kill verify_area
  2005-01-07  1:49   ` Jesper Juhl
@ 2005-01-07  1:56     ` Andrew Morton
  2005-01-09  1:20       ` Jesper Juhl
  0 siblings, 1 reply; 5+ messages in thread
From: Andrew Morton @ 2005-01-07  1:56 UTC (permalink / raw)
  To: Jesper Juhl; +Cc: juhl-lkml, linux-kernel

Jesper Juhl <juhl-lkml@dif.dk> wrote:
>
> On Thu, 6 Jan 2005, Andrew Morton wrote:
> 
> > Jesper Juhl <juhl-lkml@dif.dk> wrote:
> > >
> > > verify_area() if just a wrapper for access_ok() (or similar function or 
> > > dummy function) for all arch's.
> > 
> > This sounds more like "let's kill Andrew".  I count 489 instances in the
> > tree.  Please don't expect this activity to take top priority ;)
> > 
> Heh, right, there's an aspect I hadn't really considered.
> I'm not expecting top priority, not at all. This is nowhere near being 
> anything important, just something that should happen eventually - so I 
> thought, why not just deprecate it now and let it be cleaned up over time 
> (and I'll do my share, don't worry :)
> 
> Accept the patch if you think it makes sense, drop it if you think it does 
> not (or should wait). 

The way to do this is to fix up the callers first, in just ten or so
patches.  Then mark the function deprecated when most of the conversion is
done.

If we deprecate the functions first then 10000 people send small fixes via
various snaky routes and it's really hard to coordinate the overlapping
fixes.  The s/MODULE_PARM/module_param/ stuff did that, because we made it
warn first, then I held the big sweep patch off for 2.6.11.

^ permalink raw reply	[flat|nested] 5+ messages in thread

* Re: [PATCH][0/4] let's kill verify_area
  2005-01-07  1:56     ` Andrew Morton
@ 2005-01-09  1:20       ` Jesper Juhl
  0 siblings, 0 replies; 5+ messages in thread
From: Jesper Juhl @ 2005-01-09  1:20 UTC (permalink / raw)
  To: Andrew Morton; +Cc: Jesper Juhl, linux-kernel

On Thu, 6 Jan 2005, Andrew Morton wrote:

> Jesper Juhl <juhl-lkml@dif.dk> wrote:
> >
> > On Thu, 6 Jan 2005, Andrew Morton wrote:
> > 
> > > Jesper Juhl <juhl-lkml@dif.dk> wrote:
> > > >
> > > > verify_area() if just a wrapper for access_ok() (or similar function or 
> > > > dummy function) for all arch's.
> > > 
> > > This sounds more like "let's kill Andrew".  I count 489 instances in the
> > > tree.  Please don't expect this activity to take top priority ;)
> > > 
> > Heh, right, there's an aspect I hadn't really considered.
> > I'm not expecting top priority, not at all. This is nowhere near being 
> > anything important, just something that should happen eventually - so I 
> > thought, why not just deprecate it now and let it be cleaned up over time 
> > (and I'll do my share, don't worry :)
> > 
> > Accept the patch if you think it makes sense, drop it if you think it does 
> > not (or should wait). 
> 
> The way to do this is to fix up the callers first, in just ten or so
> patches.  Then mark the function deprecated when most of the conversion is
> done.
> 
> If we deprecate the functions first then 10000 people send small fixes via
> various snaky routes and it's really hard to coordinate the overlapping
> fixes.  The s/MODULE_PARM/module_param/ stuff did that, because we made it
> warn first, then I held the big sweep patch off for 2.6.11.
> 

Ok, that makes sense.

Here's my plan then:

I'll get to work on converting roughly one tenth og the verify_area 
occourances and then post a patch for that for review. If it turns out to 
be OK I'll get to work on the rest and do as many as I can and at that 
point (assuming those patches are also OK) I'll re-submit a patch to 
deprecate the function so the remaining instances can get cleaned up and 
the function removed.
This will probably take me a few days to do since A) it seems I didn't 
even get my initial conversions correct so I'll need to be more careful, 
and B) I have limited time.  But, I'll start doing the initial 1/10'th 
patch now and hopefully post that to lkml within a few days.

Thank you for your feedback.


-- 
Jesper Juhl



^ permalink raw reply	[flat|nested] 5+ messages in thread

end of thread, other threads:[~2005-01-09  1:09 UTC | newest]

Thread overview: 5+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2005-01-07  1:18 [PATCH][0/4] let's kill verify_area Jesper Juhl
2005-01-07  1:26 ` Andrew Morton
2005-01-07  1:49   ` Jesper Juhl
2005-01-07  1:56     ` Andrew Morton
2005-01-09  1:20       ` Jesper Juhl

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).