linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Bough Chen <haibo.chen@nxp.com>
To: Lee Jones <lee.jones@linaro.org>
Cc: "linux-kernel@vger.kernel.org" <linux-kernel@vger.kernel.org>,
	Dmitry Torokhov <dmitry.torokhov@gmail.com>,
	Shawn Guo <shawnguo@kernel.org>,
	Sascha Hauer <s.hauer@pengutronix.de>,
	Pengutronix Kernel Team <kernel@pengutronix.de>,
	Fabio Estevam <festevam@gmail.com>,
	dl-linux-imx <linux-imx@nxp.com>,
	Haibo Chen <haibo.chen@freescale.com>,
	"linux-input@vger.kernel.org" <linux-input@vger.kernel.org>
Subject: RE: [PATCH 05/15] input: touchscreen: imx6ul_tsc: Remove set but unused variable 'value'
Date: Thu, 12 Nov 2020 12:20:31 +0000	[thread overview]
Message-ID: <VI1PR04MB529451BA4FB237FA6C811E0790E70@VI1PR04MB5294.eurprd04.prod.outlook.com> (raw)
In-Reply-To: <20201112110204.2083435-6-lee.jones@linaro.org>

> -----Original Message-----
> From: Lee Jones [mailto:lee.jones@linaro.org]
> Sent: 2020年11月12日 19:02
> To: lee.jones@linaro.org
> Cc: linux-kernel@vger.kernel.org; Dmitry Torokhov
> <dmitry.torokhov@gmail.com>; Shawn Guo <shawnguo@kernel.org>; Sascha
> Hauer <s.hauer@pengutronix.de>; Pengutronix Kernel Team
> <kernel@pengutronix.de>; Fabio Estevam <festevam@gmail.com>;
> dl-linux-imx <linux-imx@nxp.com>; Haibo Chen <haibo.chen@freescale.com>;
> linux-input@vger.kernel.org
> Subject: [PATCH 05/15] input: touchscreen: imx6ul_tsc: Remove set but unused
> variable 'value'
> 
> Fixes the following W=1 kernel build warning(s):
> 
>  drivers/input/touchscreen/imx6ul_tsc.c: In function ‘adc_irq_fn’:
>  drivers/input/touchscreen/imx6ul_tsc.c:307:6: warning: variable ‘value’ set
> but not used [-Wunused-but-set-variable]
> 
> Cc: Dmitry Torokhov <dmitry.torokhov@gmail.com>
> Cc: Shawn Guo <shawnguo@kernel.org>
> Cc: Sascha Hauer <s.hauer@pengutronix.de>
> Cc: Pengutronix Kernel Team <kernel@pengutronix.de>
> Cc: Fabio Estevam <festevam@gmail.com>
> Cc: NXP Linux Team <linux-imx@nxp.com>
> Cc: Haibo Chen <haibo.chen@freescale.com>
> Cc: linux-input@vger.kernel.org
> Signed-off-by: Lee Jones <lee.jones@linaro.org>
> ---
>  drivers/input/touchscreen/imx6ul_tsc.c | 3 +--
>  1 file changed, 1 insertion(+), 2 deletions(-)
> 
> diff --git a/drivers/input/touchscreen/imx6ul_tsc.c
> b/drivers/input/touchscreen/imx6ul_tsc.c
> index cd369f9ac5e60..e1852f7d4d31e 100644
> --- a/drivers/input/touchscreen/imx6ul_tsc.c
> +++ b/drivers/input/touchscreen/imx6ul_tsc.c
> @@ -304,11 +304,10 @@ static irqreturn_t adc_irq_fn(int irq, void *dev_id)
> {
>  	struct imx6ul_tsc *tsc = dev_id;
>  	u32 coco;
> -	u32 value;
> 
>  	coco = readl(tsc->adc_regs + REG_ADC_HS);
>  	if (coco & 0x01) {
> -		value = readl(tsc->adc_regs + REG_ADC_R0);
> +		readl(tsc->adc_regs + REG_ADC_R0);
>  		complete(&tsc->completion);
>  	}
> 

Reviewed-by: Haibo Chen <haibo.chen@nxp.com>

> --
> 2.25.1


  reply	other threads:[~2020-11-12 12:20 UTC|newest]

Thread overview: 42+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-11-12 11:01 [PATCH 00/15] [Set 2/2] Rid W=1 issues from Input Lee Jones
2020-11-12 11:01 ` [PATCH 01/15] input: joystick: xpad: Demote non-conformant kernel-doc header Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 02/15] input: keyboard: samsung-keypad: Remove set but unused variable 'var' Lee Jones
2020-11-13  7:37   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 03/15] input: misc: mc13783-pwrbutton: File headers are not good candidates for kernel-doc Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 04/15] input: touchscreen: goodix: Provide some missing function parameter descriptions Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 05/15] input: touchscreen: imx6ul_tsc: Remove set but unused variable 'value' Lee Jones
2020-11-12 12:20   ` Bough Chen [this message]
2020-11-13  7:37   ` Dmitry Torokhov
2020-11-19  9:12     ` Lee Jones
2020-11-12 11:01 ` [PATCH 06/15] input: touchscreen: melfas_mip4: Remove a bunch of unused variables Lee Jones
2020-11-13  7:42   ` Dmitry Torokhov
2020-11-13  7:55     ` Lee Jones
2020-11-20  3:09       ` Dmitry Torokhov
2020-11-20  7:45         ` Lee Jones
2020-11-12 11:01 ` [PATCH 07/15] input: touchscreen: usbtouchscreen: Remove unused variable 'ret' Lee Jones
2020-11-13  7:36   ` Dmitry Torokhov
2020-11-13  7:56     ` Lee Jones
2020-11-20  3:09       ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 08/15] input: touchscreen: surface3_spi: Remove set but unused variable 'timestamp' Lee Jones
2020-11-13  7:40   ` Dmitry Torokhov
2020-11-13  7:42     ` Benjamin Tissoires
2020-11-15 22:02       ` Peter Hutterer
2020-11-12 11:01 ` [PATCH 09/15] input: misc: wm831x-on: Source file headers are not good candidates for kernel-doc Lee Jones
2020-11-12 11:20   ` Richard Fitzgerald
2020-11-20  3:17   ` Dmitry Torokhov
2020-11-12 11:01 ` [PATCH 10/15] input: touchscreen: surface3_spi: Fix naming issue with 'surface3_spi_get_gpio_config's header Lee Jones
2020-11-20  3:16   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 11/15] input: touchscreen: wm97xx-core: Provide missing description for 'status' Lee Jones
2020-11-12 11:22   ` Richard Fitzgerald
2020-11-20  3:17   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 12/15] input: mouse: synaptics: Demote non-conformant kernel-doc header Lee Jones
2020-11-20  3:18   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 13/15] input: touchscreen: goodix: Fix misspelling of 'ctx' Lee Jones
2020-11-20  3:20   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 14/15] input: keyboard: applespi: Provide missing struct 'message' descriptions Lee Jones
2020-11-20  3:21   ` Dmitry Torokhov
2020-11-12 11:02 ` [PATCH 15/15] input: mouse: vmmouse: Demote obvious abuse of kernel-doc header Lee Jones
2020-11-20  3:21   ` Dmitry Torokhov

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=VI1PR04MB529451BA4FB237FA6C811E0790E70@VI1PR04MB5294.eurprd04.prod.outlook.com \
    --to=haibo.chen@nxp.com \
    --cc=dmitry.torokhov@gmail.com \
    --cc=festevam@gmail.com \
    --cc=haibo.chen@freescale.com \
    --cc=kernel@pengutronix.de \
    --cc=lee.jones@linaro.org \
    --cc=linux-imx@nxp.com \
    --cc=linux-input@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=s.hauer@pengutronix.de \
    --cc=shawnguo@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).