From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: X-Spam-Checker-Version: SpamAssassin 3.4.0 (2014-02-07) on aws-us-west-2-korg-lkml-1.web.codeaurora.org X-Spam-Level: X-Spam-Status: No, score=-13.8 required=3.0 tests=BAYES_00, HEADER_FROM_DIFFERENT_DOMAINS,INCLUDES_CR_TRAILER,INCLUDES_PATCH, MAILING_LIST_MULTI,SPF_HELO_NONE,SPF_PASS autolearn=unavailable autolearn_force=no version=3.4.0 Received: from mail.kernel.org (mail.kernel.org [198.145.29.99]) by smtp.lore.kernel.org (Postfix) with ESMTP id 395FEC07E96 for ; Tue, 13 Jul 2021 07:46:44 +0000 (UTC) Received: from vger.kernel.org (vger.kernel.org [23.128.96.18]) by mail.kernel.org (Postfix) with ESMTP id 1CFAF6127C for ; Tue, 13 Jul 2021 07:46:44 +0000 (UTC) Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S234357AbhGMHtb (ORCPT ); Tue, 13 Jul 2021 03:49:31 -0400 Received: from mga18.intel.com ([134.134.136.126]:61484 "EHLO mga18.intel.com" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S234342AbhGMHta (ORCPT ); Tue, 13 Jul 2021 03:49:30 -0400 X-IronPort-AV: E=McAfee;i="6200,9189,10043"; a="197391554" X-IronPort-AV: E=Sophos;i="5.84,236,1620716400"; d="scan'208";a="197391554" Received: from fmsmga001.fm.intel.com ([10.253.24.23]) by orsmga106.jf.intel.com with ESMTP/TLS/ECDHE-RSA-AES256-GCM-SHA384; 13 Jul 2021 00:46:40 -0700 X-ExtLoop1: 1 X-IronPort-AV: E=Sophos;i="5.84,236,1620716400"; d="scan'208";a="570205582" Received: from kuha.fi.intel.com ([10.237.72.162]) by fmsmga001.fm.intel.com with SMTP; 13 Jul 2021 00:46:37 -0700 Received: by kuha.fi.intel.com (sSMTP sendmail emulation); Tue, 13 Jul 2021 10:46:36 +0300 Date: Tue, 13 Jul 2021 10:46:36 +0300 From: Heikki Krogerus To: "Rafael J. Wysocki" Cc: Greg Kroah-Hartman , "Rafael J. Wysocki" , Andy Shevchenko , Linux ACPI , LKML Subject: Re: [PATCH v1 5/6] software nodes: Split software_node_notify() Message-ID: References: <2780027.e9J7NaK4W3@kreacher> <5627033.MhkbZ0Pkbq@kreacher> MIME-Version: 1.0 Content-Type: text/plain; charset=us-ascii Content-Disposition: inline In-Reply-To: Precedence: bulk List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Mon, Jul 12, 2021 at 08:30:06PM +0200, Rafael J. Wysocki wrote: > On Mon, Jul 12, 2021 at 8:03 PM Greg Kroah-Hartman > wrote: > > > > On Mon, Jul 12, 2021 at 07:27:12PM +0200, Rafael J. Wysocki wrote: > > > From: Rafael J. Wysocki > > > > > > Split software_node_notify_remove) out of software_node_notify() > > > and make device_platform_notify() call the latter on device addition > > > and the former on device removal. > > > > > > While at it, put the headers of the above functions into base.h, > > > because they don't need to be present in a global header file. > > > > > > No intentional functional impact. > > > > > > Signed-off-by: Rafael J. Wysocki > > > --- > > > drivers/base/base.h | 3 ++ > > > drivers/base/core.c | 9 +++--- > > > drivers/base/swnode.c | 61 ++++++++++++++++++++++++----------------------- > > > include/linux/property.h | 2 - > > > 4 files changed, 39 insertions(+), 36 deletions(-) > > > > > > Index: linux-pm/drivers/base/swnode.c > > > =================================================================== > > > --- linux-pm.orig/drivers/base/swnode.c > > > +++ linux-pm/drivers/base/swnode.c > > > @@ -11,6 +11,8 @@ > > > #include > > > #include > > > > > > +#include "base.h" > > > + > > > struct swnode { > > > struct kobject kobj; > > > struct fwnode_handle fwnode; > > > @@ -1053,7 +1055,7 @@ int device_add_software_node(struct devi > > > * balance. > > > */ > > > if (device_is_registered(dev)) > > > - software_node_notify(dev, KOBJ_ADD); > > > + software_node_notify(dev); > > > > Should this now be called "software_node_notify_add()" to match up with: > > > > > if (device_is_registered(dev)) > > > - software_node_notify(dev, KOBJ_REMOVE); > > > + software_node_notify_remove(dev); > > > > The other being called "_remove"? > > > > Makes it more obvious to me :) > > The naming convention used here follows platform_notify() and > platform_notify_remove(), and the analogous function names in ACPI for > that matter. So why not rename those instead: platform_notify() to platform_notify_add() and so on? You are in any case modifying acpi_device_notify() in this series, and I think there is only one place left where .platform_notify is assigned. I believe you also wouldn't then need to worry about the function name collision (3/6). > I thought that adding _add in just one case would be sort of odd, but > of course I can do that, so please let me know what you want me to do. I would prefer the "_add" ending, but in any case, FWIW: Reviewed-by: Heikki Krogerus -- heikki