linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Mark Rutland <mark.rutland@arm.com>
To: madvenka@linux.microsoft.com
Cc: broonie@kernel.org, jpoimboe@redhat.com, ardb@kernel.org,
	nobuta.keiya@fujitsu.com, sjitindarsingh@gmail.com,
	catalin.marinas@arm.com, will@kernel.org, jmorris@namei.org,
	linux-arm-kernel@lists.infradead.org,
	live-patching@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH v12 04/10] arm64: Split unwind_init()
Date: Thu, 6 Jan 2022 16:31:28 +0000	[thread overview]
Message-ID: <YdcZYGI42h7zybqo@FVFF77S0Q05N> (raw)
In-Reply-To: <20220103165212.9303-5-madvenka@linux.microsoft.com>

On Mon, Jan 03, 2022 at 10:52:06AM -0600, madvenka@linux.microsoft.com wrote:
> From: "Madhavan T. Venkataraman" <madvenka@linux.microsoft.com>
> 
> unwind_init() is currently a single function that initializes all of the
> unwind state. Split it into the following functions and call them
> appropriately:
> 
> 	- unwind_init_regs() - initialize from regs passed by caller.
> 
> 	- unwind_init_current() - initialize for the current task from the
> 	  caller of arch_stack_walk().
> 
> 	- unwind_init_from_task() - initialize from the saved state of a
> 	  task other than the current task. In this case, the other
> 	  task must not be running.
> 
> 	- unwind_init_common() - initialize fields that are common across
> 	  the above 3 cases.
> 
> This is done so that specialized initialization can be added to each case
> in the future.
> 
> Signed-off-by: Madhavan T. Venkataraman <madvenka@linux.microsoft.com>
> ---
>  arch/arm64/kernel/stacktrace.c | 50 +++++++++++++++++++++++++++-------
>  1 file changed, 40 insertions(+), 10 deletions(-)
> 
> diff --git a/arch/arm64/kernel/stacktrace.c b/arch/arm64/kernel/stacktrace.c
> index a1a7ff93b84f..bd797e3f7789 100644
> --- a/arch/arm64/kernel/stacktrace.c
> +++ b/arch/arm64/kernel/stacktrace.c
> @@ -33,11 +33,8 @@
>   */
>  
>  
> -static void unwind_init(struct unwind_state *state, unsigned long fp,
> -			unsigned long pc)
> +static void unwind_init_common(struct unwind_state *state)
>  {
> -	state->fp = fp;
> -	state->pc = pc;
>  #ifdef CONFIG_KRETPROBES
>  	state->kr_cur = NULL;
>  #endif
> @@ -56,6 +53,40 @@ static void unwind_init(struct unwind_state *state, unsigned long fp,
>  	state->prev_type = STACK_TYPE_UNKNOWN;
>  }
>  
> +/*
> + * TODO: document requirements here.
> + */
> +static inline void unwind_init_regs(struct unwind_state *state,
> +				    struct pt_regs *regs)
> +{
> +	state->fp = regs->regs[29];
> +	state->pc = regs->pc;
> +}

When I suggested this back in:

  https://lore.kernel.org/linux-arm-kernel/20211123193723.12112-1-madvenka@linux.microsoft.com/T/#md91fbfe08ceab2a02d9f5c326e17997786e53208

... my intent was that each unwind_init_from_*() helpers was the sole
initializer of the structure, and the caller only had to call one function.
That way it's not possible to construct an object with an erroneous combination
of arguments because the prototype enforces the set of arguments, and the
helper function can operate on a consistent snapshot of those arguments.

So I'd much prefer that each of these helpers called unwind_init_common(),
rather than leaving that to the caller to do. I don't mind if those pass
arguments to unwind_init_common(), or explciitly initialize their respective
fields, but I don' think the caller should have to care about unwind_init_common().

I'd also prefer the unwind_init_from*() naming I'd previously suggested, so
that it's clear which direction information is flowing.

>
> +
> +/*
> + * TODO: document requirements here.
> + *
> + * Note: this is always inlined, and we expect our caller to be a noinline
> + * function, such that this starts from our caller's caller.
> + */
> +static __always_inline void unwind_init_current(struct unwind_state *state)
> +{
> +	state->fp = (unsigned long)__builtin_frame_address(1);
> +	state->pc = (unsigned long)__builtin_return_address(0);
> +}
> +
> +/*
> + * TODO: document requirements here.
> + *
> + * The caller guarantees that the task is not running.
> + */
> +static inline void unwind_init_task(struct unwind_state *state,
> +				    struct task_struct *task)
> +{
> +	state->fp = thread_saved_fp(task);
> +	state->pc = thread_saved_pc(task);
> +}
> +
>  /*
>   * Unwind from one frame record (A) to the next frame record (B).
>   *
> @@ -194,15 +225,14 @@ noinline notrace void arch_stack_walk(stack_trace_consume_fn consume_entry,
>  {
>  	struct unwind_state state;
>  
> +	unwind_init_common(&state);

As above, I really don't like that the caller has to call both the common
initializer and a specialized initializer here.

Thanks,
Mark.

> +
>  	if (regs)
> -		unwind_init(&state, regs->regs[29], regs->pc);
> +		unwind_init_regs(&state, regs);
>  	else if (task == current)
> -		unwind_init(&state,
> -				(unsigned long)__builtin_frame_address(1),
> -				(unsigned long)__builtin_return_address(0));
> +		unwind_init_current(&state);
>  	else
> -		unwind_init(&state, thread_saved_fp(task),
> -				thread_saved_pc(task));
> +		unwind_init_task(&state, task);
>  
>  	unwind(task, &state, consume_entry, cookie);
>  }
> -- 
> 2.25.1
> 

  reply	other threads:[~2022-01-06 16:31 UTC|newest]

Thread overview: 23+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
     [not found] <0d0eb36f348fb5a6af6eb592c0525f6e94007328>
2022-01-03 16:52 ` [PATCH v12 00/10] arm64: Reorganize the unwinder and implement stack trace reliability checks madvenka
2022-01-03 16:52   ` [PATCH v12 01/10] arm64: Remove NULL task check from unwind_frame() madvenka
2022-01-06 16:07     ` Mark Rutland
2022-01-03 16:52   ` [PATCH v12 02/10] arm64: Rename unwinder functions madvenka
2022-01-06 16:10     ` Mark Rutland
2022-01-03 16:52   ` [PATCH v12 03/10] arm64: Rename stackframe to unwind_state madvenka
2022-01-04 14:59     ` Mark Brown
2022-01-06 16:11     ` Mark Rutland
2022-01-03 16:52   ` [PATCH v12 04/10] arm64: Split unwind_init() madvenka
2022-01-06 16:31     ` Mark Rutland [this message]
2022-01-06 20:13       ` Madhavan T. Venkataraman
2022-01-03 16:52   ` [PATCH v12 05/10] arm64: Copy unwind arguments to unwind_state madvenka
2022-01-05 16:57     ` Mark Brown
2022-01-06 16:37     ` Mark Rutland
2022-01-06 20:17       ` Madhavan T. Venkataraman
2022-01-03 16:52   ` [PATCH v12 06/10] arm64: Make the unwind loop in unwind() similar to other architectures madvenka
2022-01-03 16:52   ` [PATCH v12 07/10] arm64: Introduce stack trace reliability checks in the unwinder madvenka
2022-01-05 16:58     ` Mark Brown
2022-01-05 23:58       ` Madhavan T. Venkataraman
2022-01-06 11:43         ` Mark Brown
2022-01-03 16:52   ` [PATCH v12 08/10] arm64: Create a list of SYM_CODE functions, check return PC against list madvenka
2022-01-03 16:52   ` [PATCH v12 09/10] arm64: Introduce arch_stack_walk_reliable() madvenka
2022-01-03 16:52   ` [PATCH v12 10/10] arm64: Select HAVE_RELIABLE_STACKTRACE madvenka

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=YdcZYGI42h7zybqo@FVFF77S0Q05N \
    --to=mark.rutland@arm.com \
    --cc=ardb@kernel.org \
    --cc=broonie@kernel.org \
    --cc=catalin.marinas@arm.com \
    --cc=jmorris@namei.org \
    --cc=jpoimboe@redhat.com \
    --cc=linux-arm-kernel@lists.infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=live-patching@vger.kernel.org \
    --cc=madvenka@linux.microsoft.com \
    --cc=nobuta.keiya@fujitsu.com \
    --cc=sjitindarsingh@gmail.com \
    --cc=will@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).