archive mirror
 help / color / mirror / Atom feed
From: Paolo Bonzini <>
To: Linus Torvalds <>,
	Sean Christopherson <>,
	Borislav Petkov <>, Xiaoyao Li <>
Cc: Linux Kernel Mailing List <>,
	KVM list <>
Subject: Re: [GIT PULL] First batch of KVM changes for 5.6 merge window
Date: Fri, 31 Jan 2020 22:08:10 +0100	[thread overview]
Message-ID: <> (raw)
In-Reply-To: <>

On 31/01/20 19:01, Linus Torvalds wrote:
> There are other (pre-existing) differences, but while fixing up the
> merge conflict I really got the feeling that it's confusing and wrong
> to basically use different naming for these things when they are about
> the same bit.

I was supposed to get a topic branch and fix everything up so that both
CPU_BASED_ and VMX_FEATURE_ constants would get the new naming.  When
Boris alerted me of the conflict and I said "thanks I'll sort it out",
he probably interpreted it as me not needing the topic branch anymore.
I then forgot to remind him, and here we are.

> I don't care much which way it goes (maybe the VMX_FATURE_xyz bits
> should be renamed instead of the other way around?) and I wonder what
> the official documentation names are? Is there some standard here or
> are people just picking names at random?

The official documentation names are the ones introduced by the KVM pull
request ("Table 24-6. Definitions of Primary Processor-Based
VM-Execution Controls").  In fact consistency with the documentation was
why we changed them.  On the other hand Sean wanted VMX_FEATURE_* to be
consistent with CPU_BASED_*, which made sense when he wrote the patch.

I'll change the names to match for next week's second batch of KVM changes.


  parent reply	other threads:[~2020-01-31 21:08 UTC|newest]

Thread overview: 8+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-01-30 18:20 Paolo Bonzini
2020-01-31 18:01 ` Linus Torvalds
2020-01-31 18:53   ` Sean Christopherson
2020-01-31 19:03     ` Linus Torvalds
2020-01-31 21:08   ` Paolo Bonzini [this message]
2020-01-31 21:24     ` Borislav Petkov
2020-01-31 21:27       ` Paolo Bonzini
2020-01-31 19:35 ` pr-tracker-bot

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \ \ \ \ \ \ \ \ \
    --subject='Re: [GIT PULL] First batch of KVM changes for 5.6 merge window' \

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).