linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Phil Reid <preid@electromag.com.au>
To: Jonathan Cameron <jic23@kernel.org>,
	Michal Simek <michal.simek@xilinx.com>
Cc: linux-kernel@vger.kernel.org, monstr@monstr.eu,
	linux@roeck-us.net, "Colin Ian King" <colin.king@canonical.com>,
	linux-iio@vger.kernel.org,
	"Stefan Brüns" <stefan.bruens@rwth-aachen.de>,
	"Lars-Peter Clausen" <lars@metafoo.de>,
	"Peter Meerwald-Stadler" <pmeerw@pmeerw.net>,
	"Hartmut Knaack" <knaack.h@gmx.de>
Subject: Re: [PATCH 4/4] iio: adc: ina2xx: Use label proper for device identification
Date: Tue, 27 Aug 2019 11:55:07 +0800	[thread overview]
Message-ID: <af5fdfc3-dbc8-40fc-2893-c786670f28d4@electromag.com.au> (raw)
In-Reply-To: <20190825190753.7d52c3f9@archlinux>

On 26/08/2019 02:07, Jonathan Cameron wrote:
> On Wed, 21 Aug 2019 11:12:00 +0200
> Michal Simek <michal.simek@xilinx.com> wrote:
> 
>> On 21. 08. 19 4:11, Phil Reid wrote:
>>> On 20/08/2019 22:11, Michal Simek wrote:
>>>> Add support for using label property for easier device identification via
>>>> iio framework.
>>>>
>>>> Signed-off-by: Michal Simek <michal.simek@xilinx.com>
>>>> ---
>>>>
>>>>    drivers/iio/adc/ina2xx-adc.c | 2 +-
>>>>    1 file changed, 1 insertion(+), 1 deletion(-)
>>>>
>>>> diff --git a/drivers/iio/adc/ina2xx-adc.c b/drivers/iio/adc/ina2xx-adc.c
>>>> index 7c7c63677bf4..077c54915f70 100644
>>>> --- a/drivers/iio/adc/ina2xx-adc.c
>>>> +++ b/drivers/iio/adc/ina2xx-adc.c
>>>> @@ -1033,7 +1033,7 @@ static int ina2xx_probe(struct i2c_client *client,
>>>>        snprintf(chip->name, sizeof(chip->name), "%s-%s",
>>>>             client->name, dev_name(&client->dev));
>>>>    -    indio_dev->name = chip->name;
>>>> +    indio_dev->name = of_get_property(np, "label", NULL) ? : chip->name;
>>>>        indio_dev->setup_ops = &ina2xx_setup_ops;
>>>>          buffer = devm_iio_kfifo_allocate(&indio_dev->dev);
>>>>   
>>> I like this personally. It'd be nice if it was a core function so
>>> it could be an opt in to any iio device.
>>>
>>> Don't know how well received that'd be thou.
>>>    
> I'm not particularly keen on changing the semantics of existing
> ABI, but how about adding new ABI to provide this?
> 
> /sys/bus/iio/devices/iio\:device0/label for example?
> 
> I haven't thought about it in depth yet though.  If you spin
> a patch with that and the DT docs we'll be more likely to get
> a view from DT maintainers if this is acceptable use of label.
> 

I've sent "iio: core: Add optional symbolic label to device attributes"
for further discussion.


> Thanks
> 
> Jonathan
> 
>>
>> Something like this?
>>
>> diff --git a/drivers/iio/industrialio-core.c
>> b/drivers/iio/industrialio-core.c
>> index 524a686077ca..d21b495d36a1 100644
>> --- a/drivers/iio/industrialio-core.c
>> +++ b/drivers/iio/industrialio-core.c
>> @@ -1647,6 +1647,9 @@ int __iio_device_register(struct iio_dev
>> *indio_dev, struct module *this_mod)
>>          if (!indio_dev->dev.of_node && indio_dev->dev.parent)
>>                  indio_dev->dev.of_node = indio_dev->dev.parent->of_node;
>>
>> +       indio_dev->name = of_get_property(indio_dev->dev.of_node,
>> "label", NULL) ? :
>> +                                         indio_dev->name;
>> +
>>          ret = iio_check_unique_scan_index(indio_dev);
>>          if (ret < 0)
>>                  return ret;
>>
>>
>> M
> 
> 
> 


-- 
Regards
Phil Reid

ElectroMagnetic Imaging Technology Pty Ltd
Development of Geophysical Instrumentation & Software
www.electromag.com.au

3 The Avenue, Midland WA 6056, AUSTRALIA
Ph: +61 8 9250 8100
Fax: +61 8 9250 7100
Email: preid@electromag.com.au

  reply	other threads:[~2019-08-27  3:55 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2019-08-20 14:11 [PATCH 0/4] iio: adc: ina2xx: Improve device identification Michal Simek
2019-08-20 14:11 ` [PATCH 1/4] iio: adc: ina2xx: Define *device_node only once Michal Simek
2019-08-21  1:56   ` Phil Reid
2019-08-20 14:11 ` [PATCH 2/4] iio: adc: ina2xx: Setup better name then simple ina2xx Michal Simek
2019-08-21  2:10   ` Phil Reid
2019-08-21  8:36     ` Michal Simek
2019-08-20 14:11 ` [PATCH 3/4] dt-bindings: Add optional label property for ina2xx Michal Simek
2019-08-27 17:06   ` Rob Herring
2019-08-20 14:11 ` [PATCH 4/4] iio: adc: ina2xx: Use label proper for device identification Michal Simek
2019-08-21  2:11   ` Phil Reid
2019-08-21  9:12     ` Michal Simek
2019-08-25 18:07       ` Jonathan Cameron
2019-08-27  3:55         ` Phil Reid [this message]
2019-08-27  6:14           ` Michal Simek

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=af5fdfc3-dbc8-40fc-2893-c786670f28d4@electromag.com.au \
    --to=preid@electromag.com.au \
    --cc=colin.king@canonical.com \
    --cc=jic23@kernel.org \
    --cc=knaack.h@gmx.de \
    --cc=lars@metafoo.de \
    --cc=linux-iio@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux@roeck-us.net \
    --cc=michal.simek@xilinx.com \
    --cc=monstr@monstr.eu \
    --cc=pmeerw@pmeerw.net \
    --cc=stefan.bruens@rwth-aachen.de \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).