linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Thomas Gleixner <tglx@linutronix.de>
To: Fenghua Yu <fenghua.yu@intel.com>
Cc: "H. Peter Anvin" <h.peter.anvin@intel.com>,
	Ingo Molnar <mingo@elte.hu>, Tony Luck <tony.luck@intel.com>,
	Peter Zijlstra <peterz@infradead.org>, Tejun Heo <tj@kernel.org>,
	Borislav Petkov <bp@suse.de>,
	Stephane Eranian <eranian@google.com>,
	Marcelo Tosatti <mtosatti@redhat.com>,
	David Carrillo-Cisneros <davidcc@google.com>,
	Shaohua Li <shli@fb.com>,
	Ravi V Shankar <ravi.v.shankar@intel.com>,
	Vikas Shivappa <vikas.shivappa@linux.intel.com>,
	Sai Prakhya <sai.praneeth.prakhya@intel.com>,
	linux-kernel <linux-kernel@vger.kernel.org>, x86 <x86@kernel.org>
Subject: Re: [PATCH v2 27/33] x86/intel_rdt_rdtgroup.c: Implement resctrl file system commands
Date: Thu, 8 Sep 2016 22:09:09 +0200 (CEST)	[thread overview]
Message-ID: <alpine.DEB.2.20.1609082141220.5454@nanos> (raw)
In-Reply-To: <1473328647-33116-28-git-send-email-fenghua.yu@intel.com>

On Thu, 8 Sep 2016, Fenghua Yu wrote:
> +static struct kernfs_syscall_ops rdtgroup_kf_syscall_ops = {
> +	.mkdir          = rdtgroup_mkdir,
> +	.rmdir          = rdtgroup_rmdir,
> +};
> +
> +static struct file_system_type rdt_fs_type = {
> +	.name = "resctrl",
> +	.mount = rdt_mount,
> +	.kill_sb = rdt_kill_sb,
> +};

So the above struct is nicely aligned and readable. While this one is
not. Sigh,

>  struct rdtgroup *root_rdtgrp;
>  static struct rftype rdtgroup_partition_base_files[];
>  struct cache_domain cache_domains[MAX_CACHE_LEAVES];
>  /* The default hierarchy. */
>  struct rdtgroup_root rdtgrp_dfl_root;
>  static struct list_head rdtgroups;
> +bool rdtgroup_mounted;

Your choice of global/static visible variables is driven by a random
generator or what?
  
>  /*
>   * kernfs_root - find out the kernfs_root a kernfs_node belongs to
> @@ -730,6 +749,110 @@ static void rdtgroup_destroy_locked(struct rdtgroup *rdtgrp)
>  	kernfs_remove(rdtgrp->kn);
>  }
>  
> +static int rdtgroup_mkdir(struct kernfs_node *parent_kn, const char *name,
> +			umode_t mode)
> +{
> +	struct rdtgroup *parent, *rdtgrp;
> +	struct rdtgroup_root *root;
> +	struct kernfs_node *kn;
> +	int ret;
> +
> +	if (parent_kn != root_rdtgrp->kn)
> +		return -EPERM;
> +
> +	/* Do not accept '\n' to avoid unparsable situation.
> +	 */

Where did copy you this comment style from? Its' horrible and here is a
lengthy explanation why: https://lkml.org/lkml/2016/7/8/625

> +static struct dentry *rdt_mount(struct file_system_type *fs_type,
> +			 int flags, const char *unused_dev_name,
> +			 void *data)
> +{
> +	struct super_block *pinned_sb = NULL;
> +	struct rdtgroup_root *root;
> +	struct dentry *dentry;
> +	int ret;
> +	bool new_sb;
> +
> +	/*
> +	 * The first time anyone tries to mount a rdtgroup, enable the list
> +	 * linking tasks and fix up all existing tasks.

What are 'list linking tasks'? What is fixed up here?

> +	 */
> +	if (rdtgroup_mounted)
> +		return ERR_PTR(-EBUSY);

How is this serialized against concurrent mounts? Oh well....

> +	rdt_opts.cdp_enabled = false;
> +	rdt_opts.verbose = false;
> +	cdp_enabled = false;
> +
> +	ret = parse_rdtgroupfs_options(data);
> +	if (ret)
> +		goto out_mount;
> +
> +	if (rdt_opts.cdp_enabled) {
> +		cdp_enabled = true;
> +		cconfig.max_closid >>= cdp_enabled;
> +		pr_info("CDP is enabled\n");
> +	}
> +
> +	init_msrs(cdp_enabled);
> +
> +	root = &rdtgrp_dfl_root;
> +
> +	ret = get_default_resources(&root->rdtgrp);
> +	if (ret)
> +		return ERR_PTR(-ENOSPC);
> +
> +out_mount:
> +	dentry = kernfs_mount(fs_type, flags, root->kf_root,
> +			      RDTGROUP_SUPER_MAGIC,
> +			      &new_sb);
> +	if (IS_ERR(dentry) || !new_sb)
> +		goto out_unlock;

And ret , which is returned @out_unlock is 0. So instead of returning the
error code encoded in dentry you return a NULL pointer.

> +	/*
> +	 * If @pinned_sb, we're reusing an existing root and holding an
> +	 * extra ref on its sb.  Mount is complete.  Put the extra ref.
> +	 */
> +	if (pinned_sb) {

And how exactly becomes pinned_sb != NULL?

> +		WARN_ON(new_sb);
> +		deactivate_super(pinned_sb);
> +	}

Not at all.

> +	INIT_LIST_HEAD(&root->rdtgrp.pset.tasks);
> +
> +	cpumask_copy(&root->rdtgrp.cpu_mask, cpu_online_mask);
> +	static_key_slow_inc(&rdt_enable_key);
> +	rdtgroup_mounted = true;
> +
> +	return dentry;
> +
> +out_unlock:
> +	return ERR_PTR(ret);

So a return magically unlocks stuff. Or does this happen in ERR_PTR()?

This jump label is not only pointless it's also named badly.

Thanks,

	tglx

  reply	other threads:[~2016-09-08 20:11 UTC|newest]

Thread overview: 96+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-09-08  9:56 [PATCH v2 00/33] Enable Intel Resource Allocation in Resource Director Technology Fenghua Yu
2016-09-08  9:56 ` [PATCH v2 01/33] cacheinfo: Introduce cache id Fenghua Yu
2016-09-09 15:01   ` Nilay Vaish
2016-09-08  9:56 ` [PATCH v2 02/33] Documentation, ABI: Add a document entry for " Fenghua Yu
2016-09-08 19:33   ` Thomas Gleixner
2016-09-09 15:11     ` Nilay Vaish
2016-09-08  9:56 ` [PATCH v2 03/33] x86, intel_cacheinfo: Enable cache id in x86 Fenghua Yu
2016-09-08  9:56 ` [PATCH v2 04/33] drivers/base/cacheinfo.c: Export some cacheinfo functions for others to use Fenghua Yu
2016-09-08  8:21   ` Thomas Gleixner
2016-09-08  9:56 ` [PATCH v2 05/33] x86/intel_rdt: Cache Allocation documentation Fenghua Yu
2016-09-08  9:57 ` [PATCH v2 06/33] Documentation, x86: Documentation for Intel resource allocation user interface Fenghua Yu
2016-09-08 11:22   ` Borislav Petkov
2016-09-08 22:01   ` Shaohua Li
2016-09-09  1:17     ` Fenghua Yu
2016-09-08 22:45       ` Shaohua Li
2016-09-09  7:22         ` Fenghua Yu
2016-09-09 17:50           ` Shaohua Li
2016-09-09 18:03             ` Luck, Tony
2016-09-09 21:43               ` Shaohua Li
2016-09-09 21:59                 ` Luck, Tony
2016-09-10  0:36                   ` Yu, Fenghua
2016-09-12  4:15                     ` Shaohua Li
2016-09-13 13:27                       ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 07/33] x86/intel_rdt: Add support for Cache Allocation detection Fenghua Yu
2016-09-08 11:50   ` Borislav Petkov
2016-09-08 16:53     ` Yu, Fenghua
2016-09-08 17:17       ` Borislav Petkov
2016-09-08 13:17   ` Thomas Gleixner
2016-09-08 13:59     ` Yu, Fenghua
2016-09-13 22:40   ` Dave Hansen
2016-09-13 22:52     ` Luck, Tony
2016-09-13 23:00       ` Dave Hansen
2016-09-08  9:57 ` [PATCH v2 08/33] x86/intel_rdt: Add Class of service management Fenghua Yu
2016-09-08  8:56   ` Thomas Gleixner
2016-09-12 16:02   ` Nilay Vaish
2016-09-08  9:57 ` [PATCH v2 09/33] x86/intel_rdt: Add L3 cache capacity bitmask management Fenghua Yu
2016-09-08  9:40   ` Thomas Gleixner
2016-09-12 16:10   ` Nilay Vaish
2016-09-08  9:57 ` [PATCH v2 10/33] x86/intel_rdt: Implement scheduling support for Intel RDT Fenghua Yu
2016-09-08  9:53   ` Thomas Gleixner
2016-09-15 21:36     ` Yu, Fenghua
2016-09-15 21:40       ` Luck, Tony
2016-09-13 17:55   ` Nilay Vaish
2016-09-08  9:57 ` [PATCH v2 11/33] x86/intel_rdt: Hot cpu support for Cache Allocation Fenghua Yu
2016-09-08 10:03   ` Thomas Gleixner
2016-09-13 18:18   ` Nilay Vaish
2016-09-13 19:10     ` Luck, Tony
2016-09-08  9:57 ` [PATCH v2 12/33] x86/intel_rdt: Intel haswell Cache Allocation enumeration Fenghua Yu
2016-09-08 10:08   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 13/33] Define CONFIG_INTEL_RDT Fenghua Yu
2016-09-08 10:14   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 14/33] x86/intel_rdt: Intel Code Data Prioritization detection Fenghua Yu
2016-09-08  9:57 ` [PATCH v2 15/33] x86/intel_rdt: Adds support to enable Code Data Prioritization Fenghua Yu
2016-09-08 10:18   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 16/33] x86/intel_rdt: Class of service and capacity bitmask management for CDP Fenghua Yu
2016-09-08 10:29   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 17/33] x86/intel_rdt: Hot cpu update for code data prioritization Fenghua Yu
2016-09-08 10:34   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 18/33] sched.h: Add rg_list and rdtgroup in task_struct Fenghua Yu
2016-09-08 10:36   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 19/33] magic number for resctrl file system Fenghua Yu
2016-09-08 10:41   ` Thomas Gleixner
2016-09-08 10:47     ` Borislav Petkov
2016-09-08  9:57 ` [PATCH v2 20/33] x86/intel_rdt.h: Header for inter_rdt.c Fenghua Yu
2016-09-08 12:36   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 21/33] x86/intel_rdt_rdtgroup.h: Header for user interface Fenghua Yu
2016-09-08 12:44   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 22/33] x86/intel_rdt.c: Extend RDT to per cache and per resources Fenghua Yu
2016-09-08 14:57   ` Thomas Gleixner
2016-09-13 22:54   ` Dave Hansen
2016-09-08  9:57 ` [PATCH v2 23/33] x86/intel_rdt_rdtgroup.c: User interface for RDT Fenghua Yu
2016-09-08 14:59   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 24/33] x86/intel_rdt_rdtgroup.c: Create info directory Fenghua Yu
2016-09-08 16:04   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 25/33] include/linux/resctrl.h: Define fork and exit functions in a new header file Fenghua Yu
2016-09-08 16:07   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 26/33] Task fork and exit for rdtgroup Fenghua Yu
2016-09-08 19:41   ` Thomas Gleixner
2016-09-13 23:13   ` Dave Hansen
2016-09-13 23:35     ` Luck, Tony
2016-09-14 14:28       ` Dave Hansen
2016-09-08  9:57 ` [PATCH v2 27/33] x86/intel_rdt_rdtgroup.c: Implement resctrl file system commands Fenghua Yu
2016-09-08 20:09   ` Thomas Gleixner [this message]
2016-09-08 22:04   ` Shaohua Li
2016-09-09  1:23     ` Fenghua Yu
2016-09-08  9:57 ` [PATCH v2 28/33] x86/intel_rdt_rdtgroup.c: Read and write cpus Fenghua Yu
2016-09-08 20:25   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 29/33] x86/intel_rdt_rdtgroup.c: Tasks iterator and write Fenghua Yu
2016-09-08 20:50   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 30/33] x86/intel_rdt_rdtgroup.c: Process schemata input from resctrl interface Fenghua Yu
2016-09-08 22:20   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 31/33] Documentation/kernel-parameters: Add kernel parameter "resctrl" for CAT Fenghua Yu
2016-09-08 22:25   ` Thomas Gleixner
2016-09-08  9:57 ` [PATCH v2 32/33] MAINTAINERS: Add maintainer for Intel RDT resource allocation Fenghua Yu
2016-09-08  9:57 ` [PATCH v2 33/33] x86/Makefile: Build intel_rdt_rdtgroup.c Fenghua Yu
2016-09-08 23:59   ` Thomas Gleixner

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.20.1609082141220.5454@nanos \
    --to=tglx@linutronix.de \
    --cc=bp@suse.de \
    --cc=davidcc@google.com \
    --cc=eranian@google.com \
    --cc=fenghua.yu@intel.com \
    --cc=h.peter.anvin@intel.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=mtosatti@redhat.com \
    --cc=peterz@infradead.org \
    --cc=ravi.v.shankar@intel.com \
    --cc=sai.praneeth.prakhya@intel.com \
    --cc=shli@fb.com \
    --cc=tj@kernel.org \
    --cc=tony.luck@intel.com \
    --cc=vikas.shivappa@linux.intel.com \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).