linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Stefano Stabellini <sstabellini@kernel.org>
To: Christoph Hellwig <hch@infradead.org>
Cc: Stefano Stabellini <sstabellini@kernel.org>,
	jgross@suse.com, boris.ostrovsky@oracle.com,
	konrad.wilk@oracle.com, xen-devel@lists.xenproject.org,
	linux-kernel@vger.kernel.org, tamas@tklengyel.com,
	roman@zededa.com,
	Stefano Stabellini <stefano.stabellini@xilinx.com>
Subject: Re: [PATCH v2 08/11] swiotlb-xen: introduce phys_to_dma/dma_to_phys translations
Date: Mon, 8 Jun 2020 16:06:57 -0700 (PDT)	[thread overview]
Message-ID: <alpine.DEB.2.21.2006081558400.2815@sstabellini-ThinkPad-T480s> (raw)
In-Reply-To: <20200608070850.GD15742@infradead.org>

On Mon, 8 Jun 2020, Christoph Hellwig wrote:
> On Wed, Jun 03, 2020 at 03:22:44PM -0700, Stefano Stabellini wrote:
> > From: Stefano Stabellini <stefano.stabellini@xilinx.com>
> > 
> > With some devices physical addresses are different than dma addresses.
> > To be able to deal with these cases, we need to call phys_to_dma on
> > physical addresses (including machine addresses in Xen terminology)
> > before returning them from xen_swiotlb_alloc_coherent and
> > xen_swiotlb_map_page.
> > 
> > We also need to convert dma addresses back to physical addresses using
> > dma_to_phys in xen_swiotlb_free_coherent and xen_swiotlb_unmap_page if
> > we want to do any operations on them.
> > 
> > Call dma_to_phys in is_xen_swiotlb_buffer.
> > Call phys_to_dma in xen_phys_to_bus.
> > Call dma_to_phys in xen_bus_to_phys.
> > 
> > Everything is taken care of by these changes except for
> > xen_swiotlb_alloc_coherent and xen_swiotlb_free_coherent, which need a
> > few explicit phys_to_dma/dma_to_phys calls.
> > 
> > Signed-off-by: Stefano Stabellini <stefano.stabellini@xilinx.com>
> > Tested-by: Corey Minyard <cminyard@mvista.com>
> > Tested-by: Roman Shaposhnik <roman@zededa.com>
> > ---
> > Changes in v2:
> > - improve commit message
> > ---
> >  drivers/xen/swiotlb-xen.c | 22 ++++++++++++----------
> >  1 file changed, 12 insertions(+), 10 deletions(-)
> > 
> > diff --git a/drivers/xen/swiotlb-xen.c b/drivers/xen/swiotlb-xen.c
> > index 0a6cb67f0fc4..60ef07440905 100644
> > --- a/drivers/xen/swiotlb-xen.c
> > +++ b/drivers/xen/swiotlb-xen.c
> > @@ -64,16 +64,16 @@ static inline dma_addr_t xen_phys_to_bus(struct device *dev, phys_addr_t paddr)
> >  
> >  	dma |= paddr & ~XEN_PAGE_MASK;
> >  
> > -	return dma;
> > +	return phys_to_dma(dev, dma);
> 
> So looking at this function:
> 
> The dma name for something passed to phys_to_dma is really
> weird.

Yeah, that is true, I am not sure why I chose that confusing name. I'll
rename it.


> The fact that the comments says don't use XEN_PFN_PHYS
> beause of the type mismatch while nothing but swiotlb-xen is the only
> user of XEN_PFN_PHYS is also weird.  I think XEN_PFN_PHYS needs to move
> to swiotlb-xen first, then use a hardcoded u64 for the size, and the
> split the function into a phys_to_xen_phys (or so) function where
> the result gets passed to phys_to_dma.

I understand what you are suggesting about having something like:

    xen_phys_to_dma(...)
    {
        phys_addr_t phys = xen_phys_to_bus(dev, paddr)
        return phys_to_dma(phys);
    }

I thought about it myself. I'll do it.

But I don't think I understood the comment about XEN_PFN_PHYS.


> Similar for the reverse direction.

OK

  reply	other threads:[~2020-06-09  1:04 UTC|newest]

Thread overview: 31+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2020-06-03 22:22 [PATCH v2 00/11] fix swiotlb-xen for RPi4 Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 01/11] swiotlb-xen: use vmalloc_to_page on vmalloc virt addresses Stefano Stabellini
2020-06-08  7:04   ` Christoph Hellwig
2020-06-08 22:53     ` Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 02/11] swiotlb-xen: remove start_dma_addr Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 03/11] swiotlb-xen: add struct device* parameter to xen_phys_to_bus Stefano Stabellini
2020-06-08  7:05   ` Christoph Hellwig
2020-06-08 22:55     ` Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 04/11] swiotlb-xen: add struct device* parameter to xen_bus_to_phys Stefano Stabellini
2020-06-08  7:05   ` Christoph Hellwig
2020-06-03 22:22 ` [PATCH v2 05/11] swiotlb-xen: add struct device* parameter to xen_dma_sync_for_cpu Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 06/11] swiotlb-xen: add struct device* parameter to xen_dma_sync_for_device Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 07/11] swiotlb-xen: add struct device* parameter to is_xen_swiotlb_buffer Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 08/11] swiotlb-xen: introduce phys_to_dma/dma_to_phys translations Stefano Stabellini
2020-06-04 17:46   ` Boris Ostrovsky
2020-06-04 17:47     ` boris.ostrovsky
2020-06-08  7:08   ` Christoph Hellwig
2020-06-08 23:06     ` Stefano Stabellini [this message]
2020-06-09  3:46       ` Stefano Stabellini
2020-06-09  5:32       ` Christoph Hellwig
2020-06-09 21:50         ` Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 09/11] swiotlb-xen: rename xen_phys_to_bus to xen_phys_to_dma and xen_bus_to_phys to xen_dma_to_phys Stefano Stabellini
2020-06-08  7:09   ` Christoph Hellwig
2020-06-03 22:22 ` [PATCH v2 10/11] xen/arm: introduce phys/dma translations in xen_dma_sync_for_* Stefano Stabellini
2020-06-08  7:12   ` Christoph Hellwig
2020-06-09  0:38     ` Stefano Stabellini
2020-06-09  5:38       ` Christoph Hellwig
2020-06-09  5:39         ` Christoph Hellwig
2020-06-09 21:50           ` Stefano Stabellini
2020-06-03 22:22 ` [PATCH v2 11/11] xen/arm: call dma_to_phys on the dma_addr_t parameter of dma_cache_maint Stefano Stabellini
2020-06-04 18:32 ` [PATCH v2 00/11] fix swiotlb-xen for RPi4 Boris Ostrovsky

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.21.2006081558400.2815@sstabellini-ThinkPad-T480s \
    --to=sstabellini@kernel.org \
    --cc=boris.ostrovsky@oracle.com \
    --cc=hch@infradead.org \
    --cc=jgross@suse.com \
    --cc=konrad.wilk@oracle.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=roman@zededa.com \
    --cc=stefano.stabellini@xilinx.com \
    --cc=tamas@tklengyel.com \
    --cc=xen-devel@lists.xenproject.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).