From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1751418AbbESV6J (ORCPT ); Tue, 19 May 2015 17:58:09 -0400 Received: from cantor2.suse.de ([195.135.220.15]:49356 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1750734AbbESV6H (ORCPT ); Tue, 19 May 2015 17:58:07 -0400 Date: Tue, 19 May 2015 23:58:05 +0200 (CEST) From: Jiri Kosina To: Minfei Huang cc: Jiri Slaby , live-patching@vger.kernel.org, jpoimboe@redhat.com, sjenning@redhat.com, vojtech@suse.cz, linux-kernel@vger.kernel.org Subject: Re: [PATCH 2/2] livepatch: introduce patch/func-walking helpers In-Reply-To: <20150519122724.GA37748@dhcp-128-78.nay.redhat.com> Message-ID: References: <1432029679-9763-1-git-send-email-jslaby@suse.cz> <1432029679-9763-2-git-send-email-jslaby@suse.cz> <20150519122724.GA37748@dhcp-128-78.nay.redhat.com> User-Agent: Alpine 2.00 (LNX 1167 2008-08-23) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Tue, 19 May 2015, Minfei Huang wrote: > > klp_for_each_object and klp_for_each_func are now used all over the > > code. One need not think what is the proper condition to check in the > > for loop now. > > > > Signed-off-by: Jiri Slaby > > --- > > include/linux/livepatch.h | 6 ++++++ > > kernel/livepatch/core.c | 18 +++++++++--------- > > 2 files changed, 15 insertions(+), 9 deletions(-) > > > > diff --git a/include/linux/livepatch.h b/include/linux/livepatch.h > > index fe45f2f02c8d..31db7a05dd36 100644 > > --- a/include/linux/livepatch.h > > +++ b/include/linux/livepatch.h > > @@ -805,7 +805,7 @@ static int klp_init_patch(struct klp_patch *patch) > > if (ret) > > goto unlock; > > > > - for (obj = patch->objs; obj->funcs; obj++) { > > + klp_for_each_object(patch, obj) { > > ret = klp_init_object(patch, obj); > > if (ret) > > goto free; > > @@ -960,7 +960,7 @@ static int klp_module_notify(struct notifier_block *nb, unsigned long action, > > mod->klp_alive = false; > > > > list_for_each_entry(patch, &klp_patches, list) { > > - for (obj = patch->objs; obj->funcs; obj++) { > > + klp_for_each_object(patch, obj) { > > The code is more clearly to use "if", instead of the loop, although we will take > more than one line than previous, since we will always get the first function > from the object. I have absolutely no idea what you are trying to say here, sorry. Could you please try to rephrase your review comment? Thanks, -- Jiri Kosina SUSE Labs