From mboxrd@z Thu Jan 1 00:00:00 1970 Return-Path: Received: (majordomo@vger.kernel.org) by vger.kernel.org via listexpand id S1031920AbbKEJka (ORCPT ); Thu, 5 Nov 2015 04:40:30 -0500 Received: from mx2.suse.de ([195.135.220.15]:39572 "EHLO mx2.suse.de" rhost-flags-OK-OK-OK-OK) by vger.kernel.org with ESMTP id S1030886AbbKEJk1 (ORCPT ); Thu, 5 Nov 2015 04:40:27 -0500 Date: Thu, 5 Nov 2015 10:40:26 +0100 (CET) From: Jiri Kosina X-X-Sender: jkosina@pobox.suse.cz To: Josh Poimboeuf cc: Miroslav Benes , Seth Jennings , Vojtech Pavlik , linux-kernel@vger.kernel.org, live-patching@vger.kernel.org, "Cyril B." Subject: Re: [PATCH] livepatch: Cleanup page permission changes In-Reply-To: Message-ID: References: <132b018cfe2c6e4cef4d1b62ac3ed70333734111.1446494413.git.jpoimboe@redhat.com> <20151103174228.GN27488@treble.redhat.com> <20151104231252.GA28254@treble.redhat.com> User-Agent: Alpine 2.00 (LNX 1167 2008-08-23) MIME-Version: 1.0 Content-Type: TEXT/PLAIN; charset=US-ASCII Sender: linux-kernel-owner@vger.kernel.org List-ID: X-Mailing-List: linux-kernel@vger.kernel.org On Thu, 5 Nov 2015, Jiri Kosina wrote: > > > > +#ifdef CONFIG_DEBUG_SET_MODULE_RONX > > > > +static void set_page_attributes(void *start, void *end, > > > > + int (*set)(unsigned long start, int num_pages)) > > > > +{ > > > > + unsigned long begin_pfn = PFN_DOWN((unsigned long)start); > > > > + unsigned long end_pfn = PFN_DOWN((unsigned long)end); > > > > + > > > > + if (end_pfn > begin_pfn) > > > > + set(begin_pfn << PAGE_SHIFT, end_pfn - begin_pfn); > > > > +} > > BTW is there any reason not to make use of the function from module.c > which does exactly the same, instead of copy pasting it all around? > > > > > +static void set_module_ro_rw(struct module *mod) > > > > +{ > > > > + set_page_attributes(mod->module_core, > > > > + mod->module_core + mod->core_ro_size, > > > > + set_memory_rw); > > > > +} > > > > +static void set_module_ro_ro(struct module *mod) > > > > > > Honestly, I find both the function names above horrible and not really > > > self-explanatory (especially the _ro_ro variant). At least comment, > > > explaining what they are actually doing, or picking up a better name, > > > would make the code much more self-explanatory in my eyes. > > > > Being the patch author, naturally the function names make sense to me. > > :) > > > set_module_ro_ro() means "set the module's read-only area to have > > read-only permissions." > > > > Do you have any suggestions for a better name? > > I'd even say it's superfluous to have the functions at the first place, > and just calling set_page_attributes() directly makes the intent clear > enough already. To make my proposal more clear: - move set_page_attributes() to module.h and provide empty stub for !CONFIG_DEBUG_SET_MODULE_RONX case (and probably rename it to something like module_set_page_attributes() to avoid namespace conflicts with mm code) - make use of that function both from module.c (where it's already being used) and livepatch.c, where it'd be called directly Thanks, -- Jiri Kosina SUSE Labs