linux-kernel.vger.kernel.org archive mirror
 help / color / mirror / Atom feed
From: Finn Thain <fthain@telegraphics.com.au>
To: LEROY Christophe <christophe.leroy@c-s.fr>,
	Arnd Bergmann <arnd@arndb.de>
Cc: linux-fbdev@vger.kernel.org, dri-devel@lists.freedesktop.org,
	linux-kernel@vger.kernel.org, linuxppc-dev@lists.ozlabs.org,
	linux-m68k@lists.linux-m68k.org,
	Bartlomiej Zolnierkiewicz <b.zolnierkie@samsung.com>,
	Michael Ellerman <mpe@ellerman.id.au>,
	Paul Mackerras <paulus@samba.org>,
	Benjamin Herrenschmidt <benh@kernel.crashing.org>,
	Greg Kroah-Hartman <gregkh@linuxfoundation.org>
Subject: Re: [PATCH v8 20/25] powerpc, fbdev: Use arch_nvram_ops methods instead of nvram_read_byte() and nvram_write_byte()
Date: Sun, 6 Jan 2019 10:06:24 +1100 (AEDT)	[thread overview]
Message-ID: <alpine.LNX.2.21.1901060931140.23@nippy.intranet> (raw)
In-Reply-To: <alpine.LNX.2.21.1812301024400.215@nippy.intranet>

On Sun, 30 Dec 2018, I wrote:

> On Sat, 29 Dec 2018, LEROY Christophe wrote:
> 
> > Finn Thain <fthain@telegraphics.com.au> a ?crit?:
> > 
> > > Make use of arch_nvram_ops in device drivers so that the nvram_* function
> > > exports can be removed.
> > > 
> > > Since they are no longer global symbols, rename the PPC32 nvram_* functions
> > > appropriately.
> > > 
> > > Signed-off-by: Finn Thain <fthain@telegraphics.com.au>
> > > ---
> > > arch/powerpc/kernel/setup_32.c             | 8 ++++----
> > > drivers/char/generic_nvram.c               | 4 ++--
> > > drivers/video/fbdev/controlfb.c            | 4 ++--
> > > drivers/video/fbdev/imsttfb.c              | 4 ++--
> > > drivers/video/fbdev/matrox/matroxfb_base.c | 2 +-
> > > drivers/video/fbdev/platinumfb.c           | 4 ++--
> > > drivers/video/fbdev/valkyriefb.c           | 4 ++--
> > > 7 files changed, 15 insertions(+), 15 deletions(-)
> > > 
> > > diff --git a/arch/powerpc/kernel/setup_32.c b/arch/powerpc/kernel/setup_32.c
> > > index e0d045677472..bdbe6acbef11 100644
> > > --- a/arch/powerpc/kernel/setup_32.c
> > > +++ b/arch/powerpc/kernel/setup_32.c
> > > @@ -152,20 +152,18 @@ __setup("l3cr=", ppc_setup_l3cr);
> > > 
> > > #ifdef CONFIG_GENERIC_NVRAM
> > > 
> > > -unsigned char nvram_read_byte(int addr)
> > > +static unsigned char ppc_nvram_read_byte(int addr)
> > > {
> > > 	if (ppc_md.nvram_read_val)
> > > 		return ppc_md.nvram_read_val(addr);
> > > 	return 0xff;
> > > }
> > > -EXPORT_SYMBOL(nvram_read_byte);
> > > 
> > > -void nvram_write_byte(unsigned char val, int addr)
> > > +static void ppc_nvram_write_byte(unsigned char val, int addr)
> > > {
> > > 	if (ppc_md.nvram_write_val)
> > > 		ppc_md.nvram_write_val(addr, val);
> > > }
> > > -EXPORT_SYMBOL(nvram_write_byte);
> > > 
> > > static ssize_t ppc_nvram_get_size(void)
> > > {
> > > @@ -182,6 +180,8 @@ static long ppc_nvram_sync(void)
> > > }
> > > 
> > > const struct nvram_ops arch_nvram_ops = {
> > > +	.read_byte      = ppc_nvram_read_byte,
> > > +	.write_byte     = ppc_nvram_write_byte,
> > > 	.get_size       = ppc_nvram_get_size,
> > > 	.sync           = ppc_nvram_sync,
> > > };
> > > diff --git a/drivers/char/generic_nvram.c b/drivers/char/generic_nvram.c
> > > index f32d5663de95..41b76bf9614e 100644
> > > --- a/drivers/char/generic_nvram.c
> > > +++ b/drivers/char/generic_nvram.c
> > > @@ -48,7 +48,7 @@ static ssize_t read_nvram(struct file *file, char __user
> > > *buf,
> > > 	if (*ppos >= nvram_len)
> > > 		return 0;
> > > 	for (i = *ppos; count > 0 && i < nvram_len; ++i, ++p, --count)
> > > -		if (__put_user(nvram_read_byte(i), p))
> > > +		if (__put_user(arch_nvram_ops.read_byte(i), p))
> > 
> > Instead of modifying all drivers (in this patch and previous ones related to
> > other arches), wouldn't it be better to add helpers like the following in
> > nvram.h:
> > 
> > Static inline unsigned char nvram_read_byte(int addr)
> > {
> >        return arch_nvram_ops.read_byte(addr);
> > }
> > 
> 
> Is there some benefit, or is that just personal taste?
> 
> Avoiding changes to call sites avoids code review, but I think 1) the 
> thinkpad_acpi changes have already been reviewed and 2) the fbdev changes 
> need review anyway.
> 
> Your suggesion would add several new entities and one extra layer of 
> indirection.
> 

Contrary to what I said above, this kind of double indirection could be 
useful if it allows us to avoid the kind of double indirection which Arnd 
objected to (which arises when an arch_nvram_ops method invokes a ppc_md 
method). For example,

static inline unsigned char nvram_read_byte(int addr)
{
#ifdef CONFIG_PPC
	return ppc_md.nvram_read_byte(addr);
#else
	return arch_nvram_ops.read_byte(addr);
#endif
}

I'll try this approach for v9 if there are no objections. It may be the 
least invasive approach. Also, arch_nvram_ops can remain const.

-- 

  parent reply	other threads:[~2019-01-05 23:06 UTC|newest]

Thread overview: 79+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2018-12-26  0:37 [PATCH v8 00/25] Re-use nvram module Finn Thain
2018-12-26  0:37 ` [PATCH v8 24/25] powerpc: Adopt nvram module for PPC64 Finn Thain
2018-12-29 22:36   ` Arnd Bergmann
2018-12-30  3:28     ` Finn Thain
2018-12-31 12:32       ` Arnd Bergmann
2019-01-01  1:38         ` Finn Thain
2019-01-04  8:45         ` Finn Thain
2019-01-06 23:36     ` Michael Ellerman
2019-01-07  4:52       ` Finn Thain
2019-01-08  9:27         ` Michael Ellerman
2019-01-08 22:51           ` Finn Thain
2018-12-26  0:37 ` [PATCH v8 07/25] char/nvram: Allow the set_checksum and initialize ioctls to be omitted Finn Thain
2018-12-26  0:37 ` [PATCH v8 22/25] powerpc: Remove CONFIG_GENERIC_NVRAM and adopt CONFIG_HAVE_ARCH_NVRAM_OPS Finn Thain
2019-01-03  8:05   ` Christoph Hellwig
2019-01-03 22:11     ` Finn Thain
2018-12-26  0:37 ` [PATCH v8 16/25] powerpc: Add missing ppc_md.nvram_size for CHRP and PowerMac Finn Thain
2018-12-26  0:37 ` [PATCH v8 03/25] m68k/atari: Replace nvram_{read,write}_byte with arch_nvram_ops Finn Thain
2018-12-26  0:37 ` [PATCH v8 11/25] m68k/mac: Use macros for RTC accesses not magic numbers Finn Thain
2018-12-26  0:37 ` [PATCH v8 02/25] m68k/atari: Move Atari-specific code out of drivers/char/nvram.c Finn Thain
2018-12-28 16:51   ` LEROY Christophe
2018-12-29  1:16     ` Finn Thain
2019-01-02 22:29       ` Finn Thain
2018-12-26  0:37 ` [PATCH v8 21/25] nvram: Drop nvram_* symbol exports and prototypes Finn Thain
2018-12-26  0:37 ` [PATCH v8 14/25] char/nvram: Add "devname:nvram" module alias Finn Thain
2018-12-26  0:37 ` [PATCH v8 08/25] char/nvram: Implement NVRAM read/write methods Finn Thain
2018-12-26  0:37 ` [PATCH v8 15/25] powerpc: Clean up nvram includes Finn Thain
2018-12-26  0:37 ` [PATCH v8 05/25] char/nvram: Adopt arch_nvram_ops Finn Thain
2019-01-03  8:02   ` Christoph Hellwig
2019-01-03 22:08     ` Finn Thain
2019-01-04 17:56       ` Christoph Hellwig
2019-01-04 22:05         ` Finn Thain
2018-12-26  0:37 ` [PATCH v8 25/25] powerpc: Remove pmac_xpram_{read,write} functions Finn Thain
2018-12-26  0:37 ` [PATCH v8 06/25] x86/thinkpad_acpi: Use arch_nvram_ops methods instead of nvram_read_byte() and nvram_write_byte() Finn Thain
2018-12-26  0:37 ` [PATCH v8 12/25] m68k/mac: Fix PRAM accessors Finn Thain
2018-12-26  0:37 ` [PATCH v8 18/25] powerpc: Implement nvram sync ioctl Finn Thain
2018-12-29 22:19   ` Arnd Bergmann
2018-12-30  7:25     ` Finn Thain
2018-12-30 23:13       ` Finn Thain
2018-12-31 12:17         ` Arnd Bergmann
2018-12-31 12:16       ` Arnd Bergmann
2019-01-01  1:06         ` Finn Thain
2019-01-02 22:25           ` Finn Thain
2018-12-26  0:37 ` [PATCH v8 23/25] char/generic_nvram: Remove as unused Finn Thain
2018-12-26  0:37 ` [PATCH v8 10/25] m68k/mac: Adopt naming and calling conventions for PRAM routines Finn Thain
2018-12-26  0:37 ` [PATCH v8 09/25] m68k/atari: Implement arch_nvram_ops methods and enable CONFIG_HAVE_ARCH_NVRAM_OPS Finn Thain
2018-12-26  0:37 ` [PATCH v8 17/25] powerpc: Implement arch_nvram_ops.get_size() and remove old nvram_* exports Finn Thain
2018-12-26  0:37 ` [PATCH v8 04/25] char/nvram: Re-order functions to remove forward declarations and #ifdefs Finn Thain
2018-12-26  0:37 ` [PATCH v8 13/25] m68k: Dispatch nvram_ops calls to Atari or Mac functions Finn Thain
2018-12-29 22:27   ` Arnd Bergmann
2018-12-30  7:26     ` Finn Thain
2018-12-30 17:53       ` LEROY Christophe
2018-12-30 22:12         ` Finn Thain
2018-12-31 12:19           ` Arnd Bergmann
2018-12-26  0:37 ` [PATCH v8 19/25] powerpc, fbdev: Use NV_CMODE and NV_VMODE only when CONFIG_PPC32 && CONFIG_PPC_PMAC && CONFIG_NVRAM Finn Thain
2018-12-26  0:37 ` [PATCH v8 20/25] powerpc, fbdev: Use arch_nvram_ops methods instead of nvram_read_byte() and nvram_write_byte() Finn Thain
2018-12-29 17:02   ` LEROY Christophe
2018-12-29 23:43     ` Finn Thain
2018-12-31 12:29       ` Arnd Bergmann
2019-01-01  1:10         ` Finn Thain
2019-01-05 23:06       ` Finn Thain [this message]
2018-12-26  0:37 ` [PATCH v8 01/25] scsi/atari_scsi: Don't select CONFIG_NVRAM Finn Thain
2018-12-28 16:38   ` LEROY Christophe
2018-12-29  1:06     ` Finn Thain
2018-12-29  1:33       ` Michael Schmitz
2018-12-29  2:34         ` Finn Thain
2018-12-29  2:50           ` Michael Schmitz
2018-12-29 21:37             ` Arnd Bergmann
2018-12-30 17:50               ` LEROY Christophe
2018-12-30 18:06                 ` James Bottomley
2018-12-30 21:44                   ` Finn Thain
2018-12-30 22:45                     ` Finn Thain
2018-12-29 16:55         ` LEROY Christophe
2018-12-29 18:54           ` Michael Schmitz
2018-12-29  2:54   ` Michael Schmitz
2018-12-29 22:45 ` [PATCH v8 00/25] Re-use nvram module Arnd Bergmann
2018-12-30  0:09   ` Finn Thain
2018-12-30  4:05     ` Finn Thain
2018-12-31 12:22       ` Arnd Bergmann
2018-12-31 22:54       ` Finn Thain

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LNX.2.21.1901060931140.23@nippy.intranet \
    --to=fthain@telegraphics.com.au \
    --cc=arnd@arndb.de \
    --cc=b.zolnierkie@samsung.com \
    --cc=benh@kernel.crashing.org \
    --cc=christophe.leroy@c-s.fr \
    --cc=dri-devel@lists.freedesktop.org \
    --cc=gregkh@linuxfoundation.org \
    --cc=linux-fbdev@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-m68k@lists.linux-m68k.org \
    --cc=linuxppc-dev@lists.ozlabs.org \
    --cc=mpe@ellerman.id.au \
    --cc=paulus@samba.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox;
as well as URLs for NNTP newsgroup(s).